Welcome! Log In Create A New Profile


Isaac Mendel build

Posted by jkelso 
Re: Isaac Mendel build
October 24, 2010 12:07PM
Since last night I've applied 4 or 5 coats of fire cement. First I wrapped the nichrome wire down to the bottom of the barrel, cemented it, let dry, then wrapped the wire back up to the top and cemented it again. The resistance is measuring in the 6 ohm range and I'm getting ready to cut some copper pipe to fit over this. I'd still like to tape the thermistor to the outside of the copper pipe in case there's more trouble with it I can take it out of there easily.

Re: Isaac Mendel build
October 24, 2010 02:53PM
I cut a length of copper tube to fit the nozzle and I tried slipping it over the fire cement, shaving off part of the sides. Doing this exposed one of the wires to the tube which resulted in a measurement of less than 1 ohm so I taped over the cement with kapton tape before putting on the tube. I also filed grooves in the top to fit around the wires at the top and again taped over the tube and the wires with kapton tape. I'm still getting a good reading and I think this looks like it could work this time.

Re: Isaac Mendel build
October 24, 2010 04:20PM
It appears everything is working great this time, the nozzle is heating, the connections are are stable and I'm going to bolt it up.
Re: Isaac Mendel build
October 24, 2010 06:11PM
Since bolting everything back on, I've been having a problem turning off the heat. It seems to want to keep ramping up, at times it seems to be going down and then I check it again and it's going up. I'd like to turn the heat completely off while making adjustments but it's not letting me. I've been toying with the extruder bolts for over an hour but I can't seem to get the Z axis to travel all the way back and forth. It wants to catch near the middle and just stay there as the motor keeps trying to pull it. I'm wondering if lubricant would help, I've loosened and tightened those bolts over and over and I'm not getting any result. I also loosened the bolts holding in the bearings slightly to make sure they are not restricted this way.
Re: Isaac Mendel build
October 24, 2010 08:43PM

Can you tell me where you purchased those black steppers you have? Also the part# on them?
Re: Isaac Mendel build
October 24, 2010 09:22PM
I'm wondering if there is some problem with the electronics now, I haven't had this problem before of not being able to control the ramping of the heat. I'm thinking that the solution could be to implement a new system that would independently control heat to the extruder without using the extruder board to do this. [www.auberins.com]
I got this from danielg
Re: Isaac Mendel build
October 25, 2010 06:31AM
you may have blown the mosfet that controls the heater. I did this on my techzone electronics. I just moved the heater to the next set of outputs and change the pin used for the heater in the firmware. If this is your problem, you will probably see that the LED for the heater is permanently on.
Re: Isaac Mendel build
October 25, 2010 09:44AM
yes it is on permanently, I will try doing this thank you G. Frost.
dunno why I didn't think of it myself....
any clue what the line of code looks like that assigns the pin number?
Re: Isaac Mendel build
October 25, 2010 02:01PM
I went into the arduino extruder firmware and found the setting I needed to change the mosfet under the configuration h tab. From there I switched the heated bed and heater numbers around, one was 11 and one was 12. That worked to set the heater controls to the B +/- terminals and now I am able to ramp the heat and turn it off. From here I just need to play with my extruder carriage bolts and belt tension until I can get the X axis moving freely and I should be ready to give it a try.
Re: Isaac Mendel build
October 25, 2010 04:32PM
After many frustrating hours of toying with bolt tightening and loosening I finally went out and grabbed a quart of motor oil from my vehicle and just used my finger to drip it all over the bearings and rods. At first it didn't seem to work but I tried it again about 15 minutes later and now my carriage travels freely without grinding to any stops. I'm going to now work on adjusting the Y platform so that everything is level and it meets up closely with the extruder tip.
Re: Isaac Mendel build
October 25, 2010 05:54PM
I've now got the nozzle adjusted to just a small gap above the bed and it seems to be level all around, but when the X axis travels all the way to 150 I get a constriction because the wires aren't long enough. I just need to file a gap in the wood down to one of the holes and the wires should be just perfect with that extra length. After that I'm going to do a test print without filament.

Re: Isaac Mendel build
October 25, 2010 06:04PM
Petroleum oil might melt your plastic parts. Be careful.

Lithium or PTFE grease (non petroleum based) appears to be the most recommended.
Re: Isaac Mendel build
October 25, 2010 07:11PM
Ok thanks. Now as I'm trying to do a test print I think I may have found a new problem. When I press Home for the Z axis it moves down until the opto stop reaches the inside of the end stop and then it stops and centers itself within that space. However, my other axis do not do this. When I press home on the X axis it goes all the way into the end stop and then the motor keeps trying to turn. Eventually it stops grinding and sets Home as 0 at the current position. From there it works fine. However, when I press home on the Y axis the platform moves the opposite way from the endstop and goes to the end and keeps trying to go for a while, grinding. I have green lights on all the endstop connectors but the green light only goes out for the Z axis properly when the end stop hits it. I'm going to try and reverse the stepper motor wires for the Y axis and see if that improves anything.
Re: Isaac Mendel build
October 25, 2010 08:14PM
If an axis is going away from an endstop when you're homing the axis, you need to either reverse the motor wires, or change the firmware to invert that axis.

Check with some other material (eg: dark cardboard) that when you block the endstop that the light on it goes out.
Re: Isaac Mendel build
October 25, 2010 09:53PM
I've reversed the stepper motor wires red/blue switched with blk/grn and this solved the problem of the axis going in the wrong direction. Right now I'm ramping up the heater and trying to get the machine to go through the motions of printing an .stl file I got off thingiverse of a web. So far I've been having problems with the connection going bad, which is usually solved by either restarting the software or restarting the computer. I've had much better luck with restarting the computer when things go bad than with anything else. Also, when I push the Ramp button to heat the nozzle it seems like nothing happens for a while, then after a minute I can see the green LED flicker on slowly and then the nozzle begins to heat. It's not right away and for some time I thought that the mosfet may have gone bad again but it just takes a while. When I insert black electrical tape into the Y endstop the light never goes out. Also, the 2 driver boards which don't have responsive opto end stops have red lights on them while the working one does not have any red lights on.
Re: Isaac Mendel build
October 25, 2010 10:57PM
My machine is doing the dance! I think I may want to make another adjustment to the Y platform level and actually put some filament in there and see what happens. It's pretty cool seeing and hearing what it sounds like printing a part for the first time. SWEET. For a while it didn't seem like it was reading the G code I created from the STL file but I waited and suddenly the machine came to life. I'd like to disable the opto endstops because 2 of them don't seem to work but I'm unsure of exactly how to do this in the firmware. Any hints on this?

Edited 1 time(s). Last edit at 10/25/2010 11:03PM by jkelso.
Re: Isaac Mendel build
October 25, 2010 11:09PM
AWSOME! You should try to fix those optos though. unless you want you constantly need to remember to remove the "home" commands out of everything...
Re: Isaac Mendel build
October 25, 2010 11:52PM
I am thinking that if I can get one working then I can check the other switches by testing them on the driver board that is working. From there I can isolate either the wires, the board, or the switch as the problem. My guess is that the wires need to be remade to switch the polarity. Hopefully I can fix it without replacing any hardware. I've been working all night on this so I think I'll pick it back up tomorrow.
Re: Isaac Mendel build
October 25, 2010 11:55PM
Be VERY VERY VERY careful when checking them... You can destroy them or possibly a regulator on the driver board if you connect the polarity in reverse! double triple check the connection!
Re: Isaac Mendel build
October 26, 2010 09:53AM
I may be sending switches back to techzone

Edited 1 time(s). Last edit at 10/26/2010 02:09PM by jkelso.
Re: Isaac Mendel build
October 26, 2010 02:06PM
After removing the faulty end stops I plugged them each into the wiring for the known working switch. When the endstop goes through the good switch the green light goes out, but when it goes through the other 2 switches the green light stays on. So it's either a problem with the switches or the boards attached to the bottom of the switches. I guess I can try sending them back to techzone but I am also going to look around for some to purchase in the next few days.

Edited 1 time(s). Last edit at 10/26/2010 02:07PM by jkelso.
Re: Isaac Mendel build
October 26, 2010 04:56PM
Lambert Andrus states through email that he will send some out to me free of charge. Sounds pretty good to me.
Re: Isaac Mendel build
October 26, 2010 08:35PM
Great news. Plastics soon smiling smiley
Re: Isaac Mendel build
October 29, 2010 06:37PM
I got the opto switches in the mail today and I've installed them and they're working great. In trying to force the bolt with a nut spaced a certain gap over the plastic block I managed to break off a part of the plastic that holds the bolt in there. So I improvised a piece of metal and put 2 bolts through it and it holds on just as good. Now with all opto switches working and tested I've got the problem of the X axis grinding to a halt about halfway. I'm going to try greasing them again and adjusting. I think one of the first things I'll want to print is a new X carriage assembly, it may have been warped by the heat from the nozzle one time. I had this working a few days ago, I'm hoping it just needs a little oil. I'm about to leave for a movie and may not be printing until tomorrow.
Re: Isaac Mendel build
October 30, 2010 08:01PM
I've been doing some last minute details. The extruder always moved the wrong way so I switched the wires and now it moves correctly. However, during several tries the extruder continued moving in the wrong direction. After restarting the computer and the software the problem goes away. Then suddenly the problem happens again. Trying to get this reprap working has been a constant struggle of the software freezing and having to restart either the software or the computer. After many adjustments to the bed height and the bearing cap on the extruder I could finally get a smooth extrusion after getting the temp up to around 250 C. After finally getting all the elements working right, I load the gcode and wait for about 5 minutes, the timer seems to count for a long time and then finally the machine tries to print. I'm right now going to retry because I've adjusted the bed height to right below the nozzle but so far I've got nothing at all coming out of the extruder that is sticking to the surface. I'm hoping the height adjustment will start grabbing the plastic and smearing it on there. I'm not sure exactly what temps I need to be at for a smooth extrusion but so far it doesn't seem to come out easily at all until around 240C. The software or something is very buggy and I'm considering trying it out on my Win 7 machine instead of this old XP machine I've been using. Not sure if it's a computer thing or the memory or the software causing all the crashes. Still hoping to print something soon...
Re: Isaac Mendel build
October 30, 2010 10:05PM
After many tries of testing I've found there is a system to getting the software to work. When I start it up I immediately go to the extruder tab to see if there is a temp reading. When I start getting problems with getting a reading after several software restarts I have to restart the computer. Then, I start the reprap software. It never works on the first try, always on the 2nd try after restarting the computer. Then, I've figured out that I need to get the temp to about 250C or more before I'm getting a good extrusion. But trying to adjust this number to 250C from the extruder tab where it says Target Temp does not work to print. I found out I needed to go into the preferences and modify the extrusion temp under the extruder 0 tab from 190 to 270C. Whenever I would ramp the heat to 250C then try to print the machine waits for it to cool down then begins the print at 190C. By then it's too cold to extrude. I'm hoping this could be progress, I'm going to give it another try...

Edited 2 time(s). Last edit at 10/30/2010 10:06PM by jkelso.
Re: Isaac Mendel build
October 30, 2010 10:48PM
When I got the heat up to 260C I tried printing. I tested the extruder and was getting a good extrusion. However, when I went to print nothing came out again. I could see that something was wrong so I checked the temp again and it went back down to 170C. I went back to preferences and also changed the extrusion size to .5 instead of .7 and the speed to 1500mm/min. I'm going to ramp it again and try again.
Re: Isaac Mendel build
October 30, 2010 11:04PM
One more try, the heat was up to 260C, I started a print, it waited for several minutes then began going through the motions of a print but nothing coming out of the nozzle. I went back to the extruder tab and the temp is still showing 260C. Then I hit stop on the print, adjust the Z axis up, and go back to the extruder tab and suddenly the temp is showing at 190C again. 2nd time this happened. I double checked my preferences and the extrusion temp is still at 270 C. I'm going to try it again.
Re: Isaac Mendel build
October 30, 2010 11:48PM
Have you tried repsnapper? if not you really should..... the reg host made me nutz as well...
Re: Isaac Mendel build
October 31, 2010 12:12AM
This time I decided that the problem may have been that I needed to save the gcode with the right temp preferences. I used a simple cube shape and converted the stl file and this time it sort of worked. The cube shape was starting to take form except that it is printing out hollow. I found a blog through youtube by jlkeegan that explained this problem. I'm planning to add some more extruder profiles and work on the settings some more and see what happens tomorrow. I took away the other 2 extruder profiles and kept only 1 of them, I'm hearing this is not the correct procedure.
Sorry, only registered users may post in this forum.

Click here to login