Re: Isaac Mendel build
September 20, 2010 06:42AM
I get similar errors if I forget to tell it to use an Arduino Mega and set 'motherboard' to 3. Make the appropriate settings and, if needed, install the sanguino files before trying to compile.
Re: Isaac Mendel build
September 20, 2010 12:00PM
I started another thread concerning this subject "can't access configuration.h file" because I ran into problems after downloading the mendel fived_gcode_interpreter file and having my folder settings set to "hide known file types". I got some advice on that thread and switched the setting and now I can see the configuration.h tab because the file had been renamed to configuration.h and I couldn't see that it already had a .h on there because of the folder setting. I think this could be a major stumbling block for a person trying to set this up for the first time. I have never updated the wiki, I'm not sure I know how or if I have access to it but it should be noted right there next to the download link to set folder settings to uncheck "hide known file types" or you will have a problem.
Re: Isaac Mendel build
September 20, 2010 03:32PM
Spent some time outside today and I've made a new place for Ra close to my computer so that I can continue with the software configuration and uploading. This will be Ra's new home and I can clean up the work area and think about preparing to build another one in the coming months. I plan on building the spool feeder that mounts on top from the files provided on thingiverse.
Re: Isaac Mendel build
September 20, 2010 05:07PM
I guess I need to install the sanguino files to the arduino software. Not sure how to do that. I defined the motherboard as 2 and the extruder count as 0 (this is interpreted as 1 by the software?) I went down the list and where it says to "comment out" the next line using a mendel I went in and deleted the next line of code. Not sure if this is correct. I couldn't get it to compile. I am using Arduino Mega as the board there is no option in there for sanguino.

Edited 1 time(s). Last edit at 09/20/2010 05:44PM by jkelso.
Re: Isaac Mendel build
September 20, 2010 05:41PM
Comment with a pair of forward slashes as seen throughout the file. It shouldn't make a difference, but its easier to remove a comment marker than to look up what was originally in the file.

As for sanguino, follow the instructions on setting up Sanguino here:
[reprap.org] .

Not sure why you set extruders to 0. This may cause problems. The first extruder is designated zero, but thats because of the way programmers think about storing lists of data, the number of items in the list is still counted normally.

Edited 1 time(s). Last edit at 09/20/2010 05:54PM by Andrew Smith.
Re: Isaac Mendel build
September 20, 2010 05:51PM
Thank you, I got the sanguino option in there now. I'm using a thermocouple sensor but still not sure of what the setting needs to be for that. I'm going to make some guesses and try to compile it again. Is there a wiki page for doing this?
Re: Isaac Mendel build
September 20, 2010 05:58PM
OK I'm understanding the concept of "uncommenting" now...meaning to remove the two forward slashes from one line and add them to another in order to change the code to a comment. But, I'm not sure if I should be messing with this where it says "these settings are mainly for darwin" ? "mainly" sounds like possibly not. I don't see any other area where this code is presented so I guess this is the place. Is the extuder count supposed to be 0 for one extruder?

I'm guessing that these stepper boards are version2.x or higher so I'm setting the Invert_enable_pins to 1

I changed the things I think needed changed and did get the software to successfully upload to the board now. Next I'm going to get the usb to ttl cable and do this with the extruder board.

Edited 3 time(s). Last edit at 09/20/2010 06:08PM by jkelso.
Re: Isaac Mendel build
September 20, 2010 06:17PM
You have:


#define MOTHERBOARD 2
...
#if MOTHERBOARD == 1
...
#define AD595_THERMOCOUPLE      <<<<< This is ignored

To fix, copy the thermocouple line somewhere after #if MOTHERBOARD == 2

#if MOTHERBOARD == 2
...
#define AD595_THERMOCOUPLE
Re: Isaac Mendel build
September 20, 2010 06:17PM
Set extruder count to one.

The 'mainly for darwin' part refers to the settings for motherboard == 1 - everything from the 'if motherboard == 1' line to the '#endif' line is only compiled when motherboard is set to 1. You want to be playing with the settings in the next section down.

This really should be indented and commented better for non-coders, we can't count on newbie reprappers to know what a C++ comment looks like or understand what the preprocessor statements are doing. Anyway, within motherboard == 2, don't mess with anything marked *RO and you should be fairly safe. The settings in that section are chosen to suit the standard reprap setup, so you shouldn't need to make any changes, but have a look through them to see what you can change if the machine doesn't behave as you expect it to.
Re: Isaac Mendel build
September 20, 2010 06:24PM
There's talk on the developer list of completely dumping the MOTHERBOARD define. That will be a change for the better. It would also be nice to dump all of the tuning-related defines and turn them into M codes.
Re: Isaac Mendel build
September 20, 2010 06:25PM
Thanks again guys and I have to agree that someone without any experience in java might be tempted to give up at this point if not for the helpful forum. I'm going to re-upload it again with the changes.
Re: Isaac Mendel build
September 20, 2010 06:47PM
OK so I'm trying to compile the exruder pde . I didn't make many changes except to define the thermocouple. But, when I go to compile this, I get this message:
Re: Isaac Mendel build
September 20, 2010 07:03PM
I don't have a thermistor wrapped up against the extruder nozzle, only the k-type thermocouple wire twisted together at the end and wrapped around there with fire cement. So now I'm trying to figure out which thermistor code to insert in there but I don't know because I'm not using a thermistor. Am I right on this or ?? I think I'm lost again, I'm looking at the wiki page for "thermistor" but have no idea how to alter the code so it will compile properly.
Re: Isaac Mendel build
September 20, 2010 07:04PM
Now you have a problem. If you look in temperature.h, you'll see that NUMTEMPS is defined within

#ifdef USE_THERMISTOR

which is undefined because you have defined AD595-THERMOCOUPLE instead. Theres no equivalent section within temperature.h. I'm not sure how this is meant to work.

Theres a thread (http://forums.reprap.org/read.php?146,59666) in the firmware forum which contains a solution to this problem, and the discussion indicates that this will be fixed in the official release shortly.
Re: Isaac Mendel build
September 20, 2010 07:33PM
OK I got the extruder file from danielg on the forum and it compiled fine, but now I can't get the program to upload to the extruder board. I have the green wire on the usb to ttl cable towards the bottom and I plugged the cable back into the COM1 slot but nothing. I tried switching the com port but it didn't help. I also checked to make sure I'm using Diecimilia
Re: Isaac Mendel build
September 20, 2010 07:36PM
As I sat looking at the error message I could hear something making a noise and I saw 3 lights on the extruder which hadn't come on before. I checked the nozzle and it felt hot so I'm thinking I may have the board working already. I'm going to plug it all in....
Re: Isaac Mendel build
September 20, 2010 07:46PM
Which 3 lights? If it's the 3 next to the mosfets then the firmware hasn't been installed. Only 1 should turn on, but not until the temperature is set.
Re: Isaac Mendel build
September 20, 2010 07:54PM
Correct, I just checked it and it's not working so I'm guessing there was a problem back with trying to install the firmware....
Re: Isaac Mendel build
September 20, 2010 08:12PM
OK I think I've narrowed the problem to the fact that when I plug in a normal usb cable into the usb it shows up on the arduino software as com 4. When I plug the usb to ttl cable into the same port I only get options in the arduino software for com 1 or com 5, no com 4 any more.
Re: Isaac Mendel build
September 20, 2010 08:24PM
Well that wasn't it. I switched out the usb to ttl adapter and regular usb cable that was hooked to the motherboard for the other usb to ttl (with no circuit board) cable and it changed from com 5 to com 4 but still the same error message and I can't upload it. I went to the arduino forum but could not find the answer there.
Re: Isaac Mendel build
September 20, 2010 08:46PM
Ive seen mention of a bug which requires you to press the reset button while uploading. Naturally I can't find the post right now, but it is mentioned in the wiki. It was supposedly fixed on the version 2.2 extruder boards.
Re: Isaac Mendel build
September 20, 2010 09:12PM
I tried that, holding the button for a long time while it tried uploading, then I tried pressing it at different intervals but still came up with the same message "problem uploading to board" I have a version 2.2 extruder board. I switched the cable for a known working cable but still no luck.

Edited 2 time(s). Last edit at 09/20/2010 09:29PM by jkelso.
Re: Isaac Mendel build
September 20, 2010 09:31PM
Google the 'stk500_getsync' error messages, you should come across some threads which discuss various solutions. I can't see anything that looks like The Answer, but there are a lot of suggestions out there.
Re: Isaac Mendel build
September 20, 2010 09:52PM
I did that earlier and browsed through the answers but didn't see anything that helped there. Now that my motherboard is programmed I should be able to control my stepper motors through the reprap console but I tried doing that according to the wiki and nothing happened, no blinking lights or anything. I was able to control them using the cupcake drivers and replicatorG software but since uploading the reprap software I've had no luck with it.
Re: Isaac Mendel build
September 20, 2010 10:10PM
I looked through the forums and tried adjusting the baud rate in com preferences, I tried all different methods of pushing the reset button and holding it. I tried disconnecting any other wires connected to the board...still nothing works yet.
Re: Isaac Mendel build
September 20, 2010 10:16PM
i had the two button problem and in viktors words: ... i have te same 'manual syncing' with the Arduino Pro Mini and the Boarduino - i press the reset-button shortly when the compiled size is shown and it uploads fine ... the Arduino Mega does this syncing automatically ...

Viktor


which also was my problem
Re: Isaac Mendel build
September 20, 2010 10:45PM
I have 2 usb cables, one goes to a circuit board with a usb to ttl adapter, one is a usb to ttl cable with no board. The cable with no circuit board will not upload anything to the motherboard so I'm guessing that there is some problem with it. However, I removed the cable with the circuit board which goes from the adapter to the ttl pins on the motherboard and connected it to the extruder board ttl pins and got a flashing light but still the same problem not being able to upload anything with that same error message. I tried burning a bootloader but got the message that there was a problem communicating.
Re: Isaac Mendel build
September 20, 2010 10:50PM
HOly MACKEREL! I tried it one more time pushing the reset button with the known good cable and got it to upload!!
Re: Isaac Mendel build
September 20, 2010 11:08PM
Unfortunately I still can get no response trying to move the steppers with the reprap console. I'm trying to nudge the Y by 10mm but nothing. I don't have the z axis stepper hooked to the driver yet but this shouldn't matter, I had it working once before in replicator G using cupcake drivers.
Re: Isaac Mendel build
September 20, 2010 11:25PM
I went to the wiki on "testing a motherboard" and tried selecting Comm debug "true" option but nothing happened. I hit create but still nothing. How do I update the preferences?
Sorry, only registered users may post in this forum.

Click here to login