Welcome! Log In Create A New Profile

Advanced

Heacent Prusa i3 with problems

Posted by aadkoene 
Heacent Prusa i3 with problems
March 01, 2016 04:39AM
Hi Ev'ryone, I've recently ordered a Heacent Prusa i3 kit and build it.

The Prusa i3 has a Bowden Extruder and the board is a Melzi Ardentissimo ( a 1.0/2.0 Ebay version).

Besides a wrong switch, no stop- but an on/off-switch the build is complete.

The problems I'm heading to are:
- the stopswitchs only stops and don't stop and park
- the Z-axle motors are moving the wrong way
- the Extrudermotor is moving the wrong way
- my laptop doesn't connect with the printer (Siemens Lifebook C with Win10), my son's laptop can connect but can't set Zero-points and Middle-startpoint (Allianware i5)

Are there any ideas to solve this, apart from bying an other one?

Thanks in advance,

Aad.
Re: Heacent Prusa i3 with problems
March 01, 2016 05:29AM
Motors that run the wrong way: turn the motor connector 180* on the board, while there is no power on the board!
No idea what you mean by "stop and park"
Did you install the drivers for the board?
Re: Heacent Prusa i3 with problems
March 01, 2016 05:44AM
Hi Frans,

thanks for the quick answer.

There are no connectors on the board, just connectorpoints (see photo).
The firmware is pre-installed Marlin, Sanquino compatible.

With "Stop and park" i mean that when the x, y and z-parts reach the stopswith the motor will stop and thakes a few steps back untill the stop-swich is released.

Aad. (Gouda)
Attachments:
open | download - 12767379_1079298145468450_544770411_n.jpg (101.6 KB)
Re: Heacent Prusa i3 with problems
March 01, 2016 07:22AM
If you take the motor wires and just invert them then the motor will turn the other way. So for those motors in reverse and wired like red,blue,green,black you change them to black,green,blue,red.

There also might be setting in the firmware to change the default DIR setting but I find swapping the wires easier.

The missing endstop bounce I don't know. What I understand is that it will hit the endstop with a certain speed and then moves away from the endstop to release it and then again try to trigger it with a slower speed, doing that a few times will allow the software to make a very precise measurement of the endstop position.

Edited 1 time(s). Last edit at 03/01/2016 07:31AM by [email protected]
Re: Heacent Prusa i3 with problems
March 01, 2016 02:20PM
Hi Frans,

I've inverted the wires of one motor, for testing, and it worked as you told.
And the result was better then you told because the "Stop-and-Park" worked suddenly too for that axle.

I replaced the broken switch and all the motors are switched now.

The printer works !!!!!

Thanks for that.

Aad Koene.
Re: Heacent Prusa i3 with problems
March 01, 2016 07:03PM
Re: Heacent Prusa i3 with problems
March 01, 2016 11:22PM
And you win10 connects?


Replikeo Prusa I3 Rework, Ramps 1.4, Marlin, Pronterface, Tinkercad.
Plan B is always to be somebody else.
Re: Heacent Prusa i3 with problems
March 02, 2016 03:35AM
Hi Giantkiller,

the Prusa i3 works on the laptop of my son (Allienware i5) but still not on my laptop (Siemens Lifebook C).

I can't get my finger on the problem:

- Pronterface gives an error:
Connecting...
[ERROR] Could not connect to COM4 at baudrate 115200:
Serial error: could not open port COM4: [Error 5] Toegang geweigerd.

- Cura said: "opening serial port" and ending up doing nothing

Looking for clues on the WWW i found some issues about Win10 and a non guinine FTDI-chip.( [hackaday.com])
Well i have that non guinine chip.

So that could be the cause of the problem.

No problem at all, i thought. I've a spare Siemens Lifebook C, give it a fresh Win7 install and start from scrath.
Wrong again, the Prusa won't print.

That's the point where i stopped last night ( 2 o'clock).

Later on this morning i will try a fresh install of WinXP but after that i'm running out of options.

If anyone knows the solution .... be my Hero.

Aad.
Re: Heacent Prusa i3 with problems
March 03, 2016 07:18PM
The USB 3.1 is the problem. If XP works then great. You still are going to need the correct drivers and I think this could cobble up the connection thing.
Go into control panel settings to get to the device manager. If your list doesn't change when you plug in then you know you still have the USB driver problem.
The left side of my Asus was 3.1 and the right side was 3.0. This was my only saving grace others wise I would be hunting down some kind of fix that I don't think exists, in regards to Marlin and atmega hardware.
Re: Heacent Prusa i3 with problems
March 07, 2016 08:59AM
Hi Giantkiller,

thank for the answer. My own laptop(Siemens LifebookC) has USB2.0 ports and My son's laptop(Alienware i5) has USB3.1.
The Prusa i3 works on his and not on mine, but i have an extended USB3.0 for my laptop.
So i will look that one up and connect it and see what it will do for me.

I will inform you about that.

Regards,

Aad Koene.

Ohh: BTW XP didn't work aswell .....

Edited 1 time(s). Last edit at 03/07/2016 08:59AM by aadkoene.
Re: Heacent Prusa i3 with problems
March 07, 2016 09:24AM
You mentioned the board is using a "fake" FTDI so did you try to load to old FTDI drivers?
Re: Heacent Prusa i3 with problems
March 07, 2016 10:29AM
Yep Frans,

I did and it didn't work out

Aad.
Re: Heacent Prusa i3 with problems
March 07, 2016 10:41AM
Quote
aadkoene
I did and it didn't work out.
You also replaced the Universal Serial Bus controllers driver? Did you compare the driver versions on your pc and your son's?
Re: Heacent Prusa i3 with problems
March 07, 2016 11:44AM
Quote
[email protected]
Quote
aadkoene
I did and it didn't work out.
You also replaced the Universal Serial Bus controllers driver? Did you compare the driver versions on your pc and your son's?

I think that it also has to do with the Operating system.
Re: Heacent Prusa i3 with problems
March 07, 2016 06:37PM
Hi Guys,

I think that to Giantkiller.

Actions so far today (the clock says: Yesterday .....):
-compare FTDI drivers: i have 2.12.14.0, my son has 2.10.0.0
-changed to 2.10.0.0 --> no results
-changed back --> no results
-read a shitload of pages and forums and found a lot of stuff about the rollback to 2.8.30.0
-changed to 2.8.30.0 --> no results

So ... history untill now:
- Alianware i5, Win10 64b --> works fine
- Lifebook C, Win10 64b --> NOT
- Lifebook C, Win10 32b --> NOT
- Lifebook C, Win7 64b --> NOT
- Lifebook C, Win7 32b --> NOT
- HP Compac 6730b, Win10 64b --> NOT

I'm out of options in the "no costs" sector ......

Options in the expensive sector:
-change the Artmega 1284 FTDI chip, costs about 10,00 euro BUT have no tools to do that
-change Melzi print, costs about 100,00 euro
-change from a Melzi print to Ramps 1.4, costs 50,00 euro BUT don't know what kind of trouble i am heading off
-change my laptop to a ....... ooh no, not an option at all!!!

Has anyone better options then mine??

Aad Koene.
Re: Heacent Prusa i3 with problems
March 07, 2016 07:12PM
Did you change both drivers? Euro 50,- for a ramps grinning smiley sure you did not placed the "," at the wrong position smiling bouncing smiley
Re: Heacent Prusa i3 with problems
March 07, 2016 07:23PM
If I understood correctly, your error is access denied. It is permission problem or some other program is using your serial port.

I found this with quick searching.
[www.equisys.com]

Good luck. I haven't really used Windows since Win 2000
Re: Heacent Prusa i3 with problems
March 07, 2016 07:27PM
Yep Frans,

i did both drivers (such a mistake is easy to make)

How do you mean the ", " in the wrong place ? Back- or Foreward?

Aad.
Re: Heacent Prusa i3 with problems
March 07, 2016 10:50PM
Changing the laptop would have to be to an older <= 3.0 USB hardware version.
I wonder if Aurduino folks will address this issue.
We are the few on the bleeding edge. But this will have to be addressed in the near future as printer prices drop and more abductees come on board with their newer pcs.
Re: Heacent Prusa i3 with problems
March 08, 2016 04:17AM
EUREKA !!!!

The printer WORKS !!!!

Vuokko didn't give the solution, but pointed the way to the solution.
Asking the system who was using an USB port didn't give any answers.

BUT ......

It brought me to the level of looking who is allowed by the Firewall (he decides who may communicate or not).
In the list i found a few that puzzles me why the where allowed to have access.

When i turned to the end of the list i saw items like: Sway, Twitter and Xbox.

I don't use that kind of stuff and closed them. (Sway, Twitter, Xbox and Xbox Game UI where closed)

For the test i opened Cura, loaded it with an item and start "connect" and "print"

And the Prusa started to print!!!!

Thanks guys for helping me !!!

The lucky one,

Aad.
Re: Heacent Prusa i3 with problems
March 08, 2016 06:35AM
Re: Heacent Prusa i3 with problems
March 08, 2016 01:56PM
I will have to check this out! My new Win10 box has XBOX on it.
The os reports Vista 6.02
Re: Heacent Prusa i3 with problems
March 08, 2016 08:25PM
Just for the record.

If printer doesn't work with one computer but works with another, the problem is in computer.

If there isn't serial port available, it is driver problem. Check with device manager.

If serial port exist but can't be opened, it is permission problem. Test for example putty (Terminal application) which usually gives reasonable error messages.

If serial port opens but machine doesn't do anything, open putty and paste for example G4 S5 to machine to dwell for five seconds. Or query for firmware or something.
If printer doesn't answer, serial port speed might be too fast. Try lower speed. This can be done by trying to run system with software which has serial console available.

If you get some propaganda from some IC manufacturer, it's driver problem.
Sorry, only registered users may post in this forum.

Click here to login