Welcome! Log In Create A New Profile


Newbie with various problems

Posted by Steamboat 
Newbie with various problems
April 06, 2016 09:53AM
Hi I got a reprap printer recently, not sure of make as I bought it as an abandoned kit and instructions were missing but I did find that the only one that seems to use the same circuit board is a 'Geeetech' but the frame is different to theirs, the first couple of prints went OK then the problems started.
First was prints not sticking to the bed glass so experimented with a lot of different bed temperatures, nozzle heights and cleaning it with various potions but no difference, have also tried an aluminium bed and Knapton tape but not much improvement and finally got working again on the glass bed but the edges/corners of things curl up quite frequently.
And I have now started having problems with the extruder head occasionally jumping to the left for no apparent reason, something like 10mm at times, it makes quite a noise when it does it and I thought the belt was slipping but tightening the belt seems to make it worse and the drive cog is tight on the motor shaft.
Any printing it does do now leaves gaps in the surface on the print bed and other layers, the extruder is also clicking a lot, I read on here that the clicking might be something to do with the the head gap but experimenting with it has not helped. I noticed the clicking appears to be less using 'Cura' for gcode but have tried several and seem to get best results with 'Slic3r'
I have read quite a bit on here about individual, similar sounding problems but nothing seems to be working for me.
Am using 1.75 PLA and a 0.4mm nozzle.
Any suggestions would be very welcome.
chinese prusa i3
April 07, 2016 02:11PM
hi every body. I am trying to get marlin to upload onto arduino 2560 mega board, 3 days so far. still unsucsesfull. any body out there has a profile for this printer I could upload I would be most greatfull stan. 70 yrs old and new to printingstanley.barnett1@gmail.com
Re: Newbie with various problems
April 07, 2016 04:43PM

Post some photos of your printer so people on the forums can try to figure out what you are working with. Have you uploaded in new firmware in order to calibrate the extruder steps per mm as well as the X, Y, and Z axis? I believe 50-60 degrees is the ideal bed temperature for printing PLA onto clean glass. But you also need to adjust that temperature for the actual temperature of the glass, not necessarily the temperature of the thermostat on the heated bed. The hot end for PLA is anywhere from 185 to 220 depending on the filament and you should measure it in a few places to ensure it is consistently between 1.74 to 1.76mm in width. Deviating beyond that is likely crap filament.

The extruder motor clicking is likely from skipping steps or grinding of the filament because the temperature is too cold. Raise the temperature 5 degrees and see if it is any better. The filament not sticking to the bed might be caused from a poorly calibrated bed height. You want to make sure a cold nozzle is roughly a thick piece of paper from the bed surface when Z=0. The paper should just catch under the nozzle, but not enough to move the nozzle.


Interesting your post is in the same thread (at least for me), but with a different subject line. Ideally the kit manufacturer should have provided you with a copy of firmware for your printer and/or instructions for uploading the firmware to the printer board. If not, you might try googling for Prusa i3 instructions. There should be some decent instructions available online the cover this.

If you want to load a fresh install of Marlin (v1.1.0-RC4?), you will need to download the code from Github, open the main *.ino file in the Arduino IDE and then copy the settings from the configuration.h file from your kits firmware over to the configuration.h file you opened in the Arduino IDE. If you weren't provided this, hopefully the instructions you found online have a good starting point for modifying the default config file.

You will also need to download and install version 1.6.x of the Arduino IDE from their website. Once installed, plug in your printer board via the USB, at least in Windows you should get a message about which COM port the device defaulted too. Open up the Arduino IDE, look for a settings or configuration menu where you can set the COM port for your board and declare it as an Arduino Mega 1280/2560 (I think it is all one choice). You should then be able to save and compile the firmware to the board. If you have problems, you might need to install the 1.05 version of the Arduino IDE instead.
Various probs
April 08, 2016 03:58AM
Been doing some reading about firmware but not making much progress, I haven't found any info yet about uploading or calibrating that is incredibly basic, most of the stuff I have seen looses me in the first few paragraphs when they start on about arduino tools and language. It sounds like stantheman is a bit more advanced than me in this area.

I have tried various nozzle temps up to 200 C so far, I did think the glass surface wasn't getting anywhere near the set temperature so have turned the heater bed over (that was the only part that was assembled when I got it) and it's also why I tried aluminium instead of glass but it was no better though it did get a lot hotter, will have to get hold of a thermometer to set that, saw some info early on in this process that said the nozzle height should be set so it grips paper firmly, should the thick paper be gripped or able to be slid under.

Pics of printer and circuit board attached, the pic of the circuit board is taken from the geeetech prusa i3 wiki though it isn't identical as mine has some extra small circuit boards plugged in along the bottom, I couldn't get a clear pic of mine, I also got the build instructions I used from there. There is another pic of the back of the geeetech board on the site and it says 'GT2560' on it.
As you may spot, the filament reel holder is home made as the thing with it kept sticking.
I'm no expert but I am fairly sure this thing would not pass any UK electrical safety checks as it had an exposed metal link that was connected directly to mains live.

Edited 1 time(s). Last edit at 04/08/2016 03:59AM by Steamboat.
open | download - Circuitboard.jpg (33.9 KB)
open | download - P100681.JPG (158.9 KB)
Re: Various probs
April 08, 2016 09:35AM
Printer is definitely a Prusa i3, so using the instructions from the Geeetech website should work well for you. From the pictures I am assuming a composite wood board frame rather than an acyrlic? Might not hurt to go through the instructions line by line to ensure everything is put together correctly and facing the right direction.

The circuit board should be the same as the one you posted. It is designed so that the stepper motor drivers will plug into the board so that they can be easily replaced. Early on in the RepRap project, the drivers tended to break a lot, especially when unplugging the motors while current was applied. Your printer board just has the drivers plugged in and ready to use. There should be one board for each motor axis (X, Y, and Z) as well as one for the extruder motor (assuming a single extruder). The Z axis will have two motors plugged into (next to?) the stepper motor driver for the Z axis.

On the Geeetech website I clicked on one of the Prusa i3 kits they had for sale which included a link to their forums for downloading the firmware. They also had links on the forum page for walking you through installing the firmware on the board. It looked fairly detailed and easy to follow. Let us know what steps you are having problems with.

Once you are able to update and load the firmware, you will want to look for Triffid's Guide on the RepRap website for calibrating your printer.

As for the heated bed, you might try printing without it. PLA doesn't necessarily need a heated bed, just spray some hair spray or use a glue stick on the glass. Blue Painters Tape also works, but I find it a pain to line up edge-to-edge. The paper thickness doesn't matter too much, some people will use a 0.1mm feeler gauge to set their heights more precisely.

Hope that helps for the time being.
Re: Various probs
April 08, 2016 01:55PM
Thanks for all the info.
Yes it is a wooden frame, I did notice it flexing a bit when it was doing some energetic manoeuvres so glued it down to a board, I also squirted a bit of super glue into some of the joints as the bolt clamping method did not seem to be working too well in places.
I think I have double checked most of the build recently when things have not been going well and re-done the wiring a couple of times trying to tidy it up but it's still not a pretty sight.
Firstly, is there no chance of me using the firmware that it came with or is that likely to be the cause of the sideways jumps.
If not, the web page does not seem very explanatory on models, I think I have narrowed it down to two but not sure which of these I should use, firmware for I3X (GT2560) or Marlin-PI3_pro_B

I did read about blue painters tape but I'm not sure what it is so tried some ordinary automotive masking tape but it did not help, just had a lot of comments when I asked if we had any hair spray, apparently there are a lot of different ones, is it the lacquer hold type stuff.

And I thought getting to grips with CAD software was going to be the hard part of 3D printing!
Re: Newbie with various problems
April 09, 2016 08:47AM
I don't know if its just the camera angle or not, but that bed does not look like its any where near level. The spring on the right hand side looks to be far more compressed than the one on the left. Have you leveled the bed ?
Re: Newbie with various problems
April 09, 2016 10:29AM
It's very possibly not 'level' level, does that matter?
The extruder nozzle is the same distance from the glass sheet on the bed wherever it is positioned. The left front corner does have some extra washers on it as the top of the base looked to have been hit or dropped and was de-laminating a bit and it's the only corner without a wing-nut as one was missing, which might make the sides look unequal.
Re: Newbie with various problems
April 09, 2016 11:32PM
The firmware currently on your printer board has been compiled into machine code as part of the upload process. If EEPROM was enabled in the firmware then you can configure some settings on the board while it is running, using M500 to M503 commands to save and reload the EEPROM during the calibration.

However, in my limited experience, I think you would be better off in the long run learning how to upload a fresh copy of the firmware as well as tweaking the configuration.h file. It will often give you the opurtunity to explore Repetier Firmware (with a web configuration interface) over Marlin if you so choose. You might also decide to experiment with a test script on the RepRap website that flashes your LEDs and moves the motors back and forth to test that they all work correctly (and possibly diagnosis a mechanical cause for the jump you mentioned).

As for the firmware, I think I would choose the GT2560 firmware to start with.

And yes, the CAD software is the hard part about 3D printing. The hardware is hard, but it is a fun hard.
Re: Newbie with various problems
April 10, 2016 09:02AM
Didn't like the sound of "using M500 to M503 commands to save and reload the EEPROM during the calibration" so installed Arduino and got Marlin-Marlin_v1 firmware but have got stuck already, Arduino does not recognise the COM port the printer uses, when I select it Arduino says it is in use and it sometimes does not even list the COM port that device manager shows the printer on. I use Pronterface for checking movements etc. and it can always connect to the printer OK.
Re: Newbie with various problems
April 11, 2016 04:31PM
Its possible Pronterface has an active connection to the printer still when you are trying to connect to the COM port. If Pronterface is closed, try rebooting the computer and then reconnecting the board.
Re: Newbie with various problems
April 12, 2016 10:33AM
Found the problem, the mains power has to be on as well and it has to be on before the USB is connected or arduino won't recognise it.
Uploaded the Marlin v1 file but don't see any difference.
Found Triffid Hunter's Calibration Guide but not sure what motors I have and I'm getting bogged-down fast with some of that stuff.
Re: Newbie with various problems
April 12, 2016 05:14PM
As far as I know, there are two main types of motors, 1.8 degree (200 steps) and 0.9 degree (400 steps). The most common are the 200 step motors as I believe the 400 step motors are more expensive. So start with that. You are also likely to be using 1/16 stepping, which is also the most common.

Grats are figuring out the mains power issue.
Re: Newbie with various problems
April 13, 2016 05:13AM
Took the X and Y axis motors out last night and there isn't even anything like a model number to identify them so will go with your suggestions.
Was also reading about belts, they have 'MXL 050' on them and I think they are 2.0 pitch but it varies a bit, even though it is hardly used they look to be showing signs of wear and it sounds like they are timing belts, would it be best to bin them and get something like GT2 belts, and if that is recommended then I assume it is a waste of time doing anything else until then.
Re: Newbie with various problems
April 13, 2016 09:58AM
I would stick with the MXL belt for right now since it came with the kit. Did a quick search and according to an eBay posting, the belt pitch should be something like 2.039 (sorry, didn't write it down). If your calibration prints are really off though, you can always swap out your belts at a later time to improve your prints.
Re: Newbie with various problems
April 16, 2016 06:29AM
hi every body
when I try to verify marlin onto arduino program I get this error message rx_buffer was not declared in this scope. this is in CRITICAL SECTION START uint8t h=rx-buffer.head; this is hi-lited also the program goes from configuration h to marlinserial.h any body got any clues.
many thanks stan
Re: Newbie with various problems
April 16, 2016 08:47AM
Haven't had chance to do anything for a few days, been working away, but printer appears to be dead now, display lights up but no text appears on it.
Tried uploading the software again and get the following in red at the bottom of the window now.

Arduino: 1.6.8 (Windows 8.1), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"
Sketch uses 47,576 bytes (18%) of program storage space. Maximum is 253,952 bytes.
Global variables use 2,726 bytes (33%) of dynamic memory, leaving 5,466 bytes for local variables. Maximum is 8,192 bytes.
avrdude: ser_open(): can't open device "\\.\COM5": Access is denied.
avrdude: ser_drain(): read error: The handle is invalid.
Problem uploading to board. See [www.arduino.cc] for suggestions.
processing.app.SerialException: Error opening serial port 'COM5'.
at processing.app.Serial.(Serial.java:125)
at processing.app.Serial.(Serial.java:66)
at processing.app.SerialMonitor$3.(SerialMonitor.java:93)
at processing.app.SerialMonitor.open(SerialMonitor.java:93)
at processing.app.AbstractMonitor.resume(AbstractMonitor.java:110)
at processing.app.Editor.resumeOrCloseSerialMonitor(Editor.java:2430)
at processing.app.Editor.access$2900(Editor.java:89)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2408)
at java.lang.Thread.run(Thread.java:745)
Caused by: jssc.SerialPortException: Port name - COM5; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(SerialPort.java:164)
at processing.app.Serial.(Serial.java:114)
... 8 more
Error opening serial port 'COM5'.
This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

the option it gives above, for more info doesn't exist in the arduino preferences I have.
tried the URL it gives but not getting very far with some of the stuff on there, all the physical checks seem OK, there are a few references to resetting and found a button on the board so tried pressing it and now there is a red light flashing in a on-on,on-on sequence and it start doing that whenever the USB is plugged in but doesn't do it if just the mains is on.
the text below comes up when I open the arduino serial monitor so that appears to be able to connect to COM5 so can Pronterface, when pronterface connects to the printer it gives a similar display to the one below.

echo: Last Updated: Apr 12 2016 15:22:43 | Author: (none, default config)
Compiled: Apr 12 2016
echo: Free Memory: 5453 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echoconfused smileyteps per unit:
echo: M92 X78.74 Y78.74 Z533.33 E836.00
echo:Maximum feedrates (mm/s):
echo: M203 X500.00 Y500.00 Z5.00 E25.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X9000 Y9000 Z100 E10000
echo:Acceleration: S=acceleration, T=retract acceleration
echo: M204 S3000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echotongue sticking out smileyID settings:
echo: M301 P22.20 I1.08 D114.00
: Extruder switched off. MAXTEMP triggered !
Errortongue sticking out smileyrinter stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

Anyone got any ideas?
Re: Newbie with various problems
April 16, 2016 09:05AM
Update, was just reading some other stuff about this and found a bit that said 'don't let arduinio update it's self' which I had done so gone back to v101 and when I try with it I get the following at the bottom, though printer display still does not show anything.

Done uploading
Binary sketch size: 52,348 bytes (of a 258,048 byte maximum)

and get this when I connect to it:

Printer is now online.
echo: Last Updated: Apr 16 2016 13:55:01 | Author: (none, default config)
Compiled: Apr 16 2016
echo: Free Memory: 5249 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echoconfused smileyteps per unit:
echo: M92 X78.74 Y78.74 Z533.33 E836.00
echo:Maximum feedrates (mm/s):
echo: M203 X500.00 Y500.00 Z5.00 E25.00
echo:Maximum Acceleration (mm/s2):
echo: M201 X9000 Y9000 Z100 E10000
echo:Acceleration: S=acceleration, T=retract acceleration
echo: M204 S3000.00 T3000.00
echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
echo:Home offset (mm):
echo: M206 X0.00 Y0.00 Z0.00
echotongue sticking out smileyID settings:
echo: M301 P22.20 I1.08 D114.00
[ERROR] Error:0

: Extruder switched off. MAXTEMP triggered !
Errortongue sticking out smileyrinter stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
[ERROR] Errortongue sticking out smileyrinter stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
Re: Newbie with various problems
April 17, 2016 04:40AM
"Extruder switched off. MAXTEMP triggered" is always hotend thermistor related

Presuming you set your motherboard correctly... #define MOTHERBOARD 7 or #define MOTHERBOARD BOARD_ULTIMAKER on modern firmwares

MAXTEMP is normally that the hotend thermistor wires are shorted somewhere

Unplug the hotend thermistor from your controller and stick a multimeter set to measure resistance on the wires. It should be around 100K at 25C threw the wires and the thermistor

Edited 4 time(s). Last edit at 04/17/2016 04:54AM by Dust.
Re: Newbie with various problems
April 17, 2016 06:19AM
Both thermistors do not show anything until I get to the 200K range then one shows 64 and the other is 61 and they seemed OK before the software load attempt..
Where do I find the motherboard settings, don't see anything in the geeetech instructions about that.
Did wonder about the 'programmer' options in arduino as didn't see anything about what to set that on either.
Re: Newbie with various problems
April 17, 2016 06:34AM
Load up your firmware in arduino IDE, go to the configuration.h tab

Find and edit the #define MOTHERBOARD line

If it has a number change it to 7
If it has a name change it to BOARD_ULTIMAKER

"don't see anything in the geeetech instructions about that"

really??... maybe your looking at different instructions.

Its item number 2 on the getting started guide for the GT2560 [www.geeetech.com]

Edited 2 time(s). Last edit at 04/17/2016 06:36AM by Dust.
Re: Newbie with various problems
April 17, 2016 08:36AM
Is 'arduino IDE' a different version? I have arduino 1.0.1

Hadn't seen that page yet, been using this one and a couple that are linked off it.

Motherboard was already set to 7

I notice there is quite a bit on that page about installing drivers for arduino, I do not have the FT232RQ driver mentioned on there , just been using one that was installed by Cura or something, device manager says it is a "USB Serial Port (COM5)" driver and 'general' tab says it is by 'FTDI' so does this need changing?

The backlight on the display and a green LED on the board were lighting up yesterday but they are not now.
Re: Newbie with various problems
April 18, 2016 04:12PM
If the LCD back light is coming on but you are not seeing any text, it is likely working correctly but the firmware was not modified to use the LCD.

You might try uploading this script, [reprap.org], which will cause your motors to move back and forth and flash the LEDs on the board. That way you will have an idea that everything is still working correctly.
Re: Newbie with various problems
April 19, 2016 03:17AM
I tried putting Marlin-1.0.2-1 on it and the LCD backlight is coming on again now.

What do I do with the script, I saved all the text in a file and gave it a pde extension but when I tried to get arduino to open it it came up with a message about it needs to be in a sketch folder but I noticed that it put it into a new folder in the arduino install folder it's self so tried again and it now shows 'error compiling'.

I tried to 'home' everything using pronterface the other day and all axes moved a little bit then stopped and pronterface was showing this:
"Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)"
Re: Newbie with various problems
April 19, 2016 03:41PM
Not sure why you copy pasted the test script text instead of just saving the existing *.pde. Did you right click and save file or just open up the file? Its possible you missed a curly bracket during the copy paste.

Can you attach your configuration.h file and possibly your config_adv.h files so we can take a look at them.
Re: Newbie with various problems
April 20, 2016 04:53AM
Right at the top of this page: [reprap.org] is a link for 'RAMPS1.4_TestCode.pde' , I clicked on it expecting the browser to offer to download a file but is just opened a page with a load of text so I went back to the original page and tried a right-click on the link but it did not offer any of the usual options to download or save, the only thing I got remotely like that was 'copy link location' so I ended up just copying all the text and pasting it in notepad.

Will have to look at a different browser, just tried it in IE11 and it offered 'save target as' so downloaded it and arduino comes up with the following as soon as it loads the file:

Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 0
at processing.app.Sketch.setCurrentCode(Sketch.java:1182)
at processing.app.Sketch.load(Sketch.java:220)
at processing.app.Sketch.(Sketch.java:142)
at processing.app.Editor.handleOpenInternal(Editor.java:2157)
at processing.app.Editor.(Editor.java:304)
at processing.app.Base.handleOpen(Base.java:704)
at processing.app.Base.handleOpen(Base.java:669)
at processing.app.Base.handleOpenPrompt(Base.java:658)
at processing.app.Editor$4.actionPerformed(Editor.java:497)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
at java.awt.Component.processMouseEvent(Component.java:6263)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
at java.awt.Component.processEvent(Component.java:6028)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
at java.awt.Container.dispatchEventImpl(Container.java:2085)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Then get this if I click on verify:

Error compiling sketch
core.a(main.cpp.o): In function `main':
E:\3Dprint\arduino-1.0.1\hardware\arduino\cores\arduino/main.cpp:5: undefined reference to `setup'
E:\3Dprint\arduino-1.0.1\hardware\arduino\cores\arduino/main.cpp:15: undefined reference to `loop'

Configuration.h and config_adv.h files attached (I hope)
open | download - Configuration.h (35 KB)
open | download - Configuration_adv.h (21.2 KB)
Sorry, only registered users may post in this forum.

Click here to login