Welcome! Log In Create A New Profile

Advanced

z offset not working

Posted by ashdavely 
z offset not working
July 09, 2016 01:17AM
I need some suggestions for a z offset issue. I recently setup auto bed leveling which technically is working when I run G29 but I cannot get the nozzle close enough to get a successful print.

I am running marlin 1.1.0 RC6

Initially i set the Z_PROBE_OFFSET_FROM_EXTRUDER with my value which is -1.3.in Arduino and flashed it to my ramps board (repeatedly). The printer says it's there in the LCD. Then I read something that said marlin may not use that value if eeprom is enabled.So I set it to zero and entered it via the LCD and stored it.When I run G28 and M114 I see my Z offset value there but the nozzle is still 1.3mm above the bed.

I've also tried adjusting the probe to not need an offset value but I've not been successful. I've crashed the nozzle into the bed pretty hard a couple of times trying to get it to work.

For reference it seems the problem I have is common:
https://github.com/MarlinFirmware/Marlin/issues/3137

Can anyone help me?

Edited 1 time(s). Last edit at 07/09/2016 01:18AM by ashdavely.
Sorry, only registered users may post in this forum.

Click here to login