calibrating motors not working
July 10, 2016 10:23PM
Prusa i3 from folger tech Clear plastic build.
Motors do not run at all.
I have tried to calibrate them by setting the pots on the board. I don't seem to be able to get a change in reading when turning pot at all. I am a novice to this and don't understand fully how the setting is supposed to be made.
for instance I am supposed to get a reading of 0.350V for the x motor but the reading I get is .0014V and it does not really change no matter how many turns of the pot I do. I have GUESSED that maybe it is a smaller turn, like a clock reading, where 11:00 position will give a different amount than a 1:00 reading but that doesn't seem to do anything. I really don't know. Do I just keep twisting and twisting and eventually the voltage will go up? I have already turned it around dozens of times in each direction.
None of the 4 motors move at all or try to move when using the software in manual, clicking the home button, or using the x,y, or z movement button.
I got the unit used, partially assembled. So I have no idea if the previous owner screwed something up.
I am thinking about replacing the motor control boards.
Also, the board does not seem to heat up. I have gotten the temp error to stop but it does not seem to heat.
I have attached the log in case that might help figure this out.
BTW I have the LCD and card reader attached with a fat 32 card in it and it seems to like it.
After the echoconfused smileyD card ok in the log the next line is "echo:Unknown command: " "
Any help is appreciated. I have been banging my head on this for a couple of weeks.

OH YES! in the "Printer Settings" of Repetier-Host V0.95F there is NO TAB labelled "Extruder" What's up with that?

Edited 1 time(s). Last edit at 07/10/2016 10:25PM by pixmanvegas.
Attachments:
open | download - logfromprusa.rtf (8 KB)
Re: calibrating motors not working
July 11, 2016 07:35AM
Have you check the 12 volts power supply? You might have it set for a different imput voltage.
Re: calibrating motors not working
July 11, 2016 12:42PM
Check the motor wiring.

Use your multimeter and check that it's wired up right. It should be like this

Pins 1&2 should show continuity between each other, but nothing else, and should be right next to each other in the connector.
Pins 3&4 should show continuity between each other, but nothing else, and should be right next to each other in the connector.

If they're not that way, you'll just get buzzing when you try to move the motor.

Also check the endstop status
By hand, move the bed and X carriage away from the endstops
Issue M119 in Repetier
It should report the status, and they should say OPEN.

If they say TRIGGERED, try holding one down with your finger and issuing M119 again
That particular axis should then report OPEN

In that case it's either something's not wired up right (eg, not wired up com and NC terminals on the switch) or there's a firmware setting telling it to invert the logic
Re: calibrating motors not working
July 31, 2016 12:13AM
Hi there!
I hope this moves the topic back up to the top.
I finally figured out the problem, or at least part of it, and here's what I found and a new question.
I checked the voltage at coming out of the power supply and it checked out at 12v. So that was OK.
BUT...
As soon as I plugged it into the board the voltage dropped to 0.4v. I unplugged everything one piece at a time ALL THE WAY to removing the RAMPS board from the Arduino and found that the voltage drop occured when NOTHING was plugged in to the board.
Therefore there must be a short in the board and I ordered a replacement.
I have just completed re-wiring and re-connecting everything and the voltage now stays consistent at 12v even when the board is plugged in...YAY!
NOW - back to calibrating the motors...
I have started trying to calibrate the driver boards as described here:
"The stepper motor drivers must be set to the correct current settings. In order to do this, the machine must be powered on. You will need a volt meter and a steady hand to measure and adjust the potentiometers. The Vref is measured in mV (millivolts). Adjust the potentiometer with the included ceramic screwdriver to prevent shorts. Measure the Vref with the positive probe on the potentiometer itself and the negative probe on the top left pin. When you’re done setting your currents on all the drivers, cover the rows of pins with Kapton (clear yellow) tape.
Adjust the potentiometers so the voltage reads the following values:
X – 0.350V
Y – 0.550V
Z – 0.350V
E – 0.350V"

I am using the following driver boards purchased on Amazon.com:
BIQU DRV8825 4-Layer StepStick Stepper Motor Driver Module with Heat Sink (Header Pins Soldered) for 3D Printer Prerap Ramps1.4 A4988 (Pack of 5 pcs) Search that on amazon if more info is needed.
I have tried both the Z and Y modules.
On the Z module I am getting -.550V
On the Z module I am getting 0.42V
When I turn the adjustment screw nothing really happens. The numbers don't change.
How much turn of the screw is supposed to make a change in the voltage?
Thanks again.
Re: calibrating motors not working
July 31, 2016 10:35PM
UPDATE:
When I plugged in the new board I was pleased. The red lights on all the limiter switches let up and everything seemed fine. After about 5 minutes, in which time the bed heated up and I was treated to a nice hot smell. Then the red lights all went out and the Ramp board was dead from that time on. ARg Anyone want to buy a Prusa 3 plastic frame cheap? Make an offer.
Sorry, only registered users may post in this forum.

Click here to login