Welcome! Log In Create A New Profile


Extruder Controller Troubleshooting

Posted by c2tb34 
Extruder Controller Troubleshooting
January 24, 2011 08:56PM
Evening everyone,

I've been working on modifying my extruder. I am using the extruder controller board v2.2.
I have been attempting to use resistors instead of nichrome wire. However, I am having trouble
with the heating element circuit. Regardless of what I hook up to the B+/B- terminals, the element
is not heating sad smiley . It has heated before using nichrome wire and using a single 5 W resistor. The issue
of no heat began after I attempted to use two 5 W resistors in parallel. (Enter the no heat problem)

The only other information I can offer is that while the B+/B- terminals are empty and a target temperature
above room temperature has been entered, the LED near the B port is brightly lit. After hooking a resistor or
segment of nichrome wire to the port, the LED immediately dims. The LED near port C is glowing dimly all the time.
I am still able to connect to the board and reflash firmware. My only guess is that I have burned out the B port MOSFET,
however that seems as if it would require some serious trying to do.

TLDR: I'm a noob, please help
Re: Extruder Controller Troubleshooting
January 24, 2011 10:09PM
If you measure your heater's resistance and it is less than 6.5 ohms or so, it will draw too many amps and you risk blowing the mosfet. High thermal mass extruders (the MK5 hot end for example) require more power for the heater, but they are driven via relays rather than the mosfets on the extruder controler.

Check that your heater's resistance is somewhere in the range of 7.5 to 6.5 ohms. If it is, next check for resistance between the heater and the thermistor. You should not have any connection between these two items. If these two things check out, then try changing your firmware pin definitions so that one of the other outputs controls the heater instead.
Re: Extruder Controller Troubleshooting
January 24, 2011 10:16PM
The resistors are each 10 ohms so wiring them in parallel would have put 5 ohms of resistance on the B port mosfet. Would this have converted the mosfet into toast? How can I check to see if the B port is still viable? Also, given that I have 10 ohm resistors, what should I do to use them as heating elements?
Re: Extruder Controller Troubleshooting
January 24, 2011 10:41PM
One approach is indicated by the fact (verify this fact, if it's wrong this approach will burn plastic) that one resistor alone isn't enough to get your nozzle up to temp.

So, wire one resistor permanently on. Attach it directly to your power source, so if the reprap is on, that resistor is on full. It won't get hot enough to extrude, but it will get somewhat hot.

Then use JUST the other resistor under microprocessor control. Two resistors running full would (hopefully) be too much, and since one is too little, the "correct" value must be between them, and can be reached by controlling just the second resistor.

I'm building it with Baling Wire
Re: Extruder Controller Troubleshooting
January 24, 2011 11:44PM
I think these mosfets have a max current output of something in the range of 10 to 14 amps. It would only handle that much if it were well heat-sinked. On our electronics, it isn't. I have no way to be sure what the actual maximum amp draw would be, but I'm guessing it would be in the ball park of 3A. Your parallel resistors, at 2.5A, may have been pushing the limit too far.

This is one of those things where it is better to spend a few bucks more and do it right rather than cobble together something using stuff you already have. The hot end design (while relatively DIY-able) is quite dodgy as it is.

What you really need is one of these: http://www.alliedelec.com/search/productdetail.aspx?SKU=9700218. I'm not saying you have to buy it here, but that is the part you want. I would advise against messing about with other model numbers because they might not have a cylindrical enough body or the enamel may not be the right kind. Wherever you buy them, consider getting a pack of 5 so you have spares on hand in case some get lost or ruined. Shipping is probably going to cost more than the resistors, so you might as well get more and make the most of your shipping charge.

If you are still set on trying to use stuff you have on hand, this will probably take some experimentation to get good temperature control, but here is an idea:

1) Wire one resistor to a constant 12V supply (consider adding a switch so you can manually shut it off without having to kill power to all your 12V stuff). Add a fuse because during this test you do not want to let it short circuit in the event that the enamel burns off or something.

2) Insert the resistor in your heater block and let it run to see if it tops out at somewhere around 115 to 180C. Make sure that you have let it run long enough that it actually reaches the peak value or you may experience runaway temperatures while printing.

3) If the peak temperature of one resistor checks out and it has held up to the heat thus far, this idea should work pretty well. If it goes much higher, maybe try running it off of a 5V or 8V supply instead? Make sure your supply can source at least 5A. Weaker supplies will probably overheat. IF it ever goes over 180, it will not be suitable for printing PLA. If it goes over 200, it won't be good for anything so you might as well shut it off.

4) When you get your always-on resistor to maintain a temperature that is in a useful range (at least half of 230C, as this is more than enough heat for extruding ABS and should be the most heat you ever need), now connect your second resistor to one of the working outputs on your extruder controler.

5) One resistor will switch on to boost the temperature to your set point, while the other will maintain a constant baseline temperature. This way you get the same amount of heat but your mosfet only has to handle 1.2A.

Edited 1 time(s). Last edit at 01/24/2011 11:46PM by dazed.dnc.
Re: Extruder Controller Troubleshooting
January 25, 2011 01:13AM
I'm a bit stumped. I have wired up a combination of resistors that provides an equivalent resistance of 6.66 ohms.
This should be in the appropriate range for the heater output. However, it seems that I have ruined the mosfet in charge of B+/B-

I have found the configuration.h file for the extruder, and I have edited the pin configuration, but when I open up the extruder pde in Arduino 22 and attempt to compile, I receive a ton of errors sad smiley . Am I incorrect in thinking that I need to recompile after changing the pin definitions? If so, please tell me how to edit the pin definitions appropiately smiling smiley . If I do need to compile, and I'm supposed to use Arduino to do so, how do I eliminate the errors? I can elaborate on the errors if it would help.

Thanks for all the help guys!
Re: Extruder Controller Troubleshooting
January 25, 2011 06:45AM
It helps if you post the errors, plus the code you edited.

The most common errors are caused by not installing the Sanguino extensions, or not selecting the right board in the Arduino environment.
Re: Extruder Controller Troubleshooting
January 25, 2011 09:34AM
Or using the latest arduino environment - sometimes the sanguino extensions haven't been updated for the latest yet.

I'm building it with Baling Wire
Re: Extruder Controller Troubleshooting
January 25, 2011 10:52AM
There's 121 errors so my guess is this is a result of a poor environment setup. I have been selecting the board before trying to compile. How do I set up the environment / find sanguino extensions?
Re: Extruder Controller Troubleshooting
January 25, 2011 11:27AM
Setting up Arduino Software for Sanguino

Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Extruder Controller Troubleshooting
January 25, 2011 03:33PM
I have some more specific errors this time around. Using Ardruino 18 with the Sanguino extensions.
When I open up the extruder pde and attempt to compile with Sanguino selected, I receive an error telling me to select
Arduino Diecimila. Here is a relevant screenshot. [i53.tinypic.com]

After trying to select Arduino Diecimila and then compiling, the error I receive tells me that configuration.h does not exist.
Relevant screenshot: [i56.tinypic.com]

In both screenshots, you can see that the file list up top does not list configuration.h
I have tried manually adding it under the Sketch toolbar, but it does not appear. I feel like I'm greatly missing the point.

Thanks for the patience everyone.
Re: Extruder Controller Troubleshooting
January 25, 2011 04:41PM
You need to rename configuration.h.dist to configuration.h!

Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Extruder Controller Troubleshooting
January 25, 2011 06:01PM
I have tried renaming but I receive the same error sad smiley

Thank you for your patience with me!
Re: Extruder Controller Troubleshooting
January 25, 2011 07:47PM
Did you rename it, close arduino, then reopen it or did you just rename it with arduino open and try to upload? If you left arduino open, you may have to close it to get it to re-load the files.

Just another guess here if that doesn't help...
If you extracted all the files into just any old folder, arduino will prompt you to move the main pde into a folder that is of the same name as the pde. If you let it move the file into an appropriate folder, it will not also move the other files so it will not find them when you try to upload.
Re: Extruder Controller Troubleshooting
January 25, 2011 10:31PM
Well, I figured out a solution. I'm not particularly sure *why* it works, but I know how it works!

The tab view was continually not loading a configuration.h, and when I attempted to compile, the compiler continued
saying configuration.h did not exist (even as I was looking at it in the directory!). So, inside Arduino, I created a new file
name configuration.h, copy pasted the contents of the allegedly nonexistant configuration.h, saved it, and compiled it.

It worked. Go figure -_- . I'm relatively puzzled as to why Arduino refused to recognize the original configuration.h.
I tried using Arduino 15, 18, and 22. All the same errors. I'll try uploading the firmware as soon as I can and then I'll
let you guys know if I'm able to heat using A+/A-
Re: Extruder Controller Troubleshooting
January 25, 2011 11:29PM
After a successful upload of what I compiled, I plugged everything back together and connected to the motherboard in ReplicatorG. However, ReplicatorG does not recognize my toolhead. Is there a step that comes after uploading from Arduino that goes between retrying the whole assembly?
Re: Extruder Controller Troubleshooting
January 26, 2011 04:22AM
... for "configuration.h" - if i remember correct, the original file has a ".dist" appended... so you have to copy it, remove the ".dist" at the end, edit your preferences, save and reopen to get them into the environment ...

Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Sorry, only registered users may post in this forum.

Click here to login