xy stepper help
December 24, 2016 12:28PM
Hi,

I just built a reprap Morgan, everything seems to be working as expected except the X and Y steppers.

The steppers are defiantly wired correctly as they move when I run the RAMPS1.4 TestCode.pde...

The only way I can get the x and y axis to move in Marlin is when I hit the home all axis button in Pronterface or if I run G28 (they only move a short distance, and don't change their behavior when moving passed the end stops). My Z axis works well and homes as expected.

I checked all my end stops and they are working when I run m119 they all say triggered or open when triggered or not.

Please help.

Thanks
Ed
Re: xy stepper help
December 24, 2016 10:21PM
you need to define bed size and home locations in the printer setup when you get an axis Y moving press its endstop and motor should stop when you home all axes the actual x and y location should be a minus value
Re: xy stepper help
December 26, 2016 04:35AM
thanks

is this the right place to do it? below is from mt config.h file

// Travel limits after homing (units are in mm)
#define X_MIN_POS -22
#define Y_MIN_POS -44
#define Z_MIN_POS MANUAL_Z_HOME_POS
#define X_MAX_POS 200
#define Y_MAX_POS 200
#define Z_MAX_POS 225
Re: xy stepper help
December 26, 2016 05:00AM
when i home all axis(g28) the x and y move small amounts, if i continue pressing g28 till one of them hit an endstop then both axis stop moving and just hold their position(cant be moved by hand) nothing i do makes them move fro that point onward.

I am using max endstops, i tried swapping to min endstops but i get the same behavior
Re: xy stepper help
December 26, 2016 08:15AM
post your complete config.h pls
Allso, make sure you have the 3 microstepping jumpers fitted underneath each stepper driver pcb(sets 1/16th microstepping)
Re: xy stepper help
December 27, 2016 02:52AM
I had this problem, but the solution to me was to simply supply power from the supply and not just and the computer. Also check that your coplings and gears and tight on the shaft.
Re: xy stepper help
December 27, 2016 04:35AM
My x and y run on drv8825 which only has a jumper in MS3 for 1/16th and my z and e are running on a4988 which has jumpers in all 3 for 1/16th

Attached is my config file,

My power is deffinatly not a problem as my z axis is moving and i can heat the bed and the extruder with no problems.
Attachments:
open | download - Configuration.h (57.9 KB)
Re: xy stepper help
December 27, 2016 06:10PM
Not too familiar with scara printers but
Check step 6 in this link,
[www.morgan3dp.com]
Re: xy stepper help
December 29, 2016 03:24AM
anyone have any ideas??

haven't been able to find anything that can help on the Morgan websiteconfused smiley
Re: xy stepper help
February 21, 2017 04:26PM
I built a Morgan type scara and have been tinkering with it for the last 8 months, it prints quite well but i am having problems with the dimensional accuracy of the prints.
The only firmware i have had running reliably is the original “marlin armlevel” from Quentin Harley.
Note that only the Max_endstops are used on this firmware.
Sorry, only registered users may post in this forum.

Click here to login