Welcome! Log In Create A New Profile


Marlin not printing past solid layers

Posted by Jeremy123 
Marlin not printing past solid layers
May 28, 2017 04:08AM
Hi all,

First time posting here so please excuse me if this problem has been solved somewhere else.

I have just finished my second 3D printer build, a Cartesian design with a moving bed (both this and my first one are scratch built). After finding I could not improve the print quality any further on my original design so I salvaged the electronics and designed and build the second one.

However, after finishing it I have run into a very strange problem that I did not come across on the older printer (running Marlin 1.0.2). The new printer (running Marlin 1.1.1) does not print correctly past the solid bottom layers. Depending on how many solid layers are set in the slicer, it becomes very jittery as if the acceleration settings are incorrect (but they are the same as on the old printer which worked fine for over a year)- see the youtube video if you don't understand what I am meaning.


Both this new design and the original are using the same electronics (RAMPS V1.4) and DRV8825 stepper motor drivers. The only difference between the electronics are that I changed the Arduino Mega board as I had accidentally fried the 5v regulator on the old board and wanted to replace it. The board still is recognised by the computer- and everything works fine for the bottom layers.

If anyone has any clues on what I did wrong it would be much appreciated. I also attached the Configuration.H file if that helps.

Thanks again!
open | download - Configuration.h (57.3 KB)
Re: Marlin not printing past solid layers
June 16, 2017 06:50AM
It seems to me that you are extruding too much plastic causing the nozzle to bump into the part and your engine does not force enough to overcome the obstacle.
Re: Marlin not printing past solid layers
June 16, 2017 12:15PM
Have you tried to adjust the Stepper motor current, sound like it not getting enough current.

Stepper Current adjust Video
Sorry, only registered users may post in this forum.

Click here to login