Welcome! Log In Create A New Profile


Issues homing/calibrating Kossel Mini build

Posted by invariant11 
Issues homing/calibrating Kossel Mini build
August 17, 2018 02:32PM
Hello. I'm new to the RepRap forums and also to building 3D printers. Currently I'm trying my first build, a Kossel Mini. I have nearly everything assembled and I'm working on configuring Marlin and calibrating the printer. However, I'm finding a couple of issues and am hoping for some suggestions on where I can start troubleshooting.

The first, biggest issue for me is that homing fails. Through Pronterface, when I issue "G28," the three carriages begin to move upwards until they hit the endstops. When they hit the endstops, at least one of the motors keeps trying to rotate, resulting in kind of a grinding noise (though I don't think anything is actually being ground). After a couple of seconds it eventually stops and Marlin shows me an error and tells me to reset the printer.

I've tested the three endstops individually by checking the status from "M119" and manually triggering each endstop. They seem to work correctly, showing "open" when nothing is touching them, and showing "TRIGGERED" when I depress them.

I'm using Marlin 1.1.9 on a RAMPS 1.4 board, if that is relevant. Any ideas for where I can begin troubleshooting and identifying the source of the problem?

Thank you!
Re: Issues homing/calibrating Kossel Mini build
August 17, 2018 09:19PM
Normally this is due to having the X,Y, Z endstops on the wrong column (ie not on the column the appropriate X,Y or Z stepper is on)

So follow each stepper motor cable from the controller to the stepper and label it
Then follow each endstop back to to the controller, and verify each endstop is correct
Re: Issues homing/calibrating Kossel Mini build
August 19, 2018 03:50AM
Thank you! That helped!
Re: Issues homing/calibrating Kossel Mini build
September 06, 2018 05:27PM
Coming back to this, I managed to get my printer to home and my z-probe built and mounted. I decided to use a hex key-based probe instead of FSRs. Now I'm trying to figure out how to set up autocalibration (or if there is a better way to do this).

Here are the steps I've taken so far:

1. I used the files in Marlin/example_configurations/delta/kossel_mini as my starting point.
2. I also edited some of the DELTA_* values that I thought were appropriate.
3. Uploaded the firmware to my RAMPS board.
4. Execute G33.

At first, everything looked fine -- the hotend descends to the print bed and triggers the probe when it hits the bottom. After this, though, the hotend starts to move up and away from the print bed, eventually hitting one of the axes (the z-axis in my case).

The printer is definitely going outside of the bounds of the bed, and I'm not sure why. I have a bed with a 170mm diameter, giving an 85.0 mm radius. I used the following values in Configuration.h:


I've also tried a few different values for DELTA_RADIUS. To be honest, I'm a little confused about the differences between the three RADIUS values (calibration radius, printable radius, and radius). Some configurations I've seen use a calculated version, but their formula gives me a value much larger than the bed radius.

Another point of confusion is that the build guides I've seen for the Kossel Mini reference an older version of Marlin with different variable names than what is available in the current firmware. I've tried using Johann's firmware, but it won't compile and I'd rather not go down that rabbit hole of chasing missing header files.

Any thoughts on what I might be doing incorrectly? I can record a video of the behavior if necessary. Thank you.

Edited 2 time(s). Last edit at 09/06/2018 05:41PM by invariant11.
Re: Issues homing/calibrating Kossel Mini build
September 06, 2018 09:54PM
I figured it out. The spring I used for the z-probe is not strong enough to reset the switch after the hotend retracts. I ended up going back to using FSRs with a JohnSL board and it works pretty nicely now.
Sorry, only registered users may post in this forum.

Click here to login