Welcome! Log In Create A New Profile

Advanced

Extruder Fan Works Intermittently

Posted by Yarnlover 
Extruder Fan Works Intermittently
September 28, 2018 10:04AM
The extruder fan on my printer used to work fine. Recently,it does not always come on when it is supposed to, and I have been getting heat creep into my extruder, gumming things up and stopping printing/extrusion. I explored this more using manual controls in Repetier and closely monitoring the fan. Usually when I ask the fan to turn on (at about 35%), I can see the fan blade move about 5mm and then stop, and it whines. If I turn it off and on and off and on and off and on, it might finally start up. If I change to a different % (say 40%), it will sometimes start.

1) What might be the problem and a solution?

2) Is there another way to help insulate my extruder from the heat creep so I don’t have to keep an eagle eye on my fan and printer every minute?

Thank you.


REPRAPGURU Prusa I3 printer with MK8/9 Step Extruder Head
Re: Extruder Fan Works Intermittently
September 28, 2018 12:21PM
the main fan should be on full especially if the mount is PLA...maybe something has warped and is stopping the fan from moving maybe its a loose wire.
Re: Extruder Fan Works Intermittently
September 28, 2018 04:07PM
sounds like maybe a broken wire to the fan - happens sometimes
If it is the main hotend fan it should be always on 100%. Switch it on and try wiggling slowly on the wires at different length and listen to the fan. if you hear it getting slower/faster when wiggling you found a broken wire.
Re: Extruder Fan Works Intermittently
September 29, 2018 11:47AM
The fan output isn't really meant for the extruder fan, it's meant for a part cooling fan. I've made a fan speed controller connected directly to a 12V power supply (simple adjustable voltage regulator with potentiometer) so I can adjust the speed of the extruder fan and set it to a low almost inaudible speed. It works very well. I also use a high quality ball bearing fan as those can be used in any orientation without wearing out too quickly.

if you use 35% on a fan you try to start it with basically 4V while you probably need at minimum 5-7V. You can try starting the fan at 100%, then scale it back to the speed you want. Since the fan is already moving, to keep it moving doesn't take nearly as much energy as getting it moving when standing still. You could use a piece of gcode to turn on the fan at 100%, wait a few seconds for the fan to speed up, then set the final speed.

Edited 1 time(s). Last edit at 09/29/2018 11:50AM by imqqmi.


--
Kind regards
Imqqmi

NFAN CoreXY printer:
[reprap.org]
Re: Extruder Fan Works Intermittently
September 29, 2018 05:47PM
Thanks for all the replies. I think I may have a number of different things going on with my fan, as well as potentially some confusion about the fan/fan output purpose.

My fan points at the extruder. I assume it’s an extruder fan, not a parts cooling fan. But in Slic3r, the choices for running the fan seem to have a lot of “parts cooling” options. I’ve been playing with those, trying to find what works. I print onto a glass plate and do not normally have any problems with parts adhering to the bed or releasing when cool. So I should just focus on cooling the extruder parts (I’m reasoning this out in my head and typing at the same time). Let me know if someone disagrees, please.

1)I do think a wire or something is loose in my fan, because it does not always obey the settings in Repetier, and if I “flick” the fan mounting or wiggle the wiring, sometimes it starts up. (I’ve ordered a new fan to address this).

2) My printer prints PLA best at 220 for first layer and 200 for subsequent layers. But if I have my fan running at 100% while the hot end is heating, it can only heat to about 210 C. Can something on my RAMPS board be messed up? I think the power supply is adequate in the kit that I assembled this from, because I think this worked ok at some point, but could be an issue theoretically. I do have new RAMPS and arduino boards ordered.

Currently I’m trying to print 10 checkers all at once. If I don’t have the fan on during the first layer, by the last 2 pieces theextruder is presumably starting to clog because it’s too hot and laying down really messy filament, if any. If I turn the fan on (which has been a struggle as described above), it helps a bit, but then the temp starts plummeting if fan at 100%. If I start fan after layer 1, the temp (which was at 220 for first layer) is supposed to go to 200 but dips down to around 189 degrees and then slowly heats back up. (This created a lot of problems a few weeks ago when I was trying to use a filament with copper that seemed more sensitive to temperature - haven’t revisited that yet). The printing gets a little rough with PLA for a while at the lowest temp, but then recovers quickly. Again, could this be a RAMPS issue or power supply? I’d eventually like to try to hook up a second extruder to do 2 color printing, but can’t imagine trying to get that to work when I can’t get my single extruder and fan to work correctly if it’s a power supply issue.

Is there Gcode that could be used to make the printer pause until at right temp before starting to extrude or something to help this? And would it work if it goes from 220 down to 189 (passing through 200) and then back up to 200......

Any other thoughts on how to address this situation?

Does this ever get easier? I feel like I get things set up, print 2 things (if I’m lucky), try to change something, and then spend 2 days troubleshooting/struggling to understand what is failing.....
Re: Extruder Fan Works Intermittently
September 29, 2018 06:54PM
Hehe, I've been there 3 years ago but learned a lot! Now I'm running my DIY corexy printer and couldn't be happier, and very little trouble shooting was necessary to get it running, just a few tuning sessions. It's certainly a steep learning curve.

Did you do PID auto tuning? Seems to me either your PSU isn't powerful enough (should be around 15 Amps if you've got a heated bed) or PID settings aren't optimal. I used to have all kinds of problems with the extruder dropping in temperature, until I did PID autotuning. The heater cartridge is a 40W one, which also helps (I think there's also 30W cartridges available). I print ABS regularly and nylon every once in a while without problems.

Also make sure the temperature sensor is secured in the heater block and no break is in the wires.

The printer shouldn't pause, it shouldn't be necessary, and it may cause drooling and loosing the pressure in the nozzle which gives all kinds of other problems. Also bumping the temperature 20 degrees up for the first layer seems excessive to me. I'd use a different bed surface to print on if it doesn't stick and use a part cooling fan. PLA should be printed with a part cooling fan. Printing at 15mm/s for the first layer usually gives me good results.

Edited 2 time(s). Last edit at 09/29/2018 06:56PM by imqqmi.


--
Kind regards
Imqqmi

NFAN CoreXY printer:
[reprap.org]
Re: Extruder Fan Works Intermittently
September 30, 2018 12:59AM
A picture of your fan setup might help, 220 sounds high to me, i'm running at 205.
Re: Extruder Fan Works Intermittently
October 08, 2018 06:46PM
Sounds like you are changing too many things at the same time.
If you are getting messy, goo'ey prints, you are printing too hot. Back it off 5C and try again.

If you have small parts you may not be waiting long enough between layers for a layer to cool off. Both Simplify3D and CURA have settings to address this.

If your hot end drops 20C when the fan comes on, don't turn it on so hard. I start all my PLA prints off at 0 fan on layer one, then go to 60% on at layer 2 and have the slicer adjust the fan speed up as the layer time drops. Again, both S3D and CURA have settings to do this in their "cooling" sections. With CURA you will have to change settings to expose those options.

There isn't much of a reason to turn a part fan on at less than 40%. If your fan won't come on there, "blip" it to 100% first; S3D has a setting for this, I don't know if CURA does. But, if your fan doesn't come on at 40%, you need a new fan!

Have fun,
DLC


Kits: He3D K200 Kossel, Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head
Scratch: Large bed Cartesian, Linear slide Delta, Maker-Beam XL Micro Delta
Sorry, only registered users may post in this forum.

Click here to login