Welcome! Log In Create A New Profile

Advanced

Stepper motors vibrate, turn one way, then the other

Posted by rflournoy 
Stepper motors vibrate, turn one way, then the other
February 18, 2020 12:28AM
I had an issue with my extruder recently. The feed tube to the hotend was clogged, so I replaced it. I screwed the new feeder barrel in too deep and hit the extruder gear and heard clicking when powered up. The power was then disconnected and the feeder tube backed out a couple of turns. When I turned the machine back on the extruder wouldn't work so I decided to Home all axes and quite for the night. None of the stepper motors would turn, so I quit for the night. The next morning I checked all the connections, but still nothing but clicking and/or grinding. A new stepper motor was connected. When I tried to move the axis 1 mm there was grinding, 10 mm the axis moved about 1/8th turn but was jittery. When I tried to move it 50 or 60 mm it would turn a round or two and then reversed. I've replaced the Arduino, RAMPS and stepper drivers and tried every axis with the same results. The X axis moves easily by hand, the Y axis moves easily by hand, and the Z motors can be turned easily by hand when the power is off.

Hardware:
RepRapGuru Prusa i3
New genuine Arduino Mega 2650
New RAMPS 1.4
Marlin 1.1.6
Arduino IDE 1.8.11
New TI drv8825 steppers

I'm out of ideas. Any thoughts?
Thank you.
Re: Stepper motors vibrate, turn one way, then the other
February 18, 2020 01:13PM
Did you change any wires? Those are the classic symptoms of a miswired stepper.

DLC


Kits: He3D K200 Kossel, Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head
Scratch: Large bed Cartesian, Linear slide Delta, Maker-Beam XL Micro Delta
Re: Stepper motors vibrate, turn one way, then the other
February 18, 2020 01:56PM
Quote
dlc60
Did you change any wires? Those are the classic symptoms of a miswired stepper.

DLC


No wires were changed, but I checked the system with new wires just in case. No change. Still stumped.
Re: Stepper motors vibrate, turn one way, then the other
February 18, 2020 05:41PM
Well, you've changed everything but the wires, and the power supply. Check to see that you are getting the voltage (12 or 24V) that you should be at your controller board. Low voltage will cause a stepper to be "weak" and may cause your issue.

DLC


Kits: He3D K200 Kossel, Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head
Scratch: Large bed Cartesian, Linear slide Delta, Maker-Beam XL Micro Delta
Re: Stepper motors vibrate, turn one way, then the other
February 19, 2020 12:35AM
Quote
dlc60
Well, you've changed everything but the wires, and the power supply. Check to see that you are getting the voltage (12 or 24V) that you should be at your controller board. Low voltage will cause a stepper to be "weak" and may cause your issue.

DLC

Voltage going into RAMPS is good, 12.1 v, I've unplugged everything and tried running the stepper motors one at a time with new wires. Nothing is plugged in to the RAMPS except the stepper I'm testing, but still get only vibration and very little movement, if any. Heated bed works. The only thing I haven't tried is the LCD/SD swap. When this all started (I remembered a few minutes ago) the display went white. On Sunday, I had the unit's USB plugged in to my computer and turned on the power supply. The LCD went white and the computer went off and wouldn't come back on, but nothing on the RepRap printer would work. I'm beginning to thing the LCD might have something to do with this, but it's late so I'll check it tomorrow with a different LCD.

I'm still open for other suggestions in case the LCD doesn't fix it.
Re: Stepper motors vibrate, turn one way, then the other
February 19, 2020 02:47AM
Sound like only one phase of the stepper motor is being energised. If it's happening on just one driver, probably due to a bad connection or faulty driver. If it's happening on all drivers, probably a bad power input connection.

Edited 1 time(s). Last edit at 02/19/2020 02:49AM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Stepper motors vibrate, turn one way, then the other
February 19, 2020 11:34PM
Quote
dc42
Sound like only one phase of the stepper motor is being energised. If it's happening on just one driver, probably due to a bad connection or faulty driver. If it's happening on all drivers, probably a bad power input connection.

I finally discovered the issue. The LCD shorted and caused overheating of the board. I kept trying to use the LCD because it still seemed to be working. After changing the LCD and then replacing the Arduino and RAMPS again it seems to be working. Now it's back to recalibrating everything again.
Re: Stepper motors vibrate, turn one way, then the other
February 24, 2020 04:54PM
Finally fixed it. Thank you for all your assistance.

Edited 1 time(s). Last edit at 02/24/2020 11:46PM by rflournoy.
Sorry, only registered users may post in this forum.

Click here to login