Welcome! Log In Create A New Profile

Advanced

Testing boards and step motors/ Error

Posted by Sirpaz 
Testing boards and step motors/ Error
July 20, 2020 04:01PM
Hi everyone,
I am a new entry in the community and I hope I am posting in the right category.

I am here to look for support for an error I have run into while doing some early tests on boards and step motors for a 3d printer I am currently working on.
In order to do my tests, I am referring to this video:
Youtube Video


Ok, so I am now at the stage where I have my .gcode file imported in my print run software ready to print; the console on the right of the software interface, pops out an error message at 0.03% of the process stopping the print. Here below the error message:

Print started at: 16:40:05

[ERROR] Failed to set power settings:

Traceback (most recent call last):

File “/Users/craigvanvliet/Desktop/PyInstaller-2.1/pronterface/build/pronterface/out00-PYZ.pyz/printrun.pronsole”, line 1186, in startcb

File “/Users/craigvanvliet/Desktop/PyInstaller-2.1/pronterface/build/pronterface/out00-PYZ.pyz/printrun.power”, line 130, in powerset_print_start

File “/Users/craigvanvliet/Desktop/PyInstaller-2.1/pronterface/build/pronterface/out00-PYZ.pyz/printrun.power.osx”, line 75, in inhibit_sleep_osx

File “/Users/craigvanvliet/Desktop/PyInstaller-2.1/pronterface/build/pronterface/out00-PYZ.pyz/printrun.power.osx”, line 52, in AssertionCreateWithName

File “/Users/craigvanvliet/Desktop/PyInstaller-2.1/pronterface/build/pronterface/out00-PYZ.pyz/printrun.power.osx”, line 44, in StringToCFString

AttributeError: ‘module’ object has no attribute ‘CFStringCreateWithCString’

echo:Active Extruder: 0

Error:MINTEMP triggered, system stopped! Heater_ID: 0

[ERROR] Error:MINTEMP triggered, system stopped! Heater_ID: 0

Error: Printer halted. kill() called!

[ERROR] Error: Printer halted. kill() called!


Has anyone ever seen anything like this? Any idea on how to solve it?

Thanks,
Flavio
Re: Testing boards and step motors/ Error
July 20, 2020 11:16PM
"Error:MINTEMP triggered"

the controller cannot see your thermistor, so it reads the lowest temp. (which is open circuit)

possible causes.

Thermistor unplugged.
Thermistor plugged into wrong place.
Thermistor or its cable is broken.
Incorrect motherboard set, so controller is looking at wrong pin.
Incorrect thermistor defined in Configuration.h
Dead ADC pin on controller.

Edited 1 time(s). Last edit at 07/21/2020 12:29AM by Dust.
Re: Testing boards and step motors/ Error
July 21, 2020 08:55AM
By the way, printrun is pretty old firmware. I'm also curious what you're doing on Craig van Vliet's macbook.

Anyway, I would try more modern firmware, since more people will be able to help you.

Edited 1 time(s). Last edit at 07/21/2020 08:55AM by Ohmarinus.


http://www.marinusdebeer.nl/
Re: Testing boards and step motors/ Error
July 21, 2020 09:29AM
If your just trying out movement, the slicer is adding in temperature related gcode, this will break your tests if you don't have heating and thermistors.

Also modern firmwares will not allow you to move E, unless the hot end is hot. unless you deliberately disable this.

Thee printrun error is just trying to tell your os not to go into power save mode. You probably need elevated security rites for that
Re: Testing boards and step motors/ Error
July 21, 2020 11:10AM
Hi Dust

Quote
Dust
"Error:MINTEMP triggered"

the controller cannot see your thermistor, so it reads the lowest temp. (which is open circuit)

possible causes.

Thermistor unplugged.
Thermistor plugged into wrong place.
Thermistor or its cable is broken.
Incorrect motherboard set, so controller is looking at wrong pin.
Incorrect thermistor defined in Configuration.h
Dead ADC pin on controller.

I am trying to disable the thermistor as indicated in this forum, but I did not have much luck so far..
I also tried to set the M302 parameter so to allow cold extrusion, but pronterface keeps reporting the same error: Heating failed, system stopped! Heater_ID:0

Quote
Dust
Also modern firmwares will not allow you to move E, unless the hot end is hot. unless you deliberately disable this.

How can I disable the hot end?

Quote
Ohmarinus
By the way, printrun is pretty old firmware.
Hi Ohmarinus, as I am approaching all this stuff just now, printrun was the first firmware I came across (something like, if you don't start somewhere, you are gonna go nowhere)
and anyway an interesting interface to begin with. I am open to advices, what would be a more up to date alternative to Printrun? Perhaps could also be the solution to my problem.

Quote
Ohmarinus
I'm also curious what you're doing on Craig van Vliet's macbook

That is out of the blue, I have no clue where that Craig van Vliet's macbook comes from...confused smiley
Re: Testing boards and step motors/ Error
July 21, 2020 11:24AM
the controller will always say heating failed if you send it any gcode to heat up.

you need to ensure there are no M104 or M109 commands in the gcode.

presuming a recent marlin

In firmware you can set #define EXTRUDERS 0 this will disable both the above gcodes. but it also disables e0. But X,Y and Z should be normal.

or you could edit the code in gcode.cpp

change
#if EXTRUDERS
        case 104: M104(); break;                                  // M104: Set hot end temperature
        case 109: M109(); break;                                  // M109: Wait for hotend temperature to reach target
      #endif

to
#if EXTRUDERS
        //case 104: M104(); break;                                  // M104: Set hot end temperature
        //case 109: M109(); break;                                  // M109: Wait for hotend temperature to reach target
      #endif

to disable the two hot end heating gcodes

Edited 2 time(s). Last edit at 07/21/2020 11:31AM by Dust.
Re: Testing boards and step motors/ Error
July 21, 2020 11:37AM
As I set EXTRUDERS to 0 and I verify, Arduino points out that 'ARRAY 0' was not declared in this scope.
I don't understand...
Re: Testing boards and step motors/ Error
July 21, 2020 11:42AM
Quote
Dust
or you could edit the code in gcode.cpp

Please, bare with me..
What/where/how do I edit the gcode.cpp?
I looked in the arduino tabs but there's nothing called like that in the Marlin.ino. Beside, for what I know the gcode is the file I imported in pronterface, the print in a nutshell...
Re: Testing boards and step motors/ Error
July 21, 2020 12:06PM
If you followed that tutorial to the letter, you using much older marlin 1.1...

you will find the equivalent in Marlin_main.cpp

line 12992
case 104: gcode_M104(); break;

line 13014
case 109: gcode_M109(); break;

add // to the front of each of these two lines.
Re: Testing boards and step motors/ Error
July 21, 2020 12:35PM
Yes! that worked!
As you said, except e, x,y and z are now moving.

I can now carry on with the tests; and yes I do have a very old version of Marlin, I did realise that after I started to work on it, but I ll provide to upload to the latest version.
Thanks for helping out smiling smiley
tmz
Re: Testing boards and step motors/ Error
June 22, 2024 06:02AM
I need your HELP. I can only home z axis but not x axis and y axis of my 3d printer.I use RAMPS 1.4-Controller + Mega R3-Board + A4988-Driver. I always get the following message in Pronterface:

Connecting...
start
Printer is now online.
Marlin 2.1.2.2
echo: Last Updated: 2024-02-08 | Author: (none, default config)
echo: Compiled: Jun 16 2024
echo: Free Memory: 4187 PlannerBufferBytes: 1200
echo:Hardcoded Default Settings Loaded
echo:; Linear Units:
echo: G21 ; (mm)
echo:; Temperature Units:
echo: M149 C ; Units in Celsius
echo:; Filament settings (Disabled):
echo: M200 S0 D1.75
echo:; Steps per unit:
echo: M92 X80.00 Y80.00 Z4000.00 E100.00
echo:; Max feedrates (units/s):
echo: M203 X300.00 Y300.00 Z2.50 E25.00
echo:; Max Acceleration (units/s2):
echo: M201 X3000.00 Y3000.00 Z100.00 E10000.00
echo:; Acceleration (units/s2) (P R T):
echo: M204 P400.00 R1000.00 T1000.00
echo:; Advanced (B S T X Y Z E):
echo: M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
echo:; Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:; Hotend PID:
echo: M301 P22.20 I1.08 D114.00
echo: SD card released
echo:Home Z First
echo:Home X First
echo:Home Y First
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:Homing Failed
Errortongue sticking out smileyrinter halted. kill() called!
[ERROR] Errortongue sticking out smileyrinter halted. kill() called!

Edited 1 time(s). Last edit at 06/22/2024 06:07AM by tmz.
VDX
Re: Testing boards and step motors/ Error
June 22, 2024 07:06AM
... check for polarity and switching state of the homing switches with "M119".

If they seems correct, then try to home them separate with "G28 X" and "...Y", "...Z" respective.

If your startup sequence "automatically" performs G28, then remove this line ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Testing boards and step motors/ Error
June 22, 2024 08:44AM
Marlin 2.1.2.2 also has lots of issue Use Marlin 2.1.2.4
tmz
Re: Testing boards and step motors/ Error
June 23, 2024 03:07PM
Firstly I would like to thank you (VDX and Dust) for your reply. I have updated Marlin 2.1.2.2 to Marlin 2.1.2.4, but still nothing has happened.:

Connecting...
start
Printer is now online.
Marlin 2.1.2.4
echo: Last Updated: 2024-06-16 | Author: (none, default config)
echo: Compiled: Jun 23 2024
echo: Free Memory: 3773 PlannerBufferBytes: 1200
echo:Hardcoded Default Settings Loaded
echo:; Linear Units:
echo: G21 ; (mm)
echo:; Temperature Units:
echo: M149 C ; Units in Celsius
echo:; Filament settings (Disabled):
echo: M200 S0 D1.75
echo:; Steps per unit:
echo: M92 X80.00 Y80.00 Z4000.00 E100.00
echo:; Max feedrates (units/s):
echo: M203 X300.00 Y300.00 Z2.50 E25.00
echo:; Max Acceleration (units/s2):
echo: M201 X3000.00 Y3000.00 Z100.00 E10000.00
echo:; Acceleration (units/s2) (P R T):
echo: M204 P400.00 R1000.00 T1000.00
echo:; Advanced (B S T X Y Z E):
echo: M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
echo:; Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:; Hotend PID:
echo: M301 P22.20 I1.08 D114.00
echo: SD card released
Traceback (most recent call last):
File "printrun\pronterface.pyc", line 1939, in editbutton
AttributeError: 'Button' object has no attribute 'properties'
SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: open
SENDING:M302
echo:Cold extrudes are disabled (min temp 170C)
>>> M119
SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: open
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:Homing Failed
Errortongue sticking out smileyrinter halted. kill() called!
[ERROR] Errortongue sticking out smileyrinter halted. kill() called!

Edited 3 time(s). Last edit at 06/24/2024 10:53AM by tmz.
VDX
Re: Testing boards and step motors/ Error
June 24, 2024 01:34AM
... could be, the endstops (or only one) aren't configured properly, so the homing didn't work ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Testing boards and step motors/ Error
June 24, 2024 05:30AM
Hi everyone,

Does anybody know why is it that in the latest Marlin version there is no .ino file?
I am stucked with the 1.8.13 which keeps on failing some Array_0 error and I cannot use any other version....

Thanks

P.S. I am still testing, none of my previous tests has ended in to an official first print.
Re: Testing boards and step motors/ Error
June 24, 2024 08:17AM
Latest Marlin bugfix 2.1.x still has Marlin.ino [github.com]
Latest release 2.1.2.4 still has Marlin.ino [github.com]

So Im not sure what your talking about, its not missing


Though arduino ide is not recommended any more, old and slow (even the new versions) vscode is recommended

Edited 1 time(s). Last edit at 06/24/2024 08:20AM by Dust.
Re: Testing boards and step motors/ Error
June 25, 2024 10:16AM
I was downloading Marlin from their official website and the .ino file is missing in that package; different story from github.com. Thanks

So...yes, unfortunately arduino is no longer compatible with my old mojave OS, therefore I was already considering VScode. I have been advised to use it paired with platformIO but I am running in an much complex IDE environment, if compared to Arduino. I hope this is for good..
Re: Testing boards and step motors/ Error
June 26, 2024 06:01AM
"Error: Nothing to build. Please put your source code files to the 'Z:\Desktop\Risorse\Archivio\DIY 3D Printer\Firmware\Marlin-2.1.2.4' folder"

I am trying to build using PlatformIO for the first time, but for some reasons it always shows up this error. I am working in a VM with windows 10, I checked and double checked so to be sure that the directory I am working in, is right as it shows in the untitled workspace and it is.

I tried to add again the folder to workspace to see if the error would quit, but it didn't. I edited the security settings for UNC hosts so to allow access to the mac, but nothing. In the .ini file I changed the directories in the tags src_dir and include_dir to match the one of the folder I am working in but nothing changed.. Is anyone familiar with this error?
Thanks
Re: Testing boards and step motors/ Error
June 26, 2024 06:17AM
You don't change anything in platformio.ini except default_envs restore the stock one [github.com]

You have to open up the directory with the platformio.ini file in it, not the marlin sub folder


Vscode is multi platform... you dont need a vm, but if you feel you must setup ubuntu 22.04, way less overhead than windows.

you really need to have the code on a local hard-drive, not networked

Edited 6 time(s). Last edit at 06/26/2024 06:47AM by Dust.
Re: Testing boards and step motors/ Error
June 26, 2024 09:24AM
I found a compatible version for my OS and I am now back to local hard-drive.

but once again the terminal is returning me the same error 'Nothing to build' with the exception that it is now indicating a made up directory: '/Users/utente/Desktop/Risorse/Archivio/DIY 3D Printer/Firmware/Marlin-2.1.2.4/C:\Users\utente\AppData\Local\Programs\Microsoft VS Code\Marlin', which is the combination of the old directory, that PIO was picking when operating from the VM, plus the current directory.
Is there a way for me to manually insert the directory? or in this case, get rid of the VM's one?
Re: Testing boards and step motors/ Error
June 26, 2024 09:58AM
SOLVED!

I have created a new project starting from the ground and the settings were ok this time. thumbs up
Sorry, only registered users may post in this forum.

Click here to login