Extruders motors will not turn
October 20, 2023 09:32AM
Hi all, I am at a complete loss, My extruders on my latest five colour mixing printer will not turn, I am using a Mega 256 with Ramps 1.4 and three add on extruders together with Marlin firmware.
At power on all extruders are free turning, no power as are X Y and Z When I ask it to home all axes X Y and Z home perfectly then I heat the hot end to 200 degrees (PLA) minimum temp set to 105 degrees, and then try to extrude on any one of the five axes and all that happens is that extruder 0 and 1 locks solid and will not move to extrude.
I have tried changing an extruder motor and cable onto the X Y or Z pins and the extruder motors all work fine as one would expect, I have swapped the extruder A4988 drivers onto X Y axes and relevant axis work fine, have checked all voltages on the A4988s and Vcc is 5V and Vmot is 12volt and the ground is grounded the trim pots are adjusted to1.2 Volts all the same as X Y and Z The add on drivers voltages are correct as well I have set pins.h commenting out the default servo pins and used them as follows

#define E0_STEP_PIN 26
#define E0_DIR_PIN 28
#define E0_ENABLE_PIN 24

#define E1_STEP_PIN 36
#define E1_DIR_PIN 34
#define E1_ENABLE_PIN 30

#define E2_STEP_PIN 4
#define E2_DIR_PIN 40
#define E2_ENABLE_PIN 42

#define E3_STEP_PIN 5
#define E3_DIR_PIN 59
#define E3_ENABLE_PIN 64

#define E4_STEP_PIN 6
#define E4_DIR_PIN 66
#define E4_ENABLE_PIN 58

After doing all this I still cannot get the extruders to run can someone please help and point out What I have missed or done wrong.
a comment from the arduino forum suggested it may be the thermister so I replaced that with a new one and still no affect
Re: Extruders motors will not turn
October 20, 2023 09:58AM
Enable PINS_DEBUGGING and send a M43

examine ouput for any pin conflicts you may have missed


A full config and edited pins file would also help...

Edited 1 time(s). Last edit at 10/20/2023 09:58AM by Dust.
Re: Extruders motors will not turn
October 20, 2023 10:13AM
Also you can test your hardware with the stock ramps tester code. A version I modified to work in vscode or arduino ide can be found here [github.com]

If you look at RAMPS1.4_TestCode.ino you will see it is very easy to extend to more axes. Or just update pins for your 5 E axis

Note: it blindly moves all steppers and turns on all the mosfets, so unplug heaters and ensure extruders have no filament

Edited 4 time(s). Last edit at 10/20/2023 11:26AM by Dust.
Re: Extruders motors will not turn
October 20, 2023 11:41AM
Thanks Dust for a very speedy reply I have downloaded the suggested file and as I understand it I will edit it to include and add the extra axes pins from my pins.h compile and run it and get back to you. thanks again
Re: Extruders motors will not turn
October 21, 2023 09:04AM
Hi Dust, I have added the extra axes to the Ramps1.4 test file and it compiles without error, so does that mean that the pins are all OK and not duplicated, do I upload it as is to the printer overwriting the Marlin sketch or do I somehow include it to the Marlin sketch to upload and run I am sorry if this seems a strange question but I really am not up to speed on this subject .
Re: Extruders motors will not turn
October 21, 2023 10:47AM
this is simple test firmware, you upload it to the controller and observe the results

All stepper motors should move back and forward a little bit.

If steppers move as expected, issue is in marlin some ware

if steppers don't move now, you have hardware issues (any of these.plugged into wrong port, vref to low, bad stepper motor wires, dead stepper driver, dead mega or ramps)

Edited 1 time(s). Last edit at 10/21/2023 10:49AM by Dust.
Re: Extruders motors will not turn
October 25, 2023 03:50AM
Thanks Dust ,after a long weekend I have now uploaded the sketch starting with the un edited version which worked perfect on all onboard motors and then adding one extruder at a time until and now all eight stepper motors are working fine all thanks to your superb sketch.
Then I uploaded Marlin and started a test print it started off just fine and then after about five minutes all extruders stopped working again and so I uploaded your sketch again and again all eight motors are working fine and so I have now turned my thoughts to either Marlin or my slicer settings any suggestions to find the problem would be greatly appreciated.
Re: Extruders motors will not turn
October 25, 2023 04:29AM
This is a mixing extruder, so a number of extruders are running concurrently...with X, Y and Z

I'm wondering if your tripping the 5a polyfuse, as ramps was not designed with 5 extruders in mind

The polyfuses are the yellow square things, the work by heating up with the current drawn through them, to much current and the get over a tripping temperature point and go open circuit.. They close back up after cooling down.

You should monitor 12v after the 5amp polyfuse. A really good place for this is the 12v-aux pins (just behind the polyfuses, not always populated)

Use a voltmeter/multimeter on volts and check what it says as it fails
You could also just use a fan, if it stops spinning when the printer stops.. the polyfuse has tripped
Re: Extruders motors will not turn
October 26, 2023 10:34AM
Thanks Dust, But if XY&Z are still working and they are surly that must rule out the poly fuse or are they an a separate fuse setting and so I am going to give the slicer settings a cote of looking at it seems to be adding G92 E0 in quite a few places down the Gcode, I have commented them out and I will keep you posted
Re: Extruders motors will not turn
October 26, 2023 10:49AM
If X,Y and Z are still moving, no it cannot be the polyfuse... Its for all steppers
Re: Extruders motors will not turn
October 26, 2023 11:03AM
That:s what I though, I think that it may be in the Gcode where the error is but I am not sure I noticed that it contains several G92 E0 lines I will try taking them out ??
Re: Extruders motors will not turn
October 31, 2023 01:20PM
]Hi all another week now past I am still trying to find the problem, I have eliminated the hardware with the aid of the ramps test sketch and the slicer by using another slicer and whats more the sliced sketch I used on my other printer with the same AUX3 pins for its third diamond extruder stepper and having disabled the ABS filament the sketch ran fine including the extruder motor and so to my logic the problem has to be in Marlin so I have isolated my current marlin sketch and downloaded a new version but to my amazement when I load it in arduino.ide it comprises of only four tabs i.e Marlin.ino, Configuration.h , configuration_adv.h and Version.h When I compile it it errors out with no pin definitions for extruder 2. 3, and 4 . In the extracted download I have found pins .h but how do I include it in arduino Marlin sketch ?, so that I can define the pin numbers
Re: Extruders motors will not turn
November 01, 2023 04:44PM
Hi all I believe that I have solved my problem after downloading a new version of Marlin and figuring how to setup the five extruders I have now seen the first extruder moving all be it in the wrong direction it moves. In my previous post I said about the pins problem I overcame this by defining all the extruder pins directly beneath the board definition in configuration.h and to my great relief it compiled and uploaded, Thanks again for all replies and help from the forum
Sorry, only registered users may post in this forum.

Click here to login