Welcome! Log In Create A New Profile

Advanced

Replikeo Prusa i3 problem after problem

Posted by crowleygarrett 
Replikeo Prusa i3 problem after problem
August 10, 2015 03:48PM
Hello Everyone,
Background: I bought a Replikeo Prusa i3 single extruder kit (http://www.replikeo.com/en/KIT001) and despite the build being simple enough, I am having major problems with the firmware. I got in way over my head and cant seem to figure out which values to adjust. I have looked at multiple guides that gave exact edits to make to the configuration.h in Marlin and none have proved completely successful. I have also tried using Repetier firmware and got nearly identical results. I have checked all my stepper motors and each works perfectly. I have counted to number of teeth on each pulley attached to the motors and get a value of 20 teeth.

Problem: X and Y motor/ belts move well but when I try to make a larger motion with them, they whir and make a loud screeching noise. Z axis wont move at all and will make a loud whir every time I try to move it. I have gotten the z axis to work but I messed around with some values and now it doesn't move at all. When I do have all motors moving, they move in much larger increments (or usually, dont move at all) than I specify in pronterface or repetier.

If there is an easier firmware or any help you can provide. I would be incredibly appreciative. I can provide any additional information at request.
Re: Replikeo Prusa i3 problem after problem
August 10, 2015 04:08PM
This doesn't look like firmware at all, more like not enough current and you didn't use 1/16 microstepping. Unsure what board you're using, try checking the jumpers below the step stick (ramps 1.4) or nearby the step stick port, place all 3 jumpers on those pins each, and test. Don't know if you've done the current calibration or not
Re: Replikeo Prusa i3 problem after problem
August 10, 2015 09:34PM
After adding all three jumpers under every stepstick, very carefully adjust the trimpot screws on the stepsticks, one at a time. For mine, I only installed one stepstick at a time, testing each stepper motor before adding another one, because getting the current setting wrong on one of those can burn it out (I learned that the hard way).

For each stepper motor, install the jumpers, then the stepstick, then step the stepper with pulses or using your printing software (printrun/pronterface/whatever) while adjusting the screw. You want the stepper motor to turn smoothly and quietly but back off the current if the stepper motor starts to get hot. Do this with all the stepper motors each in turn, and they'll stop whining.

If you do end up burning out a stepstick don't worry; they're pretty cheap. cool smiley
Re: Replikeo Prusa i3 problem after problem
August 11, 2015 02:41PM
It appears that you are both correct. I can get my X axis to move much smoother but it moves at a million miles per hour and comes smacking back and forth. I am now solely using pronterface and marlin. Which settings do I have to change to control speed? Also, I cant find the sweet spot with the Y and Z axis and they continue to whir. Any chance you can provide a link to a video or written guide or maybe walk me through the process of turning the screw?
Re: Replikeo Prusa i3 problem after problem
August 11, 2015 02:57PM
I followed Tom Sanladerer's pot adjustment rule of thumb, and that is during print carefully turn the pot while using your hand to feel the motor's temp. If you have infrared or temperature measurement, just have it around 30-35'c, which is warm to touch over 5-10 seconds.

Mine however, I always cancel the print when it starts whirring/losing steps, turn off the printer from outlet, let the current in the board to dissipate/discharged by about 1 minute, turn up/down the pot, then test print. While printing I feel the motor if it's hot/warm/cold. This I guess best when you're using different brand of nema17 motor that might require different current each
Re: Replikeo Prusa i3 problem after problem
December 25, 2015 06:07AM
I am having a similar problem too, my x and z move perfectly well, however my y refuses to move
It does not make a whirring noise but more like a struggling noise to move. I tried adjusting my trimpot but either there is too much current which causes a m999 error orr the motor does not respond at all.
Is it possible that I have spoilt my stepstick or my board in the process?
How will i know if i have?
Thanks smiling smiley
Sorry, only registered users may post in this forum.

Click here to login