Welcome! Log In Create A New Profile


FTDI stability with ARM chips

Posted by rklauco 
FTDI stability with ARM chips
January 03, 2016 03:31PM
Hello, everyone.
I have a strange issue here.
I am using a cheap Chinese RepRap i3 with Melzi 2.0 board.
The printer works just fine when printing from SD card.
I wanted to un-tether it. So I opted for OctoPrint installed on a cheap WRT router with a webcam.
It worked OK for small prints, but when printing something 3+ hours, the FTDI chip disconnects.
So I replaced the WRT router with Banana Pi.
Works faster, of course, but the problem persists - now it's even worst when I sometimes have disconnects after an hour or even less.
The print is running from SD card (after I spent several hours trying to fix the issue from the OctoPrint).
Again, even 12+ hours prints are running OK, but the FTDI disconnects.
I tried USB2.0 hub, USB1.1 hub, both powered and non-powered, I have 3A power supply, so that should not be an issue, and also have shielded USB cable (tested 3 of them actually).
The printer is in a separate room with no other electrical equipment.
Is there any advice someone has? I googled for 2 days and read majority of the advices, tested all of them as far as I can tell, but none helped so far.
Sorry, only registered users may post in this forum.

Click here to login