Re: RepRap Guru i3 Printer Kit (Official Thread)
February 26, 2018 12:30AM
Looks like this was resolved. I ended up cutting and stripping the wire and connecting it to the D9 terminal on the RAMPS board.
Re: RepRap Guru i3 Printer Kit (Official Thread)
February 26, 2018 07:56AM
You're actually better off hooking it directly to 12V and GND right off the power supply. The fan on the extruder that keeps the top half of the metal block cold should be on full blast the whole time. If the upper part of the heater block gets too hot the plastic will melt early and gum up in the top of the block instead of melting last second which is ideal. Had mine hooked up to D9 for a while which is okay if you tell it to set the fan to full blast from start to finish, but best to leave d9 open in case you decide to add a part cooling fan.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 08, 2018 02:00PM
So I'm beyond frustrated. My son and I finished assembly over a month ago. We got everything calibrated and printed a calibration cube with PLA no problem. Since then it has been one Thermal Runaway after another. We have replaced the bed and the thermistor for the extruder. I have tested the hardware by bringing them to temperature and having them sit there not doing anything at temp for 10-15 minutes for both the bed and the extruder and no issues. I did get one Thermal Runaway when I had the extruder at temp and then turned the fan on and it caused a dip in temperature that was enough to set things off.

We are totally new to 3D printing and it has been a rough go. As best as I can tell something in the software is setting things off as the hardware seems to be fine. I realize they are there to keep from burning the house down but a 10 degree dip shouldn't set things off and shut down the printer. Any ideas how we can remedy this issue? We would really like to actually print something with this 3D Printer.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 08, 2018 06:37PM
Just to try some basic things would see if moving the printer somewhere free of drafts would help, alternatively could make a foam or cardboard enclosure that at least wraps the sides of the printer to help keep whatever heat it's producing around it. One other relatively simple thing to check or try is the voltage on the power supply it should be at least 12V. If those two things don't help and you're confident in the hardware and connections next thing to look into updating/modifying the firmware to make the time or temp that triggers the error higher.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 09, 2018 11:42PM
What temp are you trying to get the bed to as well might be running into issue #2 here [reprap.org] Might be worth trying to move the mosfet that is controlling power going to the heated bed so it isn't near anything else generating heat or put a heat sink on it (possibly lower bed temp if that's an option).
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 09, 2018 11:53PM
So I tried the cardboard enclosure now as soon as I hit print the Arduino goes into safety mode and locks up everything for 20 minutes Repetier comes up with a communication timeout. If it is not one thing it's another. I can't seem to get things limited to one set of problems to work on. Is there a reason the Arduino takes so long to come back online after going into safety mode?
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 10, 2018 12:52AM
Not sure about which safety mode you mean but typically a reboot only takes somewhere around 10 seconds for marlin itself (my octopi interface takes longer to reboot when that's needed). Would try printing from SD card rather than over USB the USB connection for printing from repetier hasn't worked out great for me in the past (I used repetier for initial setup but typically use octopi or the SD card to print). Also keep the Arduino/Ramps outside the "enclosure" if possible you want them to stay cool but want to keep whatever heat is generated by the bed in (since the mosfet is underpowered the bed doesn't really get enough amps so it helps to keep whatever heat it's generating in).
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 10, 2018 11:41AM
So I think the mosfets on the RAMPS board are getting really hot and tripping some safety feature and then they have to cool down again before the board will powerup. (Hopefully I'm using those terms correctly the electronics is all new to me) I tried to run things 3 times last night and every time the printer shutdown just after getting to temperature and looking like it was ready to start printing, no lights on the LCD, Arduino, stops nothing and it was at least 20 minutes before the board would power up again. The power supply seems to stay on with power going to the board but nothing happening on the board. I didn't notice the temperature on the mosfets until the 3rd time when things were heating up and I grabbed the board to put it outside the enclosure and burned myself on them. I think all three were getting hot. I put an infrared thermometer on them and they were in the 180o-200oF range. We have been heating the bed to about 65o-70o. This seems to be a new problem to pop up without having solved the thermal runaway issue.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 10, 2018 12:55PM
Well as far as I have seen so far from the posts here it seems like it's really all one issue just showing its face in a few different ways. Best guess at this point is just MOSFETs overheating and/or not getting properly 'triggered' to open the gate (all MOSFETs have three pins the source the gate and the drain, if you 'open the gate' with voltage then you allow current to flow from the source to the drain, this is the 'on' state of the mosfet should also see a LED next to the MOSFET turning on when the MOSFET turns on I believe). I would turn everything off and try bending those mosfets such that they aren't touching anything around them and aren't touching each other ideally. One of the MOSFETs controls the heater on the bed the other one typically controls a variable speed controlled fan and the third controls the hot end heater cartridge itself (if I recall correctly) so if say one is already pretty close to it's 'cut off' temp and another one near it kicks on and adds a bit more heat in the area it could be causing them to overheat or no longer work properly... short term solution try moving them or adding small heatsinks to them, probably better solution is to 'upgrade' them to better MOSFETs that can handle the current without issue (only a few dollars but would need some solder wick and other soldering stuff to get the existing component out and replace it. Other alternative option is just replace the RAMPs board entirely. Either another RAMPs ideally with upgraded MOSFETs or with one of the clones that has good ratings usually sold as MKS boards like MKS 1.3, downside with switching boards is the connectors typically aren't the same so end up needing to either buy new or replace the connectors manually and need to learn to edit/flash the firmware (probably more tedious than replacing the component on the one you already have)

Also side note I typically run at 60degrees C at hottest on my bed and don't have the thermal runaway issues, if you are using PLA you typically don't need the bed to be nearly that hot I've printed without issue on 40 degree C beds with PLA. With ABS I use "ABS slurry" to keep the part well secured to the bed while the print is happening and to fight the warping action as the part cools.

---

Extra notes/options...

If you wanted to replace the MOSFETs apparently these are the recommended ones
[www.newegg.com]

You could also likely just modify the firmware to allow it to drop in temp for longer before giving a thermal runaway you would need to edit the Configuration.h file to change this line
[github.com]
You probably want to start with whatever source code came with your kit though since I've modified my printer and Configuration for a new hot end and some other small changes.

You could also disable the bed thermal protection entirely [github.com] but this could make the printer more of a fire hazard in a situation where the bed temp sensor gets disconnected (pretty likely due to bed movement) I'm not entirely sure. Also any changes that allow the temp to change more is going to give the plastic on the bed more of a chance to warp from the change in temperature. Overall this is the worst option but I imagine would work (I would monitor the printer closely in any case).

Edited 3 time(s). Last edit at 04/10/2018 07:28PM by wafflejock.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 11, 2018 05:13PM
Just completed the first successful print in over a month!!

Thank you for your suggestions. I ended up separating the MOSFETs as well as putting a small cooling fan on the RAMPS just in case.
I will likely still swap out the MOSFETs in the future. I also tweaked the firmware as you suggested giving things a little more wiggle room which it seems to only need in the first 5 minutes of printing. Finally I dropped my bed temp down to 40oF as you suggested.


Hopefully the worst is behind us and we can have some fun.
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 13, 2018 04:39PM
Glad to hear it! smiling smiley I decided to try upgrading my own setup after reading up more on this issue it seems there are some safety concerns with the amount of amps being pushed through some small traces on the RAMPS 1.4 version of the board (hard to say if it's just fear uncertainty and doubt spreading, but figure it's worth trying something new anyway). I'm going to try out a GT2560 board that has some upgraded components including heatsinks on the MOSFETs and uses a ATX/Molex style 12V connector for the 12V power coming in which I feel more confident about than the screw terminals. Unfortunately this means swapping a lot of connectors on motors/switches/temp sensors, but will post back again once I see how that operates (also have some updated stepper drivers the 8825 [www.pololu.com] which can apparently run the motors a bit quieter). Anyhow glad you got it working for now and will let you know if I find any more info about using these updated components (also got upgraded mosfets I may try on the old board just to see the difference temp wise on those).
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 26, 2018 04:39PM
Hey Nick, I have built one of your printers and am to the point where I am testing extrusion.

I'm using Repetier host.

The heated bed heats up past the temperature I set it to in manual control and the machine won't move to begin the print ( probably because the machine is waiting to hit some preset temp, but I don't know where that is )

Yesterday was the first time I tried to turn the heated bed on.

I have been able to move all the axis with no problem for a while.

Thanks!
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 26, 2018 05:17PM
Not sure who this Nick guy is but there is a check in the default firmware for min temp on the hot end before it allows the extruder motor to run. Default is 170C for min temp assuming the prevent cold extrusion is uncommented there like shown in my copy of Marlin here:

[github.com]

Note don't use my configuration since I've upgraded by hot end and changed the main controller board and stepper drivers which all resulted in tweaks to the Configuration.h file.

FYI the normal behavior (printing from repetier or cura or octopi) is for the printer to activate the bed until it hits and holds around the target temp can see the specific values it uses to determine if it is 'close' and how long it needs to be around that target value to consider it 'success'

[github.com]

Once it 'sees' that the heated bed is up to temp it will kick on the hot end heater until it also hits its target temp and then it will typically start printing (depending on which software I used to create the gcode for printing it may have homed before or after the heating processes)
Re: RepRap Guru i3 Printer Kit (Official Thread)
April 26, 2018 05:26PM
Just wanted to follow up on the GT2560 and stepper driver updates too. In the end I am pretty happy with having replaced the arduino+ramps 1.4 with the GT2560 that has everything baked onto one board and adds some power/safety features with fuses and heatsinks on the MOSFETs. The temp comes up much more quickly and is rock solid with regard to stability so much happier with that. The re-wiring to add all the JST-XH connectors on everything was a pain and I messed up the order of the stepper motors so had to redo those on top of it all. After updating the stepper drivers to ones that support 1/32 steps had to double all my steps per mm values but it is printing really close to accurate sized calibration cubes so that's worked out well (not sure upgrading these is worth it since benefit is basically quieter printing doesn't do much if anything for performance/resolution).
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 02, 2018 01:13PM
So the stepper motor for my extruder died and I'm looking to get a replacement. Is all that I need a NEMA 17 or is there specific specifications I should be looking for. The one I have currently is labeled as KS42SH40-1204A. Should I get this specific motor and then it is just a simple swap and go. Is there something I should get that is better? If I'm going to replace the motor and there is something better then I might as well upgrade.
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 02, 2018 01:44PM
With a "NEMA 17" that is telling you the dimensions of the box it's in, in terms of height and width (1.7") but doesn't tell you anything about the depth of the motor. The deeper/taller the motor is the more wires in the coils and the longer the magnets so the more torque it will have for holding force or turning, that said extruder motors don't typically need to push extremely hard or work against anything except the back pressure of the filament itself going through the nozzle so basically any 'regular' one will do (would avoid the 'pancake' ones that are super flat looking since you are giving up all the torque but don't need anything special either really).

Regarding wiring just be sure the printer is shut off when connecting/disconnecting the stepper wires as it can fry some of the components (imagine the stepper drivers) if the wires are powered while connecting/disconnecting. All of the NEMA 17 motors I've seen use the two pairs of wires for the coils inside but in some cases the order of the wires can be swapped, fixing this is typically pretty easy if you can pop the pins out the connector and swap them around but just heads up they're not always the same order (usually labelled as 1A 1B and 2A 2B for coils 1 and 2 I believe)
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 02, 2018 02:47PM
Good to know I'm looking at this one. It seems like it might be 2mm shorter at 38mm than the one I have now. Form what you said it doesn't sound like that will be a problem. This one looks to he the same height at 40mm but the cords are attached to the motor, I don't know if that is a problem.
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 02, 2018 04:03PM
Yup either way works so long as you can push the pins out of one side of the connector you can still swap them around if need be so shouldn't be an issue. Absolute worst case scenario can always cut and splice the wires between the connectors too, but just more work than lifting the plastic clips and pulling the wires out of the connector usually.
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 28, 2018 11:15AM
Does anyone from RepRapGuru still monitor this forum? Does anyone know what's going on with RRG? Their printer prices on Amazon have gone crazy, ranging from below $140 to over $300 several times in the last few months. I bought one in October (my third... long story) and two of my friends each bought one in November. But support from RRG seems a little lacking, their parts inventory is getting depleted, and when one of my friends ordered a part from them, the PayPal payment went through the Philippines. Not what one would expect from a North Carolina company. And he's still waiting for his part.
Re: RepRap Guru i3 Printer Kit (Official Thread)
November 28, 2018 11:20AM
The RRG originally shipped with a 213x213mm borosilicate glass plate, with beveled corners. It now ships with a 200x213mm plate, which seems to be the standard size plate for this size heatbed these days. Since it doesn't fit particularly well, I bought a 219x219mm plate from Gulfcoast Robotics, which is OK, but again doesn't fit quite right (although the beveled drop nicely between the screws), and in addition is quite a bit thicker than the 200x213mm one, which means I can't swap them out without tedious z-end stop adjustment. Does anyone know of a source for a 213x213mm glass plate with beveled corners?
Re: RepRap Guru i3 Printer Kit (Official Thread)
December 03, 2018 01:14PM
I got myself a MK3 original kit after a few years with the reprap guru kit learning and upgrading I decided to just wholesale replace it... I am not disappointed. The MK3 is an incredible upgrade (I know it should be given the price difference, but it is a massive improvement). Now working on "upgrading" or really replacing most the parts on my RepRap Guru machine, will post back here once it's complete, will be a pretty far departure from the original machine since I basically replaced everything over the course of time but might still be a relatively budget friendly machine and hopefully near on par with a CR-10 or MK2S (using an AM8 kit for upgrading the frame, GT2560 main board I had previously upgraded my guru kit with and E3D v6 I had also upgraded from the original hot end, basically the motors and end stop switches are going to be the only original components from the guru kit, still will have the soul of the DIY machine).

Edited 1 time(s). Last edit at 12/03/2018 01:15PM by wafflejock.
Re: RepRap Guru i3 Printer Kit (Official Thread)
December 05, 2018 04:36AM
Lowes, glass cutting section, will give you any size glass you want. I acquired glass for 3 of my machines that way very cheaply (2 203mm plates for ~$3.99, since the waste was exactly the size of another plate). Your application will likely only yield one plate, but this is still the cheapest, easiest, and quickest way to acquire glass of your specification.
Re: RepRap Guru i3 Printer Kit (Official Thread)
December 18, 2018 11:45AM
Are there any recommendations for replacement of the print bed mount. I would like to switch it for a 3 point adjustment instead of the existing 4 point. I have had a terrible time trying to get everything the bed level with the 4 points of adjustment. It's close but still not perfect and I fear if I go to get it perfect I will mess it up worse and end up having to start over. Also thinking of switching to a BLtouch for my z-stop. Any thoughts or suggestions? What challenges would I have in doing this? Thanks
Re: RepRap Guru i3 Printer Kit (Official Thread)
December 27, 2018 10:25PM
In the hope someone else can use it too, I've put my Marlin 1.1.9 configuration files for the RepRapGuru printer up on github: [github.com]
Re: RepRap Guru i3 Printer Kit (Official Thread)
December 28, 2018 12:42AM
Regarding the print bed mount my acrylic one warped some after being in a heated enclosure so I replaced with a sheet of thin steel from the hardware store. Ideally just get one that is sized right at least in one dimension and then can just cut down one edge to get it to size, I cut mine with a Dremel metal cutting tool and lots of patience (also some bending like a credit card to snap off the metal in the end). I think I used 1/16" steel but whatever rigid material you can get and cut to size will work. I used the acrylic as a pattern for where to put holes for the bearing mounts and just make sure it is centered and "square" by holding it in place where it will go to line up the bearing mounts/acrylic and new "y-bed". Only thing I'm not sure about is putting a hole in the heater pcb for a middle screw adjustment point for a three point adjustment but if you give it a go let us know how that does or doesn't work out. Personally got some stiffer spring and adjutsment screws and working on hooking up bltouch sensor for mesh levelling.
Re: RepRap Guru i3 Printer Kit (Official Thread)
January 02, 2019 09:03AM
Hi,
I am new to 3D printing. I received from a friend a I3 I think V2. I had to replace these parts.

Elegoo EL-CB-003 MEGA 2560 R3 Board ATmega2560 ATMEGA16U2 + USB Cable for Arduino
[Sintron] 3D Printer Controller RAMPS 1.4 Arduino Mega Pololu Shield for Reprap Prusa Mendel Arduino Mega2560
[Sintron] 5 Pcs A4988 StepStick Compatible Stepper Motor Driver Module with Heat Sink for 3D Printer Controller RAMPS 1.4 Arduino Mega Pololu Shield Arduino RepRap (A49885)
[Sintron] 3 pcs Mechanical Endstop Module V1.2 for 3D Printer RepRap Prusa i3 Kossel Delta etc.

Reason I replaced the parts was when 1 motor was coming off the limit switch it would disconnect from the computer. As cheap as the parts were I decided to replace all of them. Also I had a broken limit switch.
This is the filament I bought.
SainSmart Black Flexible TPU 3D Printing Filament, 1.75 mm, 0.8 kg, Dimensional Accuracy +/- 0.05 mm

The machine moves and does everything it should. I tried everything in manual mode and then ran a part and everything moves and runs through the motions , but the filament doesn't extrude. The bed is on temp(70) and the head is heating up to 230. It extrudes in manual but will not work when printing a part. I'm sure its a setting somewhere, but I can't find it. The manual seems to be an older one(Downloaded it from RepRap site), but in Repetier Host it doesn't seem to cover all the settings. I believe the manual was made using an older version.

Problem 2 my LCD lights up bright blue but does not show anything on the screen. I checked all the wires and connections. From all the posts in here I am thinking it also might be a setting or somewhere I have top turn it on or tell it which LCD I have.

Any help would be greatly appreciated.
Re: RepRap Guru i3 Printer Kit (Official Thread)
January 08, 2019 09:09AM
Update I adjusted the contrast on the back and got the LCD to work. I also got to print. I had to add M101 to turn on the extruder and M103 to turn off the extruder the Gcode. I have added those in the gcodes page under setting, but would have thought that it would have processed through the slicer. Just curious if I need to be running a different slicer. Also my part changes slightly when running it through slicer3. Just curious if anyone has some input or can help a noob out! lol
Re: RepRap Guru i3 Printer Kit (Official Thread)
January 08, 2019 12:03PM
Hi Teckincal,

Glad to hear you sorted out your LCD issue sometimes can be reversed cables or other things but you got it corrected before I had a chance to start guessing smiling smiley

Regarding the extruder on and off I haven't seen that issue myself but I just followed the PDF guide when I first built my machine and used whatever version of repetier they had linked and did the config as explained in the guide and that all just worked for me. That said the slicer software can be configured to add gcode for a given printer or for a given filament selection and it will add those snippets to the beginning of the sliced model paths in the gcode file it generates when you run the slicer. If you are using curaengine/cura it will have different default settings and create a different tool path in the gcode than slic3r defaults (really it will be near impossible to get them to produce exactly the same gcode since they are different code bases they process the code differently). That said if you play with the configuration in slic3r or cura you can get either to work with basically any 3d printer. At work right now but will send my config snippet for slic3r, I'm using the prusa edition of slic3r since it's a bit more up to date than the regular release and I just got a MK3 so that version of slic3r is preconfigured for that printer and was pretty easy to add a config/settings for my upgraded i3 reprap guru machine.

So long story short, different outputs from different slicers expected, need to add custom g-code for printer is somewhat expected but think it should have been part of the setup guide, I'll send what software versions and config I have setup so you have something to compare to or start with after work.
Re: RepRap Guru i3 Printer Kit (Official Thread)
June 24, 2019 04:21PM
Quote
fjbailey3
Does anyone from RepRapGuru still monitor this forum? Does anyone know what's going on with RRG? Their printer prices on Amazon have gone crazy, ranging from below $140 to over $300 several times in the last few months. I bought one in October (my third... long story) and two of my friends each bought one in November. But support from RRG seems a little lacking, their parts inventory is getting depleted, and when one of my friends ordered a part from them, the PayPal payment went through the Philippines. Not what one would expect from a North Carolina company. And he's still waiting for his part.

I think the company is essentially dead, and I'm pretty sure that some shady party has managed to take possession of their support e-mail address. Calls to their posted phone number are rejected automatically and I haven't received responses to my support requests. What I did receive was a call from a California number wanting to follow up on my support request and claiming to be a part of the "RepRap Third Party Support Team". After some very light technical conversation, the caller began promoting their discounted upgrade parts and promised to send me an e-mail with details. I link it as an image to preserve the sublime formatting of their message.



So yeah, maybe find somewhere else to buy parts.
Sorry, only registered users may post in this forum.

Click here to login