Welcome! Log In Create A New Profile


Communication problem

Posted by graybeardtx 
Communication problem
May 07, 2016 06:50PM
I have one if tose Chinese RepRap clones (Omni M-505 - Prusa I-3) and suddenly have a problem communicating with the system via the direct link provided via the program setups. When I try to connect through the USB connection, I get an error.
The screen shot from Pronterface shows the communication as being a bunch of gibberish.

If I use the bare bones interface I get the following:

Most of the information I have read says this is usually a mismatch in communication rates. The default rate for the firmware (Repetier) is 115200
and that is what is set in the machine settings in Repetier and Pronterface.

I can still function using offline mode but I do some things with Pronterfacce and would like to correct the problem.
Re: Communication problem
May 09, 2016 11:58AM
Try 250000 baud. That is what my Chinese clone was set to and is the default for Marlin at least. I changed it to 115200 when I installed my own changes via Marlin.
Re: Communication problem
May 11, 2016 11:35AM
I tried that baud rate with no luck. This problem suddenly appeared. The printer was working with the out-of-box settings. I had used the manual
control function of the Repetier program several times successfully at 115200. When I tried the program again to manually reposition the print table, I was unable to establish a connection between the computer and the printer.

I suspect that the firmware got corrupted somehow. I'm trying to learn how to update the firmware but progress is slow. I am a user with very little Arduino knowledge and the instructions tend to be rather cryptic to me. The discussions are more programmer to programmer and I get lost quickly.
Re: Communication problem
May 11, 2016 12:45PM
I suppose it's possible that this could be caused by the new M$ FTDI drivers which refuse to function on counterfeit FTDI chips. Since it happened out of the blue, it could have been a windows update. The only way I could think of to check would be try to connect with a linux machine.
Re: Communication problem
May 11, 2016 04:34PM
I'm running this on WInXP so I doubt it is due to an update. I also tried using my WIn10 notebook and got the same errors. That points to a problem with the board/firmware.
Sorry, only registered users may post in this forum.

Click here to login