Z Axis homing issues
July 08, 2016 05:13PM
I had my folger tech up and running perfectly. I wanted to adjust something in the firmware, but I don't think that I previously saved my firmware from when I had it working. So that is an issue because it now doesn't want to work. I had the problem before, but I somehow fixed it and I didn't remember what I changed. My z axis doesn't want to lower to the endstop. When I home it the motors don't work at all. I know that it has nothing to do with the hardware because I previously had it working, but it has something to do with the homing. I sent a m119 command the the endstop logic is correct. The axis will move up and down as if it is at the zero point, but is at some arbitrary point along the axis. My circuit board did look like it might have overheated the other day, but I don't think that effected anything because the motor still work perfectly, the only time that the don't work is when I send a z home command or try to move the axis below the arbitrary "0" that it has set. I have tried the g92 command and changing the feedrate of the z axis.

here is my firmware:


Thanks for your help!
Re: Z Axis homing issues
July 09, 2016 04:47AM
Check your homing direction.
you need to tell it which way the home is. This is determined by your end stop location. MIN or MAX.

// Sets direction of endstops when homing; 1=MAX, -1=MIN
// :[-1,1]
#define X_HOME_DIR 1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1
Sorry, only registered users may post in this forum.

Click here to login