Welcome! Log In Create A New Profile


Pantech Prusa i3 grinding issue

Posted by kyfho 
Pantech Prusa i3 grinding issue
July 23, 2016 01:29AM
Hi guys - I am new to 3D printing and purchased a Pantech Prusa i3 printer kit from ebay recently


I am having a lot of problems with this printer and was hoping someone could please help.

I have only been able to complete 1 print properly. Ever since, no matter what I do, the printer sounds like it is grinding the filament. When I have the filament going through the bowden tube only it is fine and extrudes properly. I then put the end of the filament into the nozzle and thats when the problems start. I have tried adjusting the nozzle temp from 210C to 230C, I also tried replacing the tube thinking that it was getting stuck in the tube but that did not help either. I am using 1.75 PLA.

Any help would be greatly appreciated.

Re: Pantech Prusa i3 grinding issue
July 31, 2016 07:53AM
I am having the same issue with that model.
where you able to figure it out?
I will let you know if I find a solution on my end.
Re: Pantech Prusa i3 grinding issue
July 31, 2016 08:30AM
Dear All,

We been told you two guys had some problem from our PanTech i3 model 3D Printer model there.
Would any one can give us a bit more info such as a video to have a look? We are always here to help our customer and welcome other expert to help us together.
thanks in advance.
Re: Pantech Prusa i3 grinding issue
August 01, 2016 07:55AM

I tried it twice tonight and had the issue both time and had to unclog the nozzle.

Re: Pantech Prusa i3 grinding issue
August 01, 2016 08:30AM
Can you edit your firmware? First you do is tune down your acceleration values to 1000. (or lower)

Why this jam happens?

There is one reason and it happens in two different ways.

First reason is that your extruder is not able to push the filament out as fast as it should.
This means you are trying to extrude unmelted (raw filament) filament and you end up grinding the filament and ruining the print.

Second reason is you are trying to extrude filament that has melted too much and it blocks your tube. You end up grinding your filament, because the tube is blocked.

The trick here is to lower your acceleration values, so your hotend can handle what your cold end is trying to push through.
This also means, that once you push filament to the hotend, you need to make sure it comes out immediately.

Default speed settings from Slic3r is shit. It slows down too much from the top speed, so your filament suffer the second reason. It is heated too much and blocks the tube.

All the speeds should be 40-60mm/s so the plastic juices are flowing constantly. There is no time to stop to raise the Z while retracting. Just let it run after you adjust the acceleration values to something that the printer can handle. (1000 or less and XY jerk to 5)

EDIT: and as usual, make sure your X/Y/Z/E -steps are calibrated correctly.
None of the above will work if the steps are shit. smiling smiley

Edited 3 time(s). Last edit at 08/01/2016 08:43AM by Veesta.
Re: Pantech Prusa i3 grinding issue
August 01, 2016 09:20AM
thanks for getting back to me.
you can find the gcode use here

I sliced it with simplify3d.
I will try to change those values after work
Re: Pantech Prusa i3 grinding issue
August 02, 2016 05:22AM
when I try to compile and upload, I'm getting this error:

Arduino: 1.6.10 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch\Marlin_main.cpp:2121:36: warning: invalid suffix on literal; C++11 requires a space between literal and string macro [-Wliteral-suffix]



In file included from sketch\SdFile.h:27:0,

from sketch\cardreader.h:8,

from sketch\Marlin_main.cpp:44:

SdBaseFile.h:38: error: using typedef-name 'fpos_t' after 'struct'

struct fpos_t {


In file included from sketch\Marlin.h:10:0,

from sketch\Marlin_main.cpp:30:

e:\program files (x86)\arduino\hardware\tools\avr\avr\include\stdio.h:950:33: note: 'fpos_t' has a previous declaration here

__extension__ typedef long long fpos_t;


exit status 1
using typedef-name 'fpos_t' after 'struct'
Re: Pantech Prusa i3 grinding issue
August 03, 2016 07:54AM
I downloaded the latest Marlin firmware and changed some values before uploading it.
2 hours in, and it's still printing. I do have other quality issues that I will have to fix, but at least, I am able to print something now.
I will upload my firmware. feel free to check it and tell me if I used some wrong values.

Re: Pantech Prusa i3 grinding issue
August 03, 2016 08:11AM
ok, the issue came back 10 minutes later................... angry smiley
Re: Pantech Prusa i3 grinding issue
August 04, 2016 08:10AM
In your video the drive gear isn't actually rotating its just oscillating back and forward. That usually indicates insufficient current to drive the motor. Check/adjust the current by tweaking the drive settings on the control board.
I wouldn't say you can hear grinding but you can hear motors "buzzing" when they are under current.

If you can I would shorten your Bowden tube. The longer the tube the greater the time delay between the extruder action and the hot end + retract distances get larger.
Re: Pantech Prusa i3 grinding issue
November 12, 2016 12:33AM
the issue was coming from the hot end.
This is what happens with cheap products. I got myself a better one and no issues anymore.
Re: Pantech Prusa i3 grinding issue
August 30, 2017 04:52AM
Holycause, I too have a Pantech Prusa i3 purchased around the same time. For safe fallback I was able to extract the manufacturer firmware using avrdude before uploading latest Marlin firmware. I find that the SD card doesn't work correctly after updating. The SD card can be interrogated from serial monitor but the control panel says "No card". Trying your 1.1.0-RC7 code with Arduino 1.6.10 I find the SD card still doesn't work, yet works fine with the original manufacturer firmware.

Did you also find that the SD card doesn't work after updating firmware? If so have you figured out the reason for this? It appears that card.cardOK() is returning false but I haven't tracked down why just yet.

Any help would be greatly appreciated.
Re: Pantech Prusa i3 grinding issue
August 31, 2017 04:01PM
no didn't have that issue.
have you tried with another sd card?
Re: Pantech Prusa i3 grinding issue
August 31, 2017 07:39PM
Ok, well that's interesting.
Given that the card works perfectly (?) with the manufacturer installed firmware I had not tried another card.
On your suggestion I just tried another card and get the same result. Control panel menu screen says "No card".

Knowing that you did not have the same issue rules out software I guess. I'll take a closer look at the SD card socket soldering, I have read of users having issues with SD connections.

Re: Pantech Prusa i3 grinding issue
September 22, 2017 04:52AM

I'm wondering if you ever actually used the SD card? After more investigation I decided it had to be a firmware issue. Eventually a friend and I discovered a typo in the Marlin code (still present). The code intends to check the SD card using definition SD_DETECT_PIN. However, when the pin is accessed they left off the "_PIN" suffix, so, in ultracd.cpp, they check for SD_DETECT. As a result, the detect pin on the card is never looked at and the control panel says "No card". There's some waffle in configuration_adv.h about SD_DETECT_INVERTED but I'd say it's all bollocks and due to the typo.

After fixing the typo my SD card works fine regardless of whether SD_DETECT_INVERTED is enabled or remmed. However, there's a new bug now, I am getting "Click to resume..." messages that I never got before.

Sorry, only registered users may post in this forum.

Click here to login