Welcome! Log In Create A New Profile


HELP! First timer stuck.

Posted by sszeliski 
HELP! First timer stuck.
July 30, 2016 03:53PM
I will start off by saying this is my first experience with 3d printers. I am an auto mechanic, not a small electronics guy.
I have 20 hrs of C++ programming experience and have been through the arduino beginners 15 projects so i am more comfortable with Arduino than someone with no experience but I am still very green.

My issue is this:
After assembling my HICTOP 3DP-18 Kit(with the little known MPX.3 board, similar to MKS base boards), none of the axis will move. I try to use the Prepare>move axis>move.1mm>x axis, and i get a clunk from the motor and one or two degrees of movement then nothing. If i keep "moving" it with the knob, nothing will happen. If i power down the printer and restart it, i can get the same behavior again. This is with the motor not loaded(not connected to the belt). behavior is same for all motors including extruder

What should i try?
What i have tried:
contacting HICTOP for a copy of the firmware. Loaded the supplied .hex file using xloader, no change.
Using a different board, OSOYOO MKS Base v1.4 board. Loaded their firmware, no change
on both boards i made sure the motor voltage was set as per this video [www.youtube.com]
Repinning the motor as per the WIKI which said coil pairs should be next to eachother on the driver on the board(not staggered ABAB if A is one pair and B is other, This is how the wiring arrived) No change, clunk was slightly smaller
Moved pins back to original...
Moved endstops to other two pins on connector(came with two wire leads going into 3 wire connectors on board) Moved endstop form x- to x+ no change
I have tried other stuff but i dont want to make this post too long so im moving on.

I have done Lots of searching around on this topic and no one seems to have the same problem. Most troubleshooting is based on the assumption that the motors move but behave unexpectedly.
In my searching, some answers have pointed to too high of an acceleration.(i will need help adjusting this if this is the case, i tried cutting the MAX ACCELERATION in Marlin in half, but that was just a shot in the dark, idk how to adjust) no change

I will do my best to answer your questions but i may frustrate you with my inexperience in this world.

Thanks in advance for your help reprap community.
Re: HELP! First timer stuck.
July 30, 2016 11:18PM
Have you tried to push the carriage so it triggers the end stop before you try and move it? It sounds like an end stop thing to me. I had issues like that from end stops and fixed it by fumbling around until it worked so I can't suggest much.

Newbie with Folgertech 2020 i3.
Re: HELP! First timer stuck.
July 31, 2016 08:34PM
First, don't give up! I built a Prusa Mendel i3 from scratch and spent an enormous amount of time in the process. Since then, 2 1/2 years ago, I have sunk more massive amounts of time into calibrating it, which never quite achieved what I was hoping for, and just recently upgraded the hot end and adding a heated bed (which I have not succeeded in getting turned on). Oh, and I found getting good assembly and Marlin instructions was like a quest for the Holy Grail. I have a post pending that has about 45 views and no responses, so sometimes it feels like there is no help out there. As for me and my humble experience, I would double and triple check the wiring on your stepper motors. Even with some crappy technical wiring diagrams, it seemed to take forever to get the wire sequence right. And I agree with the other fellow, if your end stops are wired with the normally open vs normally closed backwards it can be frustrating. My experience is that the motors either run or they don't. I have not heard of them just twitching. Nuff said, never give up!
Re: HELP! First timer stuck.
July 31, 2016 09:36PM
Pronterface would be more helpful to diagnose this.
Move your axis from pronterface and look what it says on the right hand column. It might say "endstop hit" so it will not move at all.
Sending m119 will report back the status of the endstops.

If you see that it is not touching the endstop, you might need to revert the endstop logic from the marlin configuration.h

Also notice that the endstops are either MIN or MAX. The position of the endstops determines which one it its. You need to comment out the non used endstops and enable what you are using in configuration.h
Be sure to put MIN and MAX endstops to correct pins in your board. MAX endstop will not work on MIN pins will not work on MAX pins. smiling smiley
//============================== Endstop Settings ===========================

And, there is a setting for homing direction. This setting points to the endstop and you need to set it either MIN or MAX. This tells your printer which way the home is, so it can go there.
// Sets direction of endstops when homing; 1=MAX, -1=MIN
// :[-1,1]

Edited 1 time(s). Last edit at 08/01/2016 07:10AM by Veesta.
Re: HELP! First timer stuck.
August 01, 2016 01:57PM
To avoid crashing an axis, the firmware hesitates to move the axis much unless it's been homed. Try auto homing the axes before moving them.
Re: HELP! First timer stuck.
August 02, 2016 03:13PM
So I figured it out.

As you can see in the first post, I tried repinning the motors to what the wiki said.

The supplied(preassembled) wires went like this Green Red Black Blue(motor side)>>>>>>to>>>>>(board plug)Grenn Blue Black Red.
And the "pairs" for the coils were right next to each other with one pin blank in between(6wire motor). So Green and Red should have been paired at the board as well as Blue and Black.

I was tired when I repinned the first time so I swapped the outer two wires and it didn't help.

Later in the afternoon, after returning the wires to factory and posting this, i looked at it again and realised I had swapped the wrong two.
Swapped the middle two wires and the motors moved. In the proper direction.

I wanted to make sure there were no other issues before posting this, but this morning i completed my first print!

Came with wires assembled wrong but that was literally the ONLY issue to get the thing running. Tech support was present and helpful but hard to communicate with, and my bed may be a bit warped on arrival. I will check that with my machinist straight edge when I take off the bed to LocTite the bolts.
While troubleshooting, tech support supplied me with a hex firmware and the whole marlin folder, both work beautifully.

I would still recommend it to reprapers who want a more plug and play solution than building from scratch.

THANK YOU EVERYONE for your responses and happy printing!

Edited 1 time(s). Last edit at 08/02/2016 03:13PM by sszeliski.
Sorry, only registered users may post in this forum.

Click here to login