Welcome! Log In Create A New Profile


Geeetech Prusa/I3 Pro B Build

Posted by Graves 
Geeetech Prusa/I3 Pro B Build
August 25, 2016 08:23PM
My first 3D printer arrived a few days ago. I got a GeeeTech Prusa I3 Pro B. It fit the budget and time-frame etc. I watched a few hours of various unpacking and builds and did my best to pay attention to the positives and negatives listed.

Overall, everything appears OK so far. Not great, but definitely not really that bad either. I found a few extras in the box, like a filament holder and a tiny tool kit. Nice little surprises.


One of the first things I noticed about the reviews has proven true in my case as well. The build instructions are a bit odd. I've read them cover to cover a few times and I think they will be fine overall, but they are definitely a bit odd in places. The Y-Axis frame assembly involving four pieces of acrylic, two threaded rods, two smooth rods and two captive rings, is covered in a sentence and a half with one picture, shown in an angle that hides more than it helps. The next step for the Y belt tensioner (a bracket a bearing and one screw) has four pictures from different angles at different stages of construction.

Which brings me to the whole point of this post, actually...One of the Y-Axis frame rods that holds linear bearings and will eventually support the build platform is slightly crooked. Specifics: an M8 rod 390mm length and roughly a third of the way down it shifts and when rolled across a smooth surface it shows a deviation of just less than a millimeter at the tip.

How badly will this affect printing? I can easily continue the physical build with that level of deviation, but this is the first precision machine I've built. Should I stop now and wait for a replacement to be sourced? Or, roll with it for the build, and use the whole thing as a learning curve for the future?
Re: Geeetech Prusa/I3 Pro B Build
August 26, 2016 09:59AM
I would build it as it is and get a replacement. It will cause a small deformation of prints but probably not noticeable for most things. I would put the bend at the top end.
Re: Geeetech Prusa/I3 Pro B Build
September 01, 2016 09:26AM
Finally got a few days off from work, so I'll be continuing the build today.

Ralph, Thanks for the help.
Re: Geeetech Prusa/I3 Pro B Build
September 01, 2016 11:52AM
I read a review on my Geeetech printer that mentioned that this was a good kit if you are willing to 'tinker' a bit during the build.

Very accurate. I just installed a limit switch and the bracket for it is slightly recessed. It fits nicely and is positioned well, unless you want to use the crimp connectors that come with it. I can either solder the connectors, which would easily work, or I could Dremel off about an eighth of an inch of acrylic to form a channel.

Laser-cut acrylic is very sharp and I didn't even notice the slice on the palm of my hand until I washed my hands for lunch.

Si, I'm gonna Dremel the acrylic for revenge.
Re: Geeetech Prusa/I3 Pro B Build
September 02, 2016 03:04PM
Well, the physical build is done. Now is the time for real troubleshooting.

I've updated the firmware, as per the Geeetech forum advice and I'm still having serious issues with the motor control and limit switches.

Using the Repetier software, it's whats recommended and I don't know any better yet. What I can observe is this:

-The extruder will run in one direction and once it hits the limit switch on the left side, it's not going anywhere. It appears that when I try to backtrack in the other direction, according to the serial data that the X-limit is being triggered repeatedly.

-The Z axis limit switch does nothing. I'm still reading through Geeetech forums and may try a different position on the board or swap switches to see if I have a bad one.

-Directions on X and Y were/are reversed and since there is an option in Repetier to swap them I tried that. It corrects the directions as far as moving the extruder, but not the problems that result.

-Y axis limit switch works, unless I hit the Home button on Repetier, then it shoves the carriage back and grinds for about five seconds before stopping. If I am moving the carriage in increments through Repetier, the limit switch performs perfectly.

edit - I'll be cross posting this over on Geeetech forums to see what they can recommend as well. Thanks

Edited 1 time(s). Last edit at 09/02/2016 03:05PM by Graves.
Re: Geeetech Prusa/I3 Pro B Build
September 04, 2016 12:46PM
I followed a few recommendations from Geeetech and here's the results:

When I turn the printer off and disconnect it from Repetier, manually home the three axis (axises? axies? Plural of Axis? Anybody?)...

I understand the home position to be with the Print platform to the back (against the Y limit switch), Extruder to the far right opposite the X limit switch and the Extruder support rails fully down, resting on the Z limit switch.

When I turn the printer back on and reconnect Repetier I see the following: Y and Z axis will move correctly, though I did need to reverse Y in Repetier. However, X remains problematic. It will move left and right perfectly well, until the X limit switch is hit. Then it will not move at all. The serial data states "echo:endstops hit X:209.99" If I hit the right arrow, to move the extruder away from the limit switch, nothing physically happens. The echo:endstop message will actually count down X:209.98, X:209.97 etc. But until I power cycle and physically move the extruder back to the right, nothing happens.

I have tried moving the limit switch from the Min position to the max position, no change. I have tried reversing the direction of X, it recognizes the direction change, but no change in symptoms. Once the limit switch is triggered the X will not move.

I tried the manual gcode to see the state of the limit switches and when the X_min is open, it shows open, when I push down on the switch it shows TRIGGERED. Based on that I believe that the limit switch is functioning properly.

One suggestion was to see if it responded the same between the PC controls and the LCD controls, unfortunately the LCD does not display anything...ever. It lights up when powered and flickers a bit when connecting to Repetier and thats it. Lovely.
Sorry, only registered users may post in this forum.

Click here to login