Welcome! Log In Create A New Profile


Print won't start, stuck at 0% forever.

Posted by Lon 
Print won't start, stuck at 0% forever.
October 19, 2016 02:23AM
This newbie managed to get over the sd card problem, thx to Adrian. Now when i preheat PLA to 190, insert the filament till it run out from the nozzle, the chosen gcode file won't print. LCD show printing, but stays at 0% forever. I did everything the same as in David Dan's debugging video, even moved the axis's manually. Somewhere, somehow i'm doing something wrong, please give some advice.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 04:17AM
the gcode is just text, open it up and read threw it.

The machine just reads threw each line and executes the gcode
You can also manually enter each line and see where it stops.

I suspect it has instructions to heat up a bed and wait till it gets to temperature.

I also suspect you don't have a heated bed, so it will wait for ever.

Look for gcode M190
Re: Print won't start, stuck at 0% forever.
October 19, 2016 04:39AM
Thx for reply Dust. Now that you mention the bed temp,there is a plug on it and it shows the bed temp. Thing is if i touch it with my bare hand i don't feel any heat, so i've tried to disable it cos i work with PLA, but it's still showing bed temp which can be room temp. I do not have the slightest idea how to feed code into this printer.

Edited 1 time(s). Last edit at 10/19/2016 06:21AM by Lon.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 10:07AM
Hi again Lon,

the Anet A8 does have a heated bed, and normally the print file heats the bed before the extruder. The printer will not normally heat the extruder until the bed has reached the set temperature. The printer will do nothing until both the bed and the extruder are at the set temperature and I strongly suspect that this is why your file print is stuck at 0%.

When you do a preheat PLA from the printer menu it heats the bed and extruder at the same time. Is the bed temperature increasing when you do a preheat? It would seem not from what you say and this implies lack of power to the bed heater.

If you view the printer control board there are three green plugs. The board is shown fitted in the video with these at the bottom and my description assumes that this is the case. The leftmost of these plugs is the power supply to the heated bed. Have you connected the red and black wires from the hotbed to this plug? (black wire to the left, red one to the right). This plug is not pre-fitted, only the two wires to the bed thermistor are pre-fitted with a plug at the control board end. Check that you have connected the wires as described and if you have a resistance meter check the continuity of the bed heating circuit and make sure then that the plug is pushed fully home.

Although you can print PLA without a heated bed I find it helps with the long term sticking of the print (see my post Anet A8 I3 - where I'm at). If you don't want to use the bed heater, then you need to set the bed temperature to zero in both the machine settings (this relates to the driver) and in the slicer. If you don't do this and the bed is not working then when the printer comes to the code inserted in the file which says "heat bed and wait until set temperature is achieved" it waits for ever. You will not be able to print using ABS without a bed heater.

As has been said you can edit the gcode file as a text file. If you can't sort things then look for an entry in the file that says M190 S??. This is the instruction to heat the bed and wait until heated where ?? represent the temp in degrees C to heat to. Change this to read M190 S0. You could comment the whole line out or delete it but this might cause problems with the line numbering.


Edited 2 time(s). Last edit at 10/19/2016 10:41AM by Supermec.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 11:23AM
Hi Adrian, thx again for reply. Temp stays the same at 34c with no increase while preheating, this 34c must be room temp i guess.
Regarding the green plug, the black wire is to the left nearest to the side of the board. I've checked continuity from bed to board on all 4 wires, there is a resistance of 100Kohm on the small wires that seems to be correct.
In slic3r i took the slider down to 0 and click OK, but as soon as i load a file to print then the printer moves it back to 60c.
I'm not a coder at all, but i think if i can get a gcode file to load into the printer with a no heat option it will be great, even if i get one i don't know how to load it. Since i will only be working with pla, i would really like to remove the bed heat option completely for now so that i can move on. 3 Days gone and still no print.

Re: Print won't start, stuck at 0% forever.
October 19, 2016 12:27PM
Hi Leon,

1. Use a text file editor such as notepad on your computer to open the gcode file that you want to print (as generated by the slicer).
2. Near the beginning of the file (use find to locate it) you should find M190. This will be followed by a space then S and then 2 or 3 numbers.
3. Change the S??? to read S0. This instructs the printer to wait until the bed is heated to at least 0C which it already is.
4. Save the file.
5. Print it.

The extruder should now heat up and the print progress normally.

Don't be too impatient, it's worth solving the bed problem. Even if you don't intend to print ABS now you may well change your mind at a later date. When you checked the continuity between the red and black hot bed wires did you get a reading? The resistance is very low, only a few ohms. Did you check the continuity from the green plug itself? These can be difficult to get good contact with when fitting. Also (carefully so you don't short out anything on the board) check to see if you have 12V on the hot bed plug when the machine is set to "Preheat PLA".

You need to look through the filament and machine settings for Slic3r and change any bed temperature settings to 0 or look for an enable/disable hot bed and save those changes before slicing. The default bed temperature for PLA on the Anet is 60C and this is what the slicer is trying to impose in the lack of any other over-riding instructions.

Are you running slic3r as stand alone? or from within Repetier Host? If the later then you need to go into the machine settings under config and change the default bed temperature to 0.

Have a look also under the various menus on the printer. It's woth becoming familiar with what's there.


Edited 2 time(s). Last edit at 10/19/2016 12:33PM by Supermec.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 01:00PM
Thx Adrian, i did not write of abs it is just that for the beginning i've planned to do some pla jobs.
I'll check on the advice you gave within the next hour and be back here.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 02:26PM
Thx Adrian you've made my day. It's printing and already on 3% on a 25 by 25 by25 mm cube. It started the print without a problem, only thing i am not sure of is that unlike the previous ext reading of 190c it went up and stays on 250c.

Thx a lot.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 05:16PM
Hi Leon,
glad that has got you started. I'm not quite sure why your extruder temperature should have gone up to 250C. That's far too hot for PLA and sounds more like the setting for ABS. Some of the PLA that I have prints beautifully and happily at 185 degrees.

It may be that the extruder is heating to the default extruder temperature, just as before the file was trying to heat the bed to the default bed temp. Again there are settings for default extruder temperature under machine settings in config and under filament settings in the slicer configuration.

Somewhere near the beginning of the gcode file will be an entry M109 S??? with the S followed by a three digit number, this is the instruction to heat the extruder to the temp given by the numbers and wait until the temperature is reached. This needs to read M109 S190 for the temperature you want to use.

You didn't say how you generated or obtained your gcode file. I strongly recommend that you download and install a copy of Repetier Host 1.6.2 on your computer (note this is not the Repetier firmware). Within Repetier Host you can use either Slic3r or Cura for slicing the STL file. You can view things much better, whether or not you use USB to connect to the printer or simply save the file and transfer it via SDcard. One of the things that it does do, having sliced the STL file, is to produce a verbose listing of the gcode which can be viewed and explains what a lot of the instructions do and enables you to edit them. It also allows you to shift up and down the model and view how each layer will be generated before printing. If you connect to the printer using USB coms it will also display progress on each layer (slightly in advance of the printer because of the input buffer) on screen. You also get a lot of feedback from the printer itself on the computer screen.

I suggest that you try driving the printer via the USB and Repetier Host until you become familiar with everything. It is much easier to cancel the print if things are not going as you wanted and it makes it much easier to see the results of the changes that you are making to settings. The only down side is that it ties the computer up for the duration of the print. I have printed this way OK for print files up to 2 hours long. I haven't tried minimising the program so that it runs in the background while you do other things. This might or might not provoke some coms issues if something else makes heavy demands on the USB system.

Try absolutely simple prints to start with and change only one setting at a time while viewing the results. If you let me have your email I can send you an STL file for a 2cm x 2cm x 2mm test square that will help you evaluate temperatures and speeds. Printing calibration columns is great but they consume a lot of filament.

Where configuration asks you for the filament size don't just put in 1.75mm. There is variation between different makes and sometimes even between different colours of filament. Use a micrometer or Vernier to measure your filament in a number of places along a length and use the average value for the diameter in the settings.

With regard to the printer itself (on the SDcard) and to Repetier, Slicer and Cura there are manuals available. You know what they say "if all else fails, read the manual".

Best of luck

Edited 2 time(s). Last edit at 10/19/2016 05:23PM by Supermec.
Re: Print won't start, stuck at 0% forever.
October 19, 2016 06:21PM
Hi Adrian, yes i will sort out the high temp the same way as you told me with the bed temp where i changed the S??? to read S0...and replaced the original gcode file with the one edited. But i'll do this tomorrow cos it's almost midnight in S Afr.
I am using Repetier, Slicer and Cura now and use the sd card to move gcode files to the printer. I want to print from repetier most of the time cos it's a nice program for a 64year old to try and understand. As a beginner there is so much to learn and it's one day at a time.
I'm glad i came to this forum for help cos if it wasn't for your help and tips, then i don't know. BTW i attach a very bad pic taken with my BB of my first print of a 25mm cube. I'll PM you my email.

open | download - cube bad pic.jpg (43.7 KB)
Sorry, only registered users may post in this forum.

Click here to login