Welcome! Log In Create A New Profile

Advanced

NEMA-17 MOTOR STRONGLY BEEPING

Posted by GabRep 
NEMA-17 MOTOR STRONGLY BEEPING
November 06, 2016 01:53PM
Hi everyone,i'm tryng to build by myself an i3 Prusa 3d Printer
I've already assembled all the pieces,but i'm in serious trouble with the Z-axis motors. If i keep the Vref of the driver (A4988) under 0.877 ,
motors won't be able to go up. Pointed out this fact, i realized that also in this way motors won't work. When i try to start a print,they emit a strong
beep,and then start working properly.But because of the steps they lost with that beep, the extruder heavily scrapes on the printer plan.
I tried to change Vref to any value, to change the acceleration and the speed,but the problem is still there.
please help me,and excuse me for my probably not so correct english,i'm italian
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 06, 2016 05:06PM
can you post your config.h file pls
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 07, 2016 03:20PM
Here's the setting for the Z homing and the speed setting; i think that these are the significant values to fix my problem.
I really hope you can help me

// Use "Z Safe Homing" to avoid homing with a Z probe outside the bed area.
//
// With this feature enabled:
//
// - Allow Z homing only after X and Y homing AND stepper drivers still enabled.
// - If stepper drivers time out, it will need X and Y homing again before Z homing.
// - Move the Z probe (or nozzle) to a defined XY point before Z Homing when homing all axes (G28).
// - Prevent Z homing when the Z probe is outside bed area.
//#define Z_SAFE_HOMING

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT ((X_MIN_POS + X_MAX_POS) / 2)    // X point for Z homing when homing all axis (G28).
  #define Z_SAFE_HOMING_Y_POINT ((Y_MIN_POS + Y_MAX_POS) / 2)    // Y point for Z homing when homing all axis (G28).
#endif

// Homing speeds (mm/m)
#define HOMING_FEEDRATE_XY (50*60)
#define HOMING_FEEDRATE_Z  (4*60)

//
// MOVEMENT SETTINGS
// @section motion
//

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT   {80,80,4000,500}  // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE          {300, 300, 35, 25}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {3000,3000,200,10000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION          3000    // X, Y, Z and E acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION  3000    // E acceleration in mm/s^2 for retracts
#define DEFAULT_TRAVEL_ACCELERATION   3000    // X, Y, Z acceleration in mm/s^2 for travel (non printing) moves
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 07, 2016 06:13PM
with mine, i had to set much lower Z speed to get the z motors to run

eg

// Homing speeds (mm/m)
#define HOMING_FEEDRATE_XY (50*60)
#define HOMING_FEEDRATE_Z (2*60) //<<<this used to be 2*60 untill recently changed

//
// MOVEMENT SETTINGS
// @section motion
//

// default settings

#define DEFAULT_MAX_FEEDRATE {300, 300, 2, 25} // (mm/sec) <<<<<<<slightly slower z feed

try these
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 07, 2016 09:02PM
is this a kit that came with the motors or a complete new build in which case the motors may be too small to lift the load or too big requiring more than the 2 amps available ? what are the stepper motor numbers and if your using 12 volts try using 24 on just the vmot.
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 07, 2016 11:34PM
Might be just bad wiring/connectors.
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 08, 2016 12:41PM
#define DEFAULT_MAX_FEEDRATE {500, 500, 2, 25} // (mm/sec)
Re: NEMA-17 MOTOR STRONGLY BEEPING
November 12, 2016 01:09PM
I changed the values as you suggested and it finally stopped doing that noise!!! Thank you all for the answers,you're great!
Sorry, only registered users may post in this forum.

Click here to login