Welcome! Log In Create A New Profile


Mks base 1.2 z steps per mm not updating

Posted by haleiwa 
Mks base 1.2 z steps per mm not updating
January 05, 2017 02:08PM
I purchased an HIC prusa I3 in 2015. It has served me well. I designed an upgrade and used the repetier 91 tool to generate firmware accordingly. I reverted to pre upgrade functionality and installed new repetier 91 created firmware. This firmware had no problems and served me well.
I bought a cheap delta printer from aliexpress. The printer had a different baud rate. At the time I attempted to connect to the delta discovered the differing baud rate and changed it accordingly.I later attempted to connect to the Prusa I3 with the incorrect baud rate. In my inexperience I searched for a solution, eventually updating the firmware on the Prusa I3.
Eventually I realized the baud rate was the problem and attempted to resume work with the Prusa I3. Unfortunately the solutions I tried before I realized the baud rate error seem to have caused a new error. The new error is in part that the z axis height per mm is way off. But also I seem to be unable to calibrate any axis whether through eeprom or firmware update. The only luck I have had was to update the steps per mm for extrusion. This was done through the LCD screen on the printer, and only compensated for the over extrusion due to the incorrect Z height. There is not an option to calibrate x,y,or,z in the LCD menu. In no way is this a solution. It only helps to confirm the problem.
When I enter the M503 command my Z steps per mm are 200. They should be around 2260 I believe. In the uploaded firmware the steps are 2260 per mm in Z. For some reason the correct steps per mm is not being corrected. X and Y axis' are writing correctly
I have tried writing over the firmware then re flashing. No luck.
I wanted to try to erase all eeprom info and overwrite all of the memory, then re-flash firmware. Would this work maybe?
The board on my printer is a MKS Base 1.2

Thanks in advance for any help.
Re: Mks base 1.2 z steps per mm not updating
January 05, 2017 05:05PM
there is a eeprom clear sketch in arduino/file/example/eeprom menu, uploading this will clear the eeprom and then when you re flash the firmware, the new settings will be loaded into eeprom.

Alternately if you use repetier host you can edit the eeprom directly.
send to printer
M502 ;reead config
M500 ;save config to eeprom
Re: Mks base 1.2 z steps per mm not updating
January 12, 2017 04:09AM
Clearing the EEPROM did the trick. I had looked to clear it before but all I was able to find was the clear EEPROM page on the arduino site. Unfortunately they left the number of bits to be written out of the code and I couldn't figure out where it was supposed to go.
For anyone who comes across this post. The ramps 1.4 and the MKS Base have 4096 bits of EEPROM to be erased. The code in the arduino library shows
512 bits to be written, this is for another board. If you are clearing an arduino mega or compatible replace the 512 with 4096 in the arduino sketch Obewan mentioned.

Thank you Obewan,
your advise was dope.
Sorry, only registered users may post in this forum.

Click here to login