Welcome! Log In Create A New Profile


Help Troubleshooting Anet A8 Z Axis Mother Moving in only one direction

Posted by Shoey5 
Help Troubleshooting Anet A8 Z Axis Mother Moving in only one direction
February 25, 2017 11:40AM

I'm new to 3D Printing, I purchased a cheap Anet A8 DIY 3D Printer kit to dabble in 3D Printing before deciding if I even wanted a higher end unit. I've been printing with it for about a week and it's been great. The other day I was in the middle of printing my first (proudly created on my own) object. The print started off fine but I realized I forgot a setting so I stopped the print, cleaned the heat bead and re-homed the extruder. When it was homing, I heard a loud rattle noise from one of the motors like the Z-Asis was misaligned. I corrected it but the rattle still persisted. I removed both the smooth and threaded Z-Axis rods and when I put them back in I noticed they weren't going straight down to their assembled position. I adjusted the (not sure what they're called) holders for the rods to line everything up. This fixed the rattling noise. It was working before but it either shifted or I was straining the motors.

Once I had everything going, I started printing, everything was great until I noticed the extruder wasn't raising. Upon further investigation, I realized that the Z-Axis motors are only turning the threaded rods one way (down towards the heat bead), they don't move the other way.

Anyone have any suggestions as to what the problem may be?

Some things I have tried

- Ensured all cables connected properly.
- Removed Z-Asis threaded rods and tried controlling motors from print menu, they still only move in one direction
- Adjusted the POT for the Z-Axis, this caused it to move the other way but inconstantly and inaccurate. Though I don't know how much power it should be adjusted too, Anet has one POT for both Z-Axis connectors (I'm assuming)
- Connected to spare motors (same model) I had to the Z-Axis - same problem.
Re: Help Troubleshooting Anet A8 Z Axis Mother Moving in only one direction
February 26, 2017 05:34PM
Have you tried the printers own controls - Menu/Position/Z position to try moving the Z axis up and down? If you have, and it still only moves in one direction, then it sounds like there is a problem with the signal to the DIR direction control of the Z stepper driver. On the Anet board, some of the a4988 connections are hidden by the heatsinks glued to the top of the chips and I haven't yet been able to determine the exact routing of this signal back to the processor (not wanting to remove the board from my printer to do so).

The problem could be something as simple as a dry joint, but that will be difficult to trace. It could also be the processor itself which should be raising or lowering the controlling pin to set Z direction. Sorry I can't be of more help.

I would suggest that you go back to the supplier and state that the control board is faulty and ask for a replacement

Edited 2 time(s). Last edit at 02/26/2017 05:39PM by Supermec.
Re: Help Troubleshooting Anet A8 Z Axis Mother Moving in only one direction
March 10, 2017 12:28PM
Thanks, your post lead me in the right direction. I had checked for dry joints but everything looked good. Turns out it was a bad driver on the board. I got a (took forever) replacement board yesterday and it worked. Back up and printing!

At least I know a possible symptom of a bad stepper driver in the future. smiling smiley
Sorry, only registered users may post in this forum.

Click here to login