Welcome! Log In Create A New Profile


Home position changing???

Posted by searcher 205 
Home position changing???
April 30, 2017 09:50PM
On my GeeeTech 3b pro, the home position seems to be constantly different. I set the bed (bed and extruder fully heated for ABS) and tried to print. It failed (see my other problem in previous post). I don't know if this is related, but I just fired it up cold and homed it. I checked the bed and the extruder was so close that it was striking the glass when I tried to move it. This isn't a new problem. It has been this way for the several months I have owned it. I usually calibrate the bed then rehome then recheck2 or 3 times to get the home position to remain right for 2 consecutive times before trying to print. I have the configuration for this machine posted in [forums.reprap.org] if it would help someone figure out what my problem is. Thanks so much for any help on this.
Re: Home position changing???
May 01, 2017 08:50PM
Is the home position off in all three axis or just Z?

Assuming Z only, from your post... Is the screw which activates the Z axis endstop loose, i.e. the screw is not being held in a fixed position because the spring is not compressed? If the screw becomes loose the extruder will be too low and hit the glass. I think I had to fit a 40mm screw rather than the 30mm one in the instructions to get the adjustment and a bit of tension in the spring to prevent it moving. You shouldn't have to recalibrate the machine each print once it's been set correctly.

Does the Z endstop microswitch work correctly? The Z axis should drive downwards till the switch state changes then back up till it changes back causing it to stop. Even though microswitches are pretty simple devices, the places where it changes from open to closed to open should be pretty constant. Maybe the switch is faulty? You could try replacing it or swapping with one of the other axies. If the fault changes axis, the switch definitely needs replaced.

My two cents

Play Bonny!

Re: Home position changing???
May 06, 2017 10:42AM
This problem seems to be fixed with a change in z axis feedrate (thanks obewan). Several prints later and all is well.
Sorry, only registered users may post in this forum.

Click here to login