echo:endstops hit: ERROR
May 24, 2017 03:51PM
Hi
I just bought a prusa i3 based 3d printer, I connected everything as I saw in the manual like this picture: [www.smartdiys.com]

But the problem is here, when I trying to check the printer manually in pronterface program, I only can move the extruder in one side(z-axis downward, x-axis leftside, and y-axis up to front of printer) and when I try to move it in against sides it can't move! and gives me the endstop maeesage!

How can I fix this?

I use this firmware :[ufile.io]
May you say which line of which file should be changed for that?
Re: echo:endstops hit: ERROR
May 24, 2017 05:57PM
When you power on and connect the printer, it has no clue where it is in the X,Y,Z world, it needs to be homed first so it knows where it is, that's why you are finding it is only moving in one direction (should be the direction towards the endstops).

Home the printer in pronterface (click the little house on the list side or enter G28) and once the printer homes, you should be able to move in any direction.
Re: echo:endstops hit: ERROR
May 24, 2017 06:15PM
Send the printer a M119 command

It will tell you the endstop status as seen by the controller.

Any endstops that are triggered, you cant move in that direction.
Re: echo:endstops hit: ERROR
May 24, 2017 09:47PM
Very thank you Scotty!
It worked, but there is one problem! for Y-Axis, the printer thinks the endstop switch is on the front of the printer but the switch is in back of the printer , so when I push Y-Axis home, it goes to reverse side. Can I only reverese the Y-Axis motor connector socket or should I change the firmware code? (I must say i did everything as same as the picture I attached in my first post and didn't wiring it wrong)

Edited 1 time(s). Last edit at 05/24/2017 09:49PM by rezaeee.
Re: echo:endstops hit: ERROR
May 24, 2017 09:51PM
Thank you Dust, but I don't know how can I send M119 command to printer! Im newbie in 3d printers and it's my first time to use pronterface.
Re: echo:endstops hit: ERROR
May 24, 2017 10:26PM
Type it in the red section and then click the green send button


Re: echo:endstops hit: ERROR
May 24, 2017 10:31PM
regarding Y axis

endstop should be setup as a min endstop when at the back of the machine, this is set in firmware

ie #define Y_HOME_DIR -1 in configuration.h

re movement. When you click -Y the bed should move back towards the endstop, when you click +Y the bed should move towards the front of the machine

Edited 1 time(s). Last edit at 05/24/2017 10:32PM by Dust.
Re: echo:endstops hit: ERROR
May 24, 2017 10:46PM
The end stop position is important and it needs to match where the firmware thinks the end stops are. It sounds like you have the endstops in the right location, so when it homes the nozzle should be sitting at the front left.

You should change the direction in the firmware as Dust suggested, open up your firmware in Arduino and in the config.h and search for #define Y_HOME_DIR and change it (if its 1 make it -1 or if its -1 make it 1)

If you need help with the firmware, just google "update marlin firmware" and watch a few videos.

Take notes if needed as you will be modifying the firm ear a bit during calibration. Also always keep an original copy of the firmware saved somewhere else, so you can always go back if needed.
Re: echo:endstops hit: ERROR
May 24, 2017 10:48PM
Thanks, this is the results:

Reporting endstop status
x_min: open
x_max: TRIGGERED
y_min: open
y_max: TRIGGERED
z_min: open
z_max: TRIGGERED
Re: echo:endstops hit: ERROR
May 24, 2017 10:53PM
when you entered m119 where any of the endstops pressed? as in did you have the printer in its home position
Re: echo:endstops hit: ERROR
May 24, 2017 10:58PM
You need to disable any end stops you don't have

Most I3 type machines have endstops only at one end of each axis

X min end stop on the left, max end stop on the right
Y min end stop at the back, max end stop at the front
Z min end stop at the bed, max at full height.

most don't have any max endstops and simply disable those

eg in firmware

#define USE_XMIN_PLUG
#define USE_YMIN_PLUG
#define USE_ZMIN_PLUG
//#define USE_XMAX_PLUG
//#define USE_YMAX_PLUG
//#define USE_ZMAX_PLUG

Edited 1 time(s). Last edit at 05/24/2017 10:58PM by Dust.
Sorry, only registered users may post in this forum.

Click here to login