Welcome! Log In Create A New Profile


Issue getting new controller board working (MKS Gen 1.4)

Posted by rachelr 
Issue getting new controller board working (MKS Gen 1.4)
November 07, 2017 09:57PM
I believe I've followed the instructions. I carefully did the wiring having had some negative experiences. At this point all but one thing is working. The one thing is maddening though.

For Marlin I'm using the latest stable off of Github. I've made what seemed like appropriate changes to match the reprapguru i3 I have. What isn't working is that the X control in the manual controls in repetier move the Z axis and not the X axis. This seems impossible. The wiring for the X is straightforward. The Z steppers are wired in parallel and plugged in. I'm at a loss - I couldn't find and can't imagine a configuration for something like this.

Any help would be gratefully received.

WITBOT Gen 1.4 MKS board
DRV8825 stepper boards

Re: Issue getting new controller board working (MKS Gen 1.4)
November 08, 2017 01:29AM
check your motherboard type, it defines what pins are used for what function.

Does the X move as well as Z? (when you tell X to move)

Does X move if you tell Z to move?

Edited 1 time(s). Last edit at 11/08/2017 02:08AM by Dust.
Re: Issue getting new controller board working (MKS Gen 1.4)
November 08, 2017 09:13AM
Oh dear, this morning I’m fine that either moving it cured the problem (unlikely), or I was tired and lost track of what was going on. Which seems more likely.
Addendum OK, several different issues with the X. When zeroing the Z axis is activated at least sometimes. Once it thinks it is homed in that case it won't move at all. It reports having been moved but the carriage doesn't budge.

I do have an issue with the X stepper just vibrating at me. I increased the Vref to 1.2v on the drv8825, and I tried a second spare cable and a spare driver. Seems like the motor but it spins with no control and holds with power on. If I swap x and y then the same issue happens with y, which further rules out the software and driver.

Could there still be a mechanical problem? Or is it just that the motor is blown?

It turns out that the extra spare motor cables I bought reversed the second and third wires - cool huh? Once that was fixed everything worked ducky. I am trying to get the display going, but that's a more
leisurely problem to solve.

Thanks, Rachel

Edited 3 time(s). Last edit at 11/08/2017 11:01PM by rachelr.
Sorry, only registered users may post in this forum.

Click here to login