Welcome! Log In Create A New Profile


CTC clone firmware

Posted by eddy99 
CTC clone firmware
November 21, 2017 09:38AM
I am trying to upload marlin to a spare motherboard. I have put a bootloader on the board using USBasp but I cannot get Marlin to upload to it keep getting stk500v2_receivemessage timeouts.
I have change the baud rate to 56000 as suggested but no joy.
Any ideas´╗┐
confused smileyconfused smiley

Re: CTC clone firmware
November 21, 2017 09:21PM
stk500v2_receive message timeouts. Just means its not talking..

Hasn't reset into bootloader mode, or upload setting don't match boot loader or your talking to the wrong com port

Changed the baud rate where? to change the baud rate for uploads you have to edit the appropriate boards.txt file and restart the arduino ide. changing the baud rate in marlin does nothing as marlin isnt running yet, the bootloader is

(Im presuming this is a arduino as CTC clone doesn't tell me anything about the board)

So what does the board look like, what is the cpu and clock, what boot loader are you using, what baud and protocol does the boot loader expect, what board have you selected in the arduino ide and what uploads settings are in the boards.txt file that defines the board you selected?

Are there any enable reset jumpers? Would need to be enabled to reboot into bootloader

Edited 2 time(s). Last edit at 11/21/2017 09:25PM by Dust.
Re: CTC clone firmware
November 21, 2017 09:23PM
also a baud rate of 56000 is a really non standard baud rate did you mean 57600?
Re: CTC clone firmware
November 22, 2017 03:29AM
So after reading tons of stuff I found a comment to use Arduino 1.0.1 and it uploaded Marlin first time.
Sorry for not enough info.
The printer is a CTC prusa i3 clone.
Motherboard 2560 Rev A

Arduino boards.txt and this is what was suggested to change but it did not work for me.


Re: CTC clone firmware
November 22, 2017 04:53AM
Hi eddy I had a load of the same trouble. Give this a try.

Re: CTC clone firmware
November 22, 2017 08:20AM
Thanks Bee69, sorted now just had to use the older version of Arduino and all updated ok.
On that link it says use Atmega1280 from the menu but I used Atmega2560 which worked.


Edited 1 time(s). Last edit at 11/22/2017 08:23AM by eddy99.
Re: CTC clone firmware
November 22, 2017 12:11PM
Im glad it worked.smiling smiley
Sorry, only registered users may post in this forum.

Click here to login