Welcome! Log In Create A New Profile


Controller Freezes

Posted by Roberts_Clif 
Controller Freezes
December 16, 2017 12:51PM
Today I post about the Hictop 3DP11 and 3DP12 Controllers.
They have many different board numbers I have the MPX.3 and Base v1.3.
I have flashed them with Marlin 1.1.5 back in august 2017 and have had no major problems. Yesterday however I found that the Motherboard on Blu had locked up in mid print and I could not get it to release, have printed the files on the SD card many times without incident. However this time the controller froze in mid print. And today Red is doing the same with a different Flash card. I have reloaded the firmware system defaults and re-leveled the bed saving the data and it seems to take care of the problem for now.

Spoke too soon locked again.

Thou still want to know why the 3D Printer startup Data is getting corrupted, I am using the same Cura program 15.04.6 for over a year now. I have printed with other slicers in the past though have not on this set of models.

The last time I had printing issues reformatted fat 16 completely formatted 2GB SD card.
Have had issues from windows wanting to repair the SD card. And I believe that the windows repair of the SD card is what is causing some of the issues of corrupting the SD card data. Would like to know what the forum thinks, and if anyone else is having similar problems with your controllers.

Edited 1 time(s). Last edit at 12/16/2017 01:48PM by Roberts_Clif.
Re: Controller Freezes
December 17, 2017 05:44PM
There is a web site for Raspberri Pi as its OS is on SD cards which can come corrupted etc. and things don't work. Anyhow on that site is a listing of different SD cards who made them and problems with them. If you read up on the different bad and good cards you may find a reason as perhaps it may be the actual SD card you are using
Re: Controller Freezes
December 17, 2017 08:54PM
I have been printing with
(CS4) SDHC 4GB but believe that the reason this fails is because 16bit controllers can only use 2gb SD Cards max.
Have just changed over to micro SD 2GB default speed cards.

Just purchased (CS4) SDHC Micro cards for use in Rasberri Pi

Have not decided which I want to use
Re: Controller Freezes
December 19, 2017 10:13AM
Was printing with a 2GB Micro SD Card. Printer Stopped in mid print dove into the print says print finished.
Today will switch cables I Only wrapped the LCD cable If I switch cables the SD cable will be wrapped.
Re: Controller Freezes
December 20, 2017 01:02PM
Switched the Cables and still stops in the middle of prints.
Is there a log or some G-M Code I can call to see if a error occurred on the last print?

As I studied the failure it appears to stop it thinks the print is finished, though only 30minutes into a 2 hour print.. Tried the Initialize Defaults still fails.

Inserted card into windows stated it needed to fix the card reformatted with Fat32.

OK still adding data The fat 32 did work.

Now this time I was close to the Printer, Went to see why it stopped. Every time I would the turn / click click encoder it would reset, did this a few times then finally left it alone.
It reset itself a few times then booted correctly and again worked. will hook it up to a scope and see if the regulator is supplying a clean voltage.

Then Will try to re-flash the firmware.

Anyone have any other suggestions.

Edited 3 time(s). Last edit at 12/20/2017 02:05PM by Roberts_Clif.
Re: Controller Freezes
December 20, 2017 10:04PM
OK this afternoon saw the Printer Freeze.

Just starting the 2nd print had not even finished the Outline boarder when It sounded like "Thong" and Just stopped display Froze in place no menu control worked.
Powered Off would not boot, tried 3 times no boot, On the fourth reboot it booted ok.

Now I have an ideal I think it may be the internal 5V regulator. will need to remove the Case top so I can have Access to make measurements after the Next Freeze.
Re: Controller Freezes
December 21, 2017 01:49AM
Some SD-cards draw too much current and the 3.3V regulator on the smart-adapter is fed by 5V from the controller.
I'd go for CS10 cards and format them in FAT16, no matter if I loose some GB then.
You could also try to run the 5V line from a USB-charger while printing and see, if that helps.
Re: Controller Freezes
December 21, 2017 09:15AM

Today I have connected a meter up to the LM2596S-5.0 P+ regulator to see if if shuts down under load.
will Have a look at the 3.3v Regulator later.

Did not shut down under load. and cannot find a 3.3v source.
What is causing the Controller to reboot in mid Print. Remember I have printed this STL many times without a problem.

Edited 3 time(s). Last edit at 12/23/2017 09:09AM by Roberts_Clif.
Re: Controller Freezes
December 23, 2017 10:02AM
Today I am continuing the search for a problem with the LM2596S-5.0 P+ Buck regulator.
And believe I have found potential cause. Mounting of an inductive fan too close to the Buck regulator circuit.

"As in any switching regulator, the layout of the printed
circuit board is very important. Rapidly switching currents
associated with wiring inductance, stray capacitance and
parasitic inductance of the printed circuit board traces can
generate voltage transients which can generate
electromagnetic interference's (EMI) and affect the desired

Move the Inductive fan causing parasitic inductance and the influence of electromagnetic interference's (EMI) in the circuit.


Replace out of tolerance capacitors in the LM2596S-5.0 P+ Buck regulator. (this circuit work for over a year thank it could be an out of tolerance Capacitors)(Defective).
As repairing this circuit could cause more of a delima, Special Capacitors are required (high ressistive), use of an external USB power supply may be the Best option.

Will continue testing the circuit.
First test is to reverse the fan thereby moving the inductive coil 15mm further from the buck regulators inductance coil.
Second test will be to connect a external 5V USB Supply, However adding a external power source my not eliminate the Buck Regulator electromagnetic interference's (EMI).


Replace the Buck regulator Circuit with a TO220 3 amp 5volt Regulator chip circuit .

Edited 1 time(s). Last edit at 12/23/2017 10:27AM by Roberts_Clif.
Re: Controller Freezes
December 29, 2017 08:08PM
Here Again!

Have done further testing, and the controller Connected to a Raspberry Pi Octoprint USB Still reboots, and disconnects the Pi's Com Connection.

Re-flashed Marlin 1.1.5 Still reboots in mid print, Setup the Backup controller for installation with Marlin 1.1.5. Will Install and see if problem goes away.

Next day!!

Installed backup controller. Printed first full print no problems, further test required.

Printer four fidgets 1 3/4 hours each not problems. so I am assuming from this that the controller has problems.
I still believe that it is the 5v LM2596S Buck regulator circuit is intermittently failing.
Now to setup a fake 3D Printer and run simulated prints until a failure occurs.

Edited 2 time(s). Last edit at 12/30/2017 10:46PM by Roberts_Clif.
Re: Controller Freezes
February 01, 2018 07:59PM
Last note on the blog, Contacted 3D Printer Co. they agreed to replace controller under warranty.
Replacement has been shipped and will arrive here when is can pass thru U.S. Customs.
Sorry, only registered users may post in this forum.

Click here to login