Welcome! Log In Create A New Profile


Strange z axis ticking

Posted by Focussys 
Strange z axis ticking
February 22, 2018 05:46AM

I am using a Prusa I3 Mk2 upgraded clone with Ramps 1.4, A8994 drivers and Mattercontrol.

Recently, after printing perfectly for days, the z axis has started ticking and slowly moving upwards before a print. This only happens between pressing the print button and the hotend moving to its print position.

I have tried:
1. Swapping drivers
2. Setting a lower Vref
3. Checking ease of movement of screw threads

The result is a random Z offset and prints not adhering to the bed.

Anyone had the same?
Re: Strange z axis ticking
February 22, 2018 08:44AM
I have a Ramps 1.4 compatible controller where the driver are directly soldered to the controller board...

Though I have component level troubleshooting experience of electronics. It sound like you may have a defective A8994 driver control board.
This could be simply because of a solder ball or a cold solder connection causing the controller to make the erroneous movement.
You could do a simple test by switching the Z-Axis A8994 driver board with one of the other driver boards.
If the problem moves with the A8994 driver then you would simple replace the defective A8994 driver.
As the A8994 driver controller is so inexpensive and our time is so valuable toss it or investigate why it is acting in such a manner and thereby gain knowledge.
Re: Strange z axis ticking
February 22, 2018 11:02AM
Many thanks for coming back. Sadly, as I mentioned I have both swapped and replaced the Z driver.

I have just discovered the issue is with Slic3r as by changing back to Matterslice it disappears!

I suppose it is a fix although Slic3r can be useful for some prints
Re: Strange z axis ticking
February 23, 2018 07:35AM
Slic3r only produces Gcode so can't directly afect the hardware.
I can only assume that you have a Gcode comand that is not compatible with the firmware/hardware. That would be due to a setting in the Slic3r configuration.
This may be in your start code settings. Note that start code can be defined in the slicer and host software.
Seems like there is a Gcode move command that has a feedrate component that causes the issue.
Re: Strange z axis ticking
February 24, 2018 03:40AM
I'm sure it's related to bed leveling. It only happens after homing and before printing, you said. But it might also occur during print, but unnoticed?
Re: Strange z axis ticking
February 27, 2018 09:33AM
Just read this and sounds like something im currently experiencing.

I have a strange ticking when using the extruder in manual mode. Firmware: Marlin_Prusai3_reprap_pt

It extrudes fine, then starts like almost "ticking" extruding about a mm at a time. Then once completed extruding task, the motor starts making a "ticking" sound. The driver also makes a high pitched sound with fluctuations. It seems like the stepper "Hold" function has to do with it. I have tried different drivers.

Im going to install a different firmware.

Edited 1 time(s). Last edit at 02/27/2018 09:34AM by daankie.
Sorry, only registered users may post in this forum.

Click here to login