Welcome! Log In Create A New Profile


Fried RAMPS of i3 clone?

Posted by Slayforfun 
Fried RAMPS of i3 clone?
November 08, 2018 04:27PM
TLDR: extruder wasn’t working so I unplugged and reseated stepper driver (one pin too far towards the power connectors of my RAMPS 1.5 I guess). It caused an alarm and smoke. After this it wouldn’t turn on anymore except when the driver isn't inserted. And the LCD screen still doesn’t turn on then, only weakly when plugged into USB. Steppers for other axis are not working however. Did I fry my RAMPS or something else?

I've been having extrusion problems for several days, I tried changing the retraction rate from 30 mm/s to 15, increasing the print temperature, combined, cleaning the nozzle, replacing the nozzle nothing worked. It was however notable that some prints did come out ok, this was not reliable however. The extrusion problems usually first showed under extrusion followed by stripping of the filament. Then I read that perhaps there might be ground filament on the teeth of the extruder drive. Which there was, I removed this but afterwards the stepper seemed to not function at all.

I quickly discovered that the stepper itself was fine but the connection of my RAMPS 1.5 to the stepper was not. The cable worked however. So I figured it might be the stepper driver. I took it out in order to inspect it and looked alright. Therefore I figured I would plug it back in, however I was seemingly stupid enough to put it in the wrong position, I guess by one pin, as I quickly heard an alarm and saw smoke coming of the board after I turned the power supply on.

I took out the (perhaps damaged) stepper driver and tried turning on my printer, it didn’t work. So I tried inserting the stepper driver 1 position to the right, no luck either. Next I tried what happened if I plugged in the USB connector to my pc as this seems to supply the printer with some power, enough to show some light on the LCD screen. The LCD allows for selection to occur as well as heating of the bed, and presumably hotend, but not movement of the steppers. Cura also does not recognize a printer being plugged in like this. Turning on the power supply changed nothing to the state of the LCD or the printer.

I am still getting 12 V on the inputs of the RAMPS when I turn the PSU on but that’s about it (as far as I've measured. So basically my question is, did I just fry my RAMPS or is it likely that I fried more, such as the arduino itself. I would think it’s the first option since I still get some display on my LCD with USB power but I would rather not plug in a new RAMPS and fry that too if it is something else.

My printer is an I3 clone by HTA3D I3 steel (I3 clone by HTA3D). I have been using it pretty heavily for a month or two now and it is my first 3D printer. I'd say I've learned quite a bit about the machine but clearly there is more to learn especially since I don’t have an extensive electrical engineering background. I hope someone has some suggestions on what the problem might be and/or what I can try to solve it. I don’t mind a bit of a break in my printing schedule but I would like to get it working again sooner rather than later. Which could be relatively fast if I can just plug in a RAMPS 1.4 but again, I would like to know if that is safe first.

Edited 1 time(s). Last edit at 11/08/2018 04:28PM by Slayforfun.
Re: Fried RAMPS of i3 clone?
November 08, 2018 09:21PM
You potentially fried everything!

The stepper modules have both 12v and 5v, If you put them in the wrong place often the 12v is applied to the 5v side and everything gets damaged...

The power issue is a very common one. You have definitely killed the 5v voltage regulator on the mega, thus you only get 5v when you plug in the usb cable.

So you looking at a new mega and new stepper driver(s) minimum.
Only thing on the actual ramp that is likely to die is the mosfets
Re: Fried RAMPS of i3 clone?
November 09, 2018 03:06AM
Also, did you switch the printer off before you unplugged the stepper connector? If you unplug it when the power's on there's a fair chance that a back-EMF spike (a pulse of high voltage) could fry something.

If you know this already, just ignore this post! smiling smiley
Re: Fried RAMPS of i3 clone?
November 09, 2018 08:34AM
Thanks for the feedback. I have taken of the voltage regulator and diode D1 of the RAMPS in order to power the arduino from USB. This allowed the screen to seemingly turn back on to normal levels, however non of the steppers were working so I guess at this point it might be better to just order a new arduino-Ramps assembly possibly with some backup stepper drivers. It's a shame and will cost me like 30-40 euros from the same company probably. But I guess that's the price for making dumb mistakes and learning not to make them again, shit happens smiling smiley
Re: Fried RAMPS of i3 clone?
November 20, 2018 04:34AM
Don't be to upset about it, most have been there done thathot smiley
Re: Fried RAMPS of i3 clone?
November 29, 2018 01:52AM
The 5A SMT fuse on your RAMPS is likely blown if its a 1.5--RAMPS 1.4 should self-reset over time. Check continuity on the fuses. Replace if no continuity. Also replace the stepper driver that caused the problem, of course. The board is likely fine except for that fuse. You can also replace the voltage regulator on the Arduino with an LM7805 wired externally, just be aware that it has a different pin-out and should have a heat sink--that's what I did: its more robust and reliable. As a bonus, upgrading the regulator allows you to use up to 25V input for the Arduino.
Sorry, only registered users may post in this forum.

Click here to login