Support issues
May 28, 2019 06:21PM
We purchased a Prusha kit for our classroom but received the wrong z-axis couplings. I got connected with support and was assured that replacements were going to be sent. After numerous emails and voicemails left....still nothing and zero contact back via email or phone. Has anyone else experienced this?
Re: Support issues
May 28, 2019 09:36PM
95% of clone 3d printer manufactures will not provide support for their products.

Whats is wrong with your couplers.. pictures?
Re: Support issues
May 29, 2019 10:59AM
what they sent were additional couplings for the belt, not the correct ones to hold the lead screw shaft. Why would I want to do business with a company that offers a product but doesn't correct a packing and shipping mistake?
Re: Support issues
May 29, 2019 02:48PM
"Why would I want to do business with a company that offers a product but doesn't correct a packing and shipping mistake?"

You wouldn't, They have your money now, so it is very unlikely you will ever hear anything anything back from them, let alone get any satisfaction..

All you can do is try and move forward, and perhaps name and shame so anyone else searching for reviews may find your story.

Any pictures of the parts you need, are they printed or aluminium? I am presuming your talking about the stepper motor to the lead screw couplings?
Re: Support issues
June 03, 2019 10:28AM
Are you talking about a i3 Clone or a genuine Prusa?
Re: Support issues
June 03, 2019 10:51AM
@SteveRoy

Genuine Prusa MK2 or MK3 don't have z-axis couplings! the Z stepper motors and lead screws are one part.

eg


Edited 1 time(s). Last edit at 06/03/2019 10:52AM by Dust.
Re: Support issues
June 04, 2019 06:50PM
@Dust

I should have paid closer attention to them when I was there :-)
Attachments:
open | download - 20180605_110029.jpg (101.7 KB)
Sorry, only registered users may post in this forum.

Click here to login