Welcome! Log In Create A New Profile

Advanced

Prusa MK3 X axis test failure

Posted by cevans9921 
Prusa MK3 X axis test failure
July 30, 2019 03:32PM
I have a self built Prusa MK3, its not an official one but i have bought all the parts to spec. I got every thing together and going but when I do a self test the fans check out ok then it starts on the X axis, the carriage goes back and forth the ENTIRE distance of the machine and still fails.There is no further for the carriage to be able to go so I dont understand why its failing. I have checked thoroughly that there is no wires or any thing else obstructing it and have seen nothing. The x carriage plastics seems to come in to contact with both ends of the X axis plastics when it gets to them. I had a bad bearing triggering it to stop before which wasnt allowing it to travel like it should of but since fixing that I still havnt made much more progress since i still cant pass the test.

As I stated the X axis moves back and forth the whole distance as I imagine it should, but its still reporting back that I have a X axis length problem.
Re: Prusa MK3 X axis test failure
July 30, 2019 03:33PM
Im using every thing a prusa MK3 would have, eisny ramobo, pinda probe etc...etc...
Re: Prusa MK3 X axis test failure
July 30, 2019 03:34PM
and yes, my 3D printer frame is a MK3 clone from Fysec so it should be the correct specs. I bought MK3 sized smooth rods and they match up to the frame so every thing should be right...
Re: Prusa MK3 X axis test failure
July 30, 2019 03:50PM
my x axis belt tension reads at 248 as well.
Re: Prusa MK3 X axis test failure
July 30, 2019 04:40PM
Did you run the test with the steel bed off? As it uses the pinda probe to locate special marks on the heated bed that it cannot see when the steel is on.
Re: Prusa MK3 X axis test failure
July 30, 2019 04:46PM
I do not have the steel sheet on. I've noticed that when I home the bot that it does NOT home the Probe to the location on the heatbed. My x carriage stays around 12mm away from the end of the travel length. When I auto home the bot it does not bump the end, it stays away from it so it never meets up with the mark on the heatbed.

when I manually move the axis with in the settings i only travel about 200mm before i hit either side of the carriages but firmware lets it go to 255mm on the manual movement, is there a way to change the steps per minute like I would in marlin firmware. Im assuming that might be my issue here? or ay least one of them im still not sure why it wont auto home correctly.
Re: Prusa MK3 X axis test failure
July 30, 2019 05:00PM
Sounds like you have incorrect pulley sizes, so it moves different lengths to what is expected
How many teeth on X pulley and what is the size of your X idler?

From memory the pulley should be 16 tooth
Re: Prusa MK3 X axis test failure
July 30, 2019 05:08PM
ahhhh, that is some thing I did not consider. I have been doing 3D printing for over 5 years now so I have tons of extra stuff from building repraps, I used some older pullys which I think are 23 teeth. Couldnt I just edit firmware to make the difference? I know its not as simple on prusa sense the file is a hex file but I know theres a way it an be done. I had a reprap I made with a ramps 1.4 runnig prusa mk2 firmware but it was some work.
Re: Prusa MK3 X axis test failure
July 30, 2019 05:46PM
Try this Prusa calculator online

[blog.prusaprinters.org]


Electronics Technician / Computer Programmer
Re: Prusa MK3 X axis test failure
July 30, 2019 05:50PM
You can recompile it, but as you know that is a PITA.

I doubt editing the binary is really an option. just how many places is the steps/mm used? Does it just point to the one or copy it throughout the code? how would you tell without compiling it with and without changes to make a delta... which is pointless as you just compiled it....


Far simpler to get the correct pulley and maintain binary compatibility
Re: Prusa MK3 X axis test failure
July 30, 2019 09:41PM
alright, I guess ill jsut load a version of marlin on the board for now so I can print stuff since im really familiar with it its easy for me to change settings with in it. In the mean time i guess ill order the pullys i need, thanks again!
Re: Prusa MK3 X axis test failure
August 01, 2019 12:47PM
Ok so I got the new 16 teeth pullys, my X axis now passes but my Y axis wont pass. I tried adjusting the belt tension and it does help +/- a couple mm but not quite enough to be accurate enough to pass the test. I'm using F623ZZ bearings for the idler on the X and Y. I think for X axis this is correct any way but for the Y axis I believe it uses a different pully then X. Is the F623ZZ bearing not suitable alone for using as idler since its a little smaller? I'd imagine just using one of my other printers to print a shell for the bearings to meat the gear ratio would be just fine? I'll order the correct part but if this is all thats stopping me from printing....
Re: Prusa MK3 X axis test failure
August 01, 2019 11:16PM
Do you know about the official assembly manuals [manual.prusa3d.com]


The Y idler (and the X idler bearing is the same)



No a F623ZZ is not suitable

Edited 2 time(s). Last edit at 08/01/2019 11:18PM by Dust.
Re: Prusa MK3 X axis test failure
August 02, 2019 08:17PM
yeah i looked at them but originally i didnt realize the prusa software wasnt as editable as its predecessor marlin. I thought I was going to be able to edit some of the firmware to suit my needs. I ordred the correct bearings theyll be here tomorrow. How ever since X axis is passing with the 623 bearings im not going to mess with it, dont fix some thing thats not broke winking smiley

I was able to use prusa mk2 firmware on a ramps 1.4 so that's why i originally thought I'd be able to edit the MK3 firmware but the einsy rambo board works a lil different for mk3 then it does compared to mini rambo for instance.
Re: Prusa MK3 X axis test failure
August 03, 2019 04:31PM
i now pass every thing but the Z calibration test. For some reason when my probe lowers down it instantly fails the z calibration.
Sorry, only registered users may post in this forum.

Click here to login