I'm stuck with this one - Can anyone help?
September 05, 2019 03:54AM
I’m having a problem that started a few weeks ago where if I send an M303 E-1 S60 C5 command (or any temp for S) I get the ‘Error:Thermal Runaway, system stopped! Heater_ID: bed’ immediately and the printer halts. My printer, an original Tevo Tarantula hadn't been used or around 6 months and I wanted to start printing with it again.

The reason I am trying to PID tune the bed is that sometimes during printing I get the same error message however nothing feels hotter than it should and it happens at random times, for example it could be an hour into a print or 3 hours into a print.

If I set the bed temperature manually to 60, or any temperature it reaches temp as normal and holds there.

This is what I have checked so far

1) 12v (actually just under at 11.8) at the power supply, board and heater connections on the bed
2) Continuity of cables using 2 known good multimeter’s, all cables are unbroken.
3) Used an external Mosfet with the same result
4) Changed the control board from a ramps 1.4 to an mks base 1.5
5) Changed the bed thermistor
6) Swapped to another PSU giving full 12v

I am running the Jim Brown's easy config firmware (can't remember version off the top of my head) and no changes have been made to the firmware since it was loaded on around 18months ago.
The only part involved I haven’t changed is the whole heat bed (I have one on order).

Are there any other things I can look at?

Some people use the bang-bang heating method, what are the advantages and disadvantages to this as what I have read it may not be as safe (I’m probably mistaken)?

If Bang-Bang is safe is it as accurate and how do I use this method over PID?

Sorry for so many questions but this is starting to annoy me a little now as I haven’t changes anything and everything tells me it should be working but isn’t, I guess that’s what makes this hobby so interesting and yet so frustrating at the same time.

Thanks for any advice you can offer.
Re: I'm stuck with this one - Can anyone help?
September 09, 2019 02:03PM
This has always confused me in the g-code wiki, but could it be E1 instead of E-1?
I run smoothieware now, but it makes more sense with the hotend being 0 and the bed being 1.. dunno if that's the problem..

I use bang bang BTW, no issues with it. You just have to uncomment a line in Marlin and set hysterisis to 2 degrees to define when heat is on or off.
I started with a tarantula, but my bed was a silicone heater and needed a relay to bypass the board.. relays don't like PID's fast switching. I use a mosfet on my current machine, but have never bothered to stop using bang bang as it's not given me any trouble.

Just read the comments under the bed section, it should point the way for you.
Re: I'm stuck with this one - Can anyone help?
September 10, 2019 12:31AM
E-1 is the heated bed E1 would be hotend 1 E0 being hotend 0
Re: I'm stuck with this one - Can anyone help?
September 10, 2019 02:27PM
There was a bug in Marlin where if your WATCH_BED_TEMP_PERIOD was more than 127 seconds it would cause an immediate failure of M303 E-1. This was fixed back in January 2018, so it's unlikely to be your problem, but it might make sense to check it anyway.
Re: I'm stuck with this one - Can anyone help?
September 17, 2019 12:51PM

Sorry for the late reply, I've tried rebuilding the printer and still have the same problem although I got a single successful calibration cube and now the same thing happens within about 30 seconds of printing.

I checked the WATCH_BED_TEMP_PERIOD and it's set to 120 so don't think it's that.

Any other ideas anyone?
Sorry, only registered users may post in this forum.

Click here to login