Welcome! Log In Create A New Profile

Advanced

Weird setup issue

Posted by AndyKay 
Weird setup issue
May 16, 2016 05:15PM
So I just built my Fisher Delta last week and today was the first day of commissioning. I followed these instructions (https://reprappro.com/documentation/fisher-1/commissioning/) All switched on fine although the web portal while it would send commands, it wouldn't show any feedback. No X, Y or Z positions, no logs on the Console for each command, no temperature. One thing that worked was G28 - carriage went to the top, did it's little touch of the end stops, and went down 4mm above print bed. Great. But I wasn't happy I couldn't see any feedback on the web portal. I checked the settings area and it said 1.09x-ch but saw this wasn't the most up to date one.
So I flashed the Duet with the latest firmware (https://github.com/reprappro/RepRapFirmware) with Arduino as per instructions. All went well. Tried loading the SD card again with the stuff in the 'SD-image' folder. Noticed there was no 'sys' folder though (it had "sys-Huxley-Duo" and 3 other printers sys folders). Googling these machines showed they were completely different to the Fisher so I used the old sys folder from 1.09x-ch. Web portal now working - showing me temperatures, XYZ position etc. But when I try to 'home' carriage would go up a split second, but then go all the way down to the bottom on one axis. So I have a nice score mark on the bed. I tried doing this pressing each axis at a time to home, same issue: it would go down to the bottom (managed to press Emergency Stop). Nothing seemed to work. The last attempt snapped a rod so I thought I'd come and ask here what I'm doing wrong.
Re: Weird setup issue
May 16, 2016 06:20PM
probably too late for this, but dont install the build tak until after commissioning, use blue painter tape instead, and even if you have installed the buildtak, still use the painters tape

the SD card image for the fisher is on the instructions page immediately below 'First Connection' you should be using this however Ive copied the link here [reprappro.com]



RepRapPro Mendel 3 Tricolour
RepRapPro Fisher
-Carbon Arms
-Easy adjust Carriage+effector
-axis stiffness mods
HE3D -600 delta
-Duet 0.8.5
-PanelDue
-DC42 Height probe
-RobotDigg metal components
Simplyfy3D
RS Design Spark CAD
Re: Weird setup issue
June 02, 2016 04:50PM
Hmmm. Now trying to do initial setup, X and Z top end stops show that they are 'Min' stops when I run the M119 G code....
Also the Z-Probe figure is jumping all over the place when nothing is moving on the Duet.
I know it's wired up correctly. Double and tripple checked. Checked LEDs under neath when I click the end stops too.

When I switch the Delta on, I get: Error: invalid M Code: M574 X2 Y2 Z2 S1 (which I believe is the End stop configuration setting)

I have a feeling there's some incorrect software/firmware somewhere... I must contact the company I bought it from

Edited 3 time(s). Last edit at 06/02/2016 05:42PM by AndyKay.
Re: Weird setup issue
June 02, 2016 05:50PM
My guess is that you are running the old RepRapPro 1.09 firmware version. That version doesn't support delta printers or the M574 command. The commissioning instructions for the Fisher on the RRP web site have always pointed to a release of my firmware fork instead of their own.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Weird setup issue
June 03, 2016 04:22AM
You can check the bed probe by disconnecting the wires from the bed and doing a continuity check, then using another wire to bridge the two bed connector pins on the board



RepRapPro Mendel 3 Tricolour
RepRapPro Fisher
-Carbon Arms
-Easy adjust Carriage+effector
-axis stiffness mods
HE3D -600 delta
-Duet 0.8.5
-PanelDue
-DC42 Height probe
-RobotDigg metal components
Simplyfy3D
RS Design Spark CAD
Re: Weird setup issue
June 03, 2016 05:02AM
Quote
dc42
My guess is that you are running the old RepRapPro 1.09 firmware version. That version doesn't support delta printers or the M574 command. The commissioning instructions for the Fisher on the RRP web site have always pointed to a release of my firmware fork instead of their own.

Ah OK do you have a link to which firmware I should be using please?
Re: Weird setup issue
June 03, 2016 06:00AM
The latest non beta version [github.com]

You probably should also update the web interface as well.



RepRapPro Mendel 3 Tricolour
RepRapPro Fisher
-Carbon Arms
-Easy adjust Carriage+effector
-axis stiffness mods
HE3D -600 delta
-Duet 0.8.5
-PanelDue
-DC42 Height probe
-RobotDigg metal components
Simplyfy3D
RS Design Spark CAD
Re: Weird setup issue
June 03, 2016 09:00AM
Quote
bgkdavis
The latest non beta version [github.com]

You probably should also update the web interface as well.

And in case you are new to this: follow that link, then press the Raw button to download the firmware binary,



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Weird setup issue
June 03, 2016 09:13AM
Quote
bgkdavis
You probably should also update the web interface as well.
Thanks for that - I'll give that version a go tonight.

Do you have the link to the web interface and SD card files too? (I read that reading that updating the firmware to the one above, I need to update SD card files to a matching version)

/sorry for all these questions - I'm new to this!

Edited 1 time(s). Last edit at 06/03/2016 01:46PM by AndyKay.
Re: Weird setup issue
June 03, 2016 06:15PM
If you look at the page I linked you will see there is a directory tree inside gitub, navigate back to the top and you will see the sd image.

For more help try looking at the duet pages on the reprap wiki, the rrp instructions also give good information, you may want to read the mendel and ormerod insrructions on firmware updating if the fisher ines are not up to scratch

Edited 1 time(s). Last edit at 06/03/2016 06:15PM by bgkdavis.



RepRapPro Mendel 3 Tricolour
RepRapPro Fisher
-Carbon Arms
-Easy adjust Carriage+effector
-axis stiffness mods
HE3D -600 delta
-Duet 0.8.5
-PanelDue
-DC42 Height probe
-RobotDigg metal components
Simplyfy3D
RS Design Spark CAD
Sorry, only registered users may post in this forum.

Click here to login