Cannot Commission my Fisher Delta
November 05, 2016 04:38PM
My problem is similar to others on this forum.
I have finished assembly and when I connect USB lead all lights come on and end stops work.

I have downloaded from GitHub the firmware bin for 15e and flashed this successfully to the Duet Board. I also copied DWC 1.12 to www on SD Card and other directories from the SD image.


My PC runs under Windows 10
With SD Card in the printer and USB cable connected I run Arduino. When I check Tools the BOARD is Arduino Duet (Native USB port), the PORT is COM9 and the PROGRAMMER is AVR ISP.
The Device Manager indicates under Ports(Com & LPT) - Duet 3D Printer control electronics (COM 9)

When under Arduino I run Tools/Serial Monitor and send the command M115 I get the following six lines

Cannot initialise SD Card 0: Card not found RepRapFirmware for Due Version 1.15e dated 2016-10-02

Executing default.g (no configuration file found) ... Error, Not found
Starting Network...
ReRapFirmware for Duet is up and running
FIRWARE_NAME: RepRapFirmware for Duet FIRMWARE_VERSION: 1.15e ELECTRONICS: Duet 0.6 DATE 2016-10-02


I run Delta Fisher with only Ethernet cable connected to PC and mains power switched on.
When I go to a web and input http:/ reprapfisher it cannot find page

Please tell what is wrong ?


Leslie Ward
Re: Cannot Commission my Fisher Delta
November 05, 2016 05:59PM
The "Cannot initialise SD card" is what's wrong. Suggestions:

- Send M122 and look at the SD card section of the Platform diagnostics (AFAIR version 1.15e provides this section). Check that it says the SD card is detected. If it isn't detected then either the card is not fully inserted or the board has a soldering fault on the corner pin of the SD card socket.

- If the card is shown by M122 as detected, try a different SD card.

The Ethernet interface won't work if the SD card isn't being read.

Large delta printer [], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [].
Re: Cannot Commission my Fisher Delta
November 05, 2016 07:05PM
Thanks for your help.

The Message is "SD card 0 detected".

I will contact Trap,etc on Monday and take it from there.


Leslie Ward
Sorry, only registered users may post in this forum.

Click here to login