Welcome! Log In Create A New Profile


atmega 1284p

Posted by Alizier21 
atmega 1284p
August 18, 2012 10:33PM
Has anyone tried or has been able to upload firmware on this chip using a sanguino board using arduino version 0023 as interface . .
I have been able to compile and upload firmware on sanguino with atmega 644p and with ramps 1.3 using arduino 2560 and arduino1280 boards . . .
I went on and practiced my google-fu on the subject chip and followed all the insttuctions but still cant seem to uplpad firmware on it . . .i get a programmer not responding error . .so got me thinking it might be the bootloader . .good practice though for better understanding how the arduino interface works . . .

how can i verify my installed bootloader on the chip?

All sugestion, comments are apreciated . . .
Re: atmega 1284p
August 19, 2012 01:06AM
For some reason we could only upload from one Vista laptop and not from my Win7 netbbook and only using Arduino22. Is there a jumper on the board by the chip, can't find a picture of it but it needs one

Experimenting in 3D in New Zealand
Re: atmega 1284p
August 19, 2012 03:24AM
Yes i have done the reset pins too . . Im using mac osx 5.6 . . Havent tried it with windows platform . .will give the arduino 0022 a go . . .thanks
Re: atmega 1284p
August 19, 2012 04:24AM
I know you said you googled it, but did you see


they are using windows 7 and arduino version 0023 and successfully using 1284p on Sanguinololu
Re: atmega 1284p
August 19, 2012 04:49AM
Yeah i had a look at that site too dust . .they had success using the pololu usb avr programmer to burn the bootloader. .and yeah they are using wondows 7 which i dont havr the luxury of . .bummer. . .

I am trying to search for an alternative usb programmer that has the same support as the pololu . . .ive ordered some on fleabay and will have do it the way the guys at your link did . .start from scratch . .
Re: atmega 1284p
August 19, 2012 04:58AM
Why not just get the pololu avr [www.robokits.co.nz]

also I have one of these...
Re: atmega 1284p
August 19, 2012 05:24AM
Cool . .thanks dust
Re: atmega 1284p
August 19, 2012 05:45AM
Just purchased the pololu avr programmer from robokits. . .thanks again dust . .btw ive changed my x axis setupto a bowden . . .works great . . .
open | download - 20120819_213835.jpg (286.7 KB)
Re: atmega 1284p
August 19, 2012 06:09AM
You will probably have to update the firmware in the AVR.
Details on the resources tab on robokits page.

Bowden looks great
Re: atmega 1284p
August 23, 2012 04:47AM
Finally!!!after about 2 hrs of fidlin' with my settings on my mac . .i managed to upload sprinter on my 1284p sang. Board . .will try marlin and repertier tommorow . . .
Re: atmega 1284p
August 24, 2012 12:14AM
What did you have to do on your Mac to get it working?

I'm struggling with that programmer not responding too...
I'm using a sang 1.3 board with a 1284p
I have a AVR Pocket Programmer I bought from spark fun if I need to reflag a boot loader

Edited 1 time(s). Last edit at 08/24/2012 12:17AM by shippo0708.
Re: atmega 1284p
August 24, 2012 04:57AM
if you mean the pololu avr programmer, (2 steps) update cust. firmware on windows and burn a new bootloader on mac

1) windows side of things:

before you can connect your avr programmer to a mac you will need access to windows based pc ( yes....i had to install windows 7 on my mac to get the avr going) follow the pololu link on how to install the drivers and software for windows.

then i downloaded the custom firmware for mac here, and uploaded the custom firmware with terminal

if you are successfull the red LED will light up, orange LED always on..halfway there..time to boot back to mac.

2) mac side:

( arduino 0023 installed)

i updated my avr lib with avr macpack, it was 20090319 that i installed on my mac,

i played around with the azteegx1, maniacbug ,this file from github oh and i modified the avrdude.conf i was using to add the 1284p from stevesfixitshop blog. dont forget to change the fuse settings on your boards.txt (these worked for me:

Low 0xD6
High 0xDC
Ext 0xFD

burn the bootloader (avr isp v2)

board= sanguino with atmega1284p 16mhz
i used the tty.usbserial (it will show up as a dev/tty.usbserial and a dev/cu.usbserial)
then, upload the firmware.

so far i have just connected it to pronterface, i have yet to test print on it..will update as i go...
open | download - 1284p on sanguino.jpg (333.5 KB)
Re: atmega 1284p
August 24, 2012 11:24AM
No i actually meant this [www.sparkfun.com]

They said its based off the USBTinyISP so I'm not sure if its incapable of writing to a 1284p like people have said is outside its memory range, but i tried it and i was able to burn a new boot loader to it grinning smiley (it verified failed but at least i could upload Marlin to it now)
Re: atmega 1284p
August 24, 2012 06:03PM
Did you use arduino 0023 to burn the new bootloader?
Re: atmega 1284p
August 24, 2012 09:06PM
Yes, i got mine to work by using

Arduino 0023
and [www.sparkfun.com]

After i copied over the files from github i had to delete the Parallel port programmers from the avrdude.conf because i was getting errors that i have no port :/
Then i hooked up the Pocket programmer to my sanguinololu board, selected the 1284p 16mhz version in arduino and hit burn bootloader using USBTinyISP.

It took about 12-15 minutes and it said verification failed, but now i can upload sketches and firmware using the arduino IDE tongue sticking out smiley
Re: atmega 1284p
August 24, 2012 11:20PM
Yup . .those files from github was the one that workwd for me uploading sprinter firmware . .glad to hear it eventually worked for you . .
Re: atmega 1284p
April 07, 2013 08:20PM
Just to confirm what shippo0708 did. It also work for my sanguinololu 1284p as well....thanks for the info! thumbs up

Sorry, only registered users may post in this forum.

Click here to login