Re: a take on smoothie
February 01, 2013 11:10AM
i am testing the software under win7 64 bit.
i have the 01.1 software but when i run the win.install it runs but not ok end the rest will not work ok than to.

Wat do i wrong??.
Attachments:
open | download - Nieuw tekstdocument.txt (15.4 KB)
Re: a take on smoothie
February 01, 2013 11:20AM
Hi !

Do you have a .bin file in the folder ? If so, the problem is just with displaying the compilation result, but everything is fine, and you can continue.
You can also install [strawberryperl.com] and try again.

Cheers !
Re: a take on smoothie
February 01, 2013 11:51AM
build shell make clean make.
but no bin file
Attachments:
open | download - buildshell txt..txt (3.8 KB)
Re: a take on smoothie
February 01, 2013 06:45PM
Try to run buildshell in the smoothie folder . .not on thr gcc4mbed folder . .look at the video before your first post here . .i just renamed the smoothie folder to "s" just tomake it easier . .

If you run make clean anf clean under the gcc4mbed folder you will be getting the samples . .

If you run the make clean and make under the smoothie folder you will get the main.bin . .
Re: a take on smoothie
February 05, 2013 01:05PM
ok i think i have it running ok now.
in pronto face i can load a code en run it i see several led burning.
i cant see the temperature from the head and the bed.
in the config the head and bed are ok.
a test whit M105 something like that it gives ok and nothing more.

i like a little more info wat to see en wat not.
Re: a take on smoothie
February 06, 2013 03:04AM
On your set up, have you powered the vbb?

Do you have motors, heaters and thermosistors attached?

Which fets are you running the hb and hot end on?

If its just the SB that you have connected powered through usb, the temps for your hot end and hb would just register as zero (or atleast that was what i got when i tested it with just usb)
Re: a take on smoothie
February 06, 2013 06:17PM
vbb and 5 volt on power now.
the software looks to work ok see lots of leds work when i load a code.
1 motor at the m1 port fore testing.
head bed and head not posible fore now i hope soon.
the motor will not move at al with g gode running leds go on and of so it looks like the code is working.

this is the config file i hope the pins are ok.

alpha_step_pin 2.0 # Pin for alpha stepper step signal
alpha_dir_pin 0.5 # Pin for alpha stepper direction
alpha_en_pin 0.4 # Pin for alpha enable pin
alpha_current 1.5 # X stepper motor current
x_axis_max_speed 30000 # mm/min
Re: a take on smoothie
February 06, 2013 07:04PM
Have you connected limit/stop switch to where your motor is connected?

Is there any indication of your motor locking/ getting power from the vbb(i.e. can you easily turn it by hand if powered? Should have a resistance when trying to turn it by hand)

Ill check my config files and let you kbow the pin settings i have . .
Re: a take on smoothie
February 06, 2013 08:16PM
no power to the motor at all.
there is no info fore the end stops i have no id s to gound??.
Re: a take on smoothie
February 06, 2013 08:55PM
Try the smoothie site [smoothieware.org]

It has an image with color coded connections . .see if that helps
Re: a take on smoothie
February 07, 2013 09:51AM
i can reed the tempeture now in pronterface but only in the text after M105 the tempeture has no auto update.

the motor will not turn at all the problem good be the end stop`s?? in the con-fig file there is no option to set them off.
there is no diverseness in power when the 24 volt is on or off it looks like the drives ar not coming online.
Re: a take on smoothie
February 07, 2013 02:06PM
i have 3,3 volt at the step and the Dir but the enable is not coming online.

i dont understand this.
Re: a take on smoothie
February 07, 2013 06:59PM
Hi !

You will probably get more help if you come and ask on the IRC channel ( see website ).

Can I see your config file ?
Do you get the power LED ligting up when you plug your power supply in ?
Endstops can't prevent your steppers from moving at this point.

Cheers !
Re: a take on smoothie
February 07, 2013 07:11PM
led 9 and 1 are burning.
motors are not online but when i turn 1 motor led 1 gets on and the leds from q8 and q9 licht up.
when i run a g code several leds go on and of.
an with a multi meter i can get the step and dir but the enable is still 0 the step en dir are 3,3 Hy and 0 low so the work ok and the enable is constant 0

sorry fore my bad english.
and thanks fore now.
Attachments:
open | download - config.txt (7.5 KB)
Re: a take on smoothie
February 07, 2013 07:31PM
i cant upload the file firus problem my pc is clean test it.
led 9 and 1 are burning.
when i run a g code several leds burn.
when i check the voltage of the step and dir and enable the step and the dir are hy and low the enable sty low.
the con fig file is standard.

i cant find the enable setup in the code the ports are ok.

sorry fore my bad english.

and thanks fore now.
Re: a take on smoothie
February 07, 2013 07:32PM
ok this is the config file.
Attachments:
open | download - config.txt (7.5 KB)
Re: a take on smoothie
February 08, 2013 03:54PM
power led is not coming on line when the vdd is power by the 24 volt.
Re: a take on smoothie
February 10, 2013 11:20AM
ok its working.
the problem is the windows software.
i installed Linux and did the same thing and it works.
Re: a take on smoothie
February 12, 2013 08:41AM

this is my test setup.

[www.youtube.com]

Edited 1 time(s). Last edit at 02/12/2013 08:44AM by michel pet.
Re: a take on smoothie
February 12, 2013 08:34PM
Looking good!!! Are you running it of a windows or ubuntu ?
Re: a take on smoothie
February 13, 2013 06:44AM
i make the software with linux.
and i control the smootieboard under win7 with pronteface ftdi works but also usb.
with usb you have less commands no sd card and no commands like LS /SD/ .


start pronterface now plug in the usb you will see a window pop up with sd card info close this now connect whit prontefase and its online.

reset and sd card in the software is not working with me.

Edited 1 time(s). Last edit at 02/13/2013 11:50AM by michel pet.
Re: a take on smoothie
April 02, 2013 06:15AM
Its been a while, so i havent touched my SB for quite some time . .was reading a corresponding with a friend with the smoothie board scene . .

It has come a long way since last i had the time to work on the board . .everthing seems to be jiving now . .

Last weekend i tried to print something on my prusa . .but the sanguinololus power kept cutting on me in the middle of a print. .couldnt isolate the fault at that time . .so maybe time to switch to the SB and see if it fairs . .


Will update . .watch this space . .
Re: a take on smoothie
April 10, 2013 03:49PM
With a lot of help from the Smoothie software crew, and Alizier21, I am now printing up a storm with my Smoothieboard controlled printer. I had two major stumbles:
1. Homing - Solved the problem by making each homing switch two way switching between ground and V+, rather than relying on a one way switch and the pullup.
2. Bed temperature control. With a M140 S90 the bed would never quite reach the set temperature, no mater what I set it to. It would stall out one or two degrees below the set value. I used the M303 PID-autotune commands for both S0 the hotend and S1 the bed. Then added the suggested PID instructions to 'config' but the software never loaded those values. Recently there was added a M301 command to enter or edit PID values. I took the PID values from the M303 runs using Cutecom, and added two M301 lines to my G Code preamble to load those values with each print. That fixed it. Now my printer is running better than anything I previously achieved with my Sanguinololu controller. Hats off to the Smoothieboard and the Smoothie software team

John
Re: a take on smoothie
April 12, 2013 04:27AM
Good to hear that you have got everything going John. Great sense of satisfaction when you see somegthing you created work the way you want it to . . .

As you said hats of to the smoothie firmware team, and to arthur who introduced the board . . . .

I just need to get my head around on how to use the SB on a laser cutter now, a bit of a side project .
Sorry, only registered users may post in this forum.

Click here to login