Welcome! Log In Create A New Profile


endstop problems

Posted by clogs51 
endstop problems
December 02, 2014 09:15PM
I have a strange problem with the z-endstop,using mechanical switches.
When sending the m119 command.all switches show open except z min,which shows triggered.
When i press "home" in pronterface,the z axis goes UP just a fraction and stops,and will not go down.
If the endstop sw is pushed in by hand,z will go down until sw released,and go up 0.1,1,or10.
If i hold down the sw and keep it down until the z touches it,the z motor keeps going,and starts to rattle until i reset the printer.
I have tried reversing the connector on the ramps,inverting z in config,h in marlin,but nothing seems to work.
I've been right through this forum,and didn't find any reference to this particular problem.
I'm guessing it,s possibly a setting in marlin i don't know about.
Re: endstop problems
December 03, 2014 03:59AM
you have to get that z endstop to say open when not pressed and triggered when it is

just use m119 with z endstop switch not pressed, should say open
repeat use m119 with z endstop switched pressed, should say triggered.

If its reverse of what it should be but is actually changing, you need to invert z min endstop in firmware
see Z_MIN_ENDSTOP_INVERTING in configuration .h (if its true make it false and if false make it true)

if it does not change you have a fault you will need to fix it or work around it, try moving a working endstop from the xmin pins to the zmin pins and rerun tests remembering to press x endstop and watch for change in z min). If it works its just your endstop. if not its your ramps or mega (presuming you have a ramps, I cant recall)

Now move you x endstop back onto the xmin pins, before you forget
Re: endstop problems
December 04, 2014 01:17AM
Thanks for the advice,dust.It didn't make any difference tho,odd that 2 out of 4 switches could be duds.confused smiley
I've ordered a few optical switches,so i'll see how i get on with them.
It could hardly get any worse.Or could it?eye popping smiley
Re: endstop problems
December 05, 2014 02:34AM
When the "Z home" command is issued, the axis will rise, then fall again to nozzle height (as you would know already) or, if the Z axis is away from the bed, it will fall, then rise then fall again to nozzle height. What might be happening on you machine is, when the axis lifts away from the endstop, the microswitch may not be breaking - it has to break before it can drive down again. I would put a meter on the switch, click home, and see if the switch changes state when it lifts. If that's the problem then moving the switch around may help.

Waitaki 3D Printer
Re: endstop problems
December 05, 2014 05:07AM
Following on from Waitaki, the reason why the Z axis homes then lifts and homes again is so that the second homing can be done slower and therefore more accurately. The distance it lifts is customisable in firmware. If it is not lifting enough to release the switch, you should change the setting in firmware to make the lift distance higher.

If you are using Marlin look for this in configuration_adv.h:

//homing hits the endstop, then retracts by this distance, before it tries to slowly bump again:

There will probably be similar in other firmwares.

My Z home retract was originally 1mm and did not work reliably. 4mm works fine for my mech endstops.

My Prusa Mendel i2 inspired Repstrap with welded steel frame: [youtu.be]
And my Smartrap derived Briefcase 3D printer: [youtu.be]
Re: endstop problems
December 06, 2014 12:59AM
Yeah, that's a point - I forgot you can adjust that in Marlin although not in Sprinter (as far as I know)

Waitaki 3D Printer
Re: endstop problems
December 06, 2014 04:24PM
Thanks guys,I hadn't even looked in the adv.h tab.I tried printing a test cube yesterday,but still had some extruder issues.
The homing signal pointed out that the endstops don't work reliably,because both x and y axes overran the switches,e.g., the motors kept turning,with the belts rattling over the pulleys for a bit.
Perhaps I can cure this in the offsets configuration?
I seem to have a dodgy USB port on the laptop now,sometimes it doesn't want to connect.
Is it ok to run the ramps USB cable through a hub?

Edited 1 time(s). Last edit at 12/06/2014 04:25PM by clogs51.
Re: endstop problems
December 06, 2014 10:39PM
in your laptops power settings it can turn off the usb ports if they are not in use, try to turn that off.

i would suggest to take a long hard look at how the printer contacts the endstop switches, what part of the printer makes contact? does the whole switch move? does it need to be more firmly affixed to the frame? can you move the switch so that the printer makes contact with the far end of the lever? (this will mean it will take less force to actuate the switch)
have you taken a multimeter to the switch and checked that it fully opens when the switch closes?

and just for clarity when you make a change to the firmware you have to re-upload it to the arduino before it takes effect.
Re: endstop problems
January 03, 2015 02:00PM
Recheck your endstop plugs on the ramp board. From memory, they go into column positions 2,4,6 just left of a yellow plug.
Check that one of the contacts used on each switch must be C for common, and the other must be NO or NC for normally open/normally closed.
Your Z is corrected in firmware now?

I'm guessing your X and Y end stops are plugged in the wrong places. Fix labels on and take a picture for your records once you have it all correct.
Re: endstop problems
January 07, 2015 01:21AM
I have installed opto endstops now,and have them working reliably.
If what I've read online,I actually have them back to front(led is on until beam interrupted).
But as it's working fine,I'm going to leave it alone.
I was going to fit auto bed levelling too,but now that I fitted nylock nuts instead of the thumb screws,
the level has stayed constant through several prints.
I'll keep a close eye on the bed level anyway,better to be sure.
Re: endstop problems
March 09, 2015 05:38AM
I have some problem. I was put external resistor pull up 10k and it solved. I was ordered opto endstop since it's looks more stable and waiting for arrived smiling smiley
Sorry, only registered users may post in this forum.

Click here to login