Welcome! Log In Create A New Profile


1.1.0RC7 & BLTouch

Posted by DaveA 
1.1.0RC7 & BLTouch
July 28, 2016 07:00AM
Anyone else tried to build RC7 with a BlTouch probe? Built-in support for the BLTouch was added in RC7 and it seems that all you need to do is uncomment the line //#define BLTOUCH at line 456 in configuration.h.
However, if you do this the compile fails with "STOW_Z_SERVO' was not declared in this scope"

I'm trying this with a virgin configuration.h file with only the #define BLTOUCH line edited. I wanted to see if it would build before editing all my other config changes.
Re: 1.1.0RC7 & BLTouch
August 04, 2016 10:51AM
Worked for me.

// The BLTouch probe emulates a servo probe.
#define BLTOUCH

// Z Servo Probe, such as an endstop switch on a rotating arm.
#define Z_SERVO_ANGLES {10,90} // Z Servo Deploy and Stow angles

Only lines I uncommented besides this one:
#define NUM_SERVOS 3 // Servo index starts with 0 for M280 command
Re: 1.1.0RC7 & BLTouch (SOLVED)
August 05, 2016 07:01AM
Got it working myself a few days ago and forgot to come back to mark the topic solved. It was another editing error in configuration.h. When I enabled the new BLTouch define I didn't realize at the time that I needed to also update the #define NUM_SERVOS. Once I set the number of servos to >0 all went well.

Also, with BLTOUCH defined the following lines are not necessary.
#define Z_SERVO_ANGLES {10,90} // Z Servo Deploy and Stow angles

They are set in Conditionals_post.h if BLTOUCH is defined.
Re: 1.1.0RC7 & BLTouch
August 06, 2016 09:56PM
I'm still having an issue. Everything is working as expected. G28 and G29 work fine. However, after the G29 the nozzle is not dropping down far enough to print. I made a great print last night with

#define Z_PROBE_OFFSET_FROM_EXTRUDER -1.73, Now today I'm at #define Z_PROBE_OFFSET_FROM_EXTRUDER -1.90 and its still not far enough. I ended up giving up and just eliminated giving the G29. My beds actually pretty level so I can get by with just a G28 for now. Seems a waste though since everything I did to upgrade software was to use the BL Touch. Pretty frustrating. Any ideas?


Edited 1 time(s). Last edit at 08/06/2016 09:57PM by krwynn.
Re: 1.1.0RC7 & BLTouch
August 07, 2016 09:08AM
Did you do a M502 and M500 to lock in the new settings to EEPROM? Do you have a z_offset defined? (Check the numbers at the end of the reset/power up dialog)
Re: 1.1.0RC7 & BLTouch
August 07, 2016 12:03PM
Yeah I update with each change and it shows on RH after reset or power up. First thing I watch for. No z_offset defined.
Sorry, only registered users may post in this forum.

Click here to login