Z axis Not working well
May 24, 2017 10:27AM
Hi all!

I'm a little confused, I do not understand it anymore!?

My printer is now printing half-prints?
And in Repetier host when I go manually raise the Z axis,
he does then turn a little but then suddenly stops and go buzzing.
small steps goes well but if I want more rotation They turn a little piece And go buzzing

I have tried differend types of marlin.
The machine is a self DIY Prusa i3
(Has orked well?) From one(small) problem to another to this this problem???
I have exchanged 3 times the Arduino, Ramps(with all the stepsticks) and LCD
the Z rods are M5
The values in marlin for the engines
First I had 80, 80, 400, 770
Then I tried 80, 80, 2560, 500 (I had seen those values on YouTube.)
Then I tried 80, 80, 4000, 500

I have done the extruder test (100MM) and must actually the value of 500 Must be 770
but the Z axis problem I find more important

I hope it's all understandable
friendly greetings from The Netherlands!
Re: Z axis Not working well
May 26, 2017 08:24AM
For M5 rods on the Z axis you need z steps=4000

however with this high value of steps/mm you need to slow the max feedrate down a bit


#define HOMING_FEEDRATE_Z (4*60)

// @section motion

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,4000,500} // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE {300, 300, 5, 25} // (mm/sec)
#define DEFAULT_MAX_ACCELERATION {3000,3000,100,10000}

find the above section in the configuration.h and change
#define HOMING_FEEDRATE_Z (2*60)

#define DEFAULT_MAX_FEEDRATE {300, 300, 2, 25} // (mm/sec)
Re: Z axis Not working well
May 26, 2017 03:04PM
Hoi Hoi hoi hoiiii Hij doet het!!! :-)

Thank You Obewan!
Now I can finally move the Z axis up and down also with 10MM I'm so happy with that,
I also thought something was broken!
I hope I can ask another question?
Because now the whole printer goes slowly and I have put the printer on the LCD faster (speed 150/175)
Maybe I did something wrong or misunderstood.
I'll show a few pieces of my Marlin:

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 4000, 770 }

* Default Max Feed Rate (mm/s)
* Override with M203
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]] { 200, 200, 5, 25 } was het, nu is de 5 = 2 - Rob
#define DEFAULT_MAX_FEEDRATE { 200, 200, 2, 25 }

* Default Max Acceleration (change/s) change = mm/s
* (Maximum start speed for accelerated moves)
* Override with M201
* X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
#define DEFAULT_MAX_ACCELERATION { 3000, 3000, 100, 10000 }

if I remember correctly the { 200, 200, 2, 25 } Was before { 300, 300, 2, 25 } (Seen in a video from Thomas Sanladerer)
#define Z_SAFE_HOMING_X_POINT ((X_MIN_POS + X_MAX_POS) / 2) // X point for Z homing when homing all axis (G28).
#define Z_SAFE_HOMING_Y_POINT ((Y_MIN_POS + Y_MAX_POS) / 2) // Y point for Z homing when homing all axis (G28).

// Homing speeds (mm/m) was (4*60) = (2*60) Rob
#define HOMING_FEEDRATE_XY (50*60)
#define HOMING_FEEDRATE_Z (2*60)

//============================= Additional Features ===========================

Can the speed be put back a bit?
May it be possible to increase the speed again?

friendly greetings from The Netherlands!
(location Rotterdam)
Re: Z axis Not working well
May 29, 2017 04:51AM
Yes you should be ok with
#define DEFAULT_MAX_FEEDRATE { 300, 300, 2, 25 }

you could possibly change the 2 up a bit maybe 2.5 or 3 (this is the Z speed) but if you go too high then the Z motors will complain.

I have done the extruder test (100MM) and must actually the value of 500 Must be 770
What type of extruder is fitted to the printer,bowden or direct drive ?
Dont forget, you calibrate the extruder by measuring the amount of 'cold' filament pulled into the extruder, not the 'hot' coming out .
Re: Z axis Not working well
May 30, 2017 05:02AM
Thank you for your reply Obewan!
I am currently busy a bit but will get started with it.

And I wonder how is it possible that other people do the Marlin have those values?
Do they have those values that do not work with me?(On my printer)
I do not understand it...? or....? Can you tell me something?

My extruder,
In the beginning I had direct driven (Greg's Wade's Extruder)
But then built a second printer (my experimental printer) with bowden tube.
Only this one has Greg's Wade's Extruder as a drive gear.
Yes the calibration I looked at YouTube so I think that's right!

Maybe it's weird, but I've already 3D printed a lot!
But by coincidence I've never had problems with the Z as??? (so weird???)
Look what I've printed:
expirimenteer printer:
I still learn
The saying is still correct: You're never too old to learn!
in this case thanks to you!

Kind regards from the Netherlands (loc. Rotterdam)

Edited 3 time(s). Last edit at 05/30/2017 05:09AM by 3D rob.
Re: Z axis Not working well
May 30, 2017 11:48AM
Hello Obewan,

no translation/translator now!
I have tested with 3 and the Z motors were complaining and buzing!
so now on 2.5 it is okee and I start A test print forloking waht the printer wil do.
it goes/printing well!
only the infill speed is verry hi
it goes well
Only the speed
Of the fill is going (I think!) too fast!
this is because Marlin??? or in this case Cura??? The settings.

BUT!!! He is doing it very well now!
I did not must have say that...... afterwards!
Now the printer is missing a step during printing (Just looking at it) ;-)
I think the printer (the workpiece) can still be used
In other words, I have to do something about that speed (The infill speed)

he has below the center of the workpiece
6 layers shifted laid down,
And after that the printer went well again?

till so far.

Edited 5 time(s). Last edit at 05/30/2017 05:03PM by 3D rob.
Sorry, only registered users may post in this forum.

Click here to login