Extruder Strange Movement!
June 25, 2017 07:40PM
I upgraded my 3D printer to the latest Marlin firmware, while printing the first layer the extruder moves away from the print in a straight line, sometimes in the X direction and other times in Y direction and then returns to the print and resumes printing. This strange movement doesn't happen at the same location every time. There is nothing in the Gcode that commands this move, it seems related to temperature threshold somewhere in the firmware. I didn't have this issue with the old Marlin firmware. I'm using Arduino Mega with RAMPS 1.4.
Any help in solving this issue will be appreciated.

Thanks
Re: Extruder Strange Movement!
June 26, 2017 11:00AM
Might be spurious endstop triggering, try Try sending a M121 to dissable endstop testing during printing.
Re: Extruder Strange Movement!
June 26, 2017 11:05AM
I'm printing from an SD Card, printer is not connected to PC, can't send Gcode commands.
Re: Extruder Strange Movement!
June 26, 2017 05:03PM
edit the G code on the sd card and insert a M121 in the start code
Re: Extruder Strange Movement!
June 26, 2017 09:33PM
I had experienced this same symptom, took forever to diagnose.

Read these 5 posts here for more Info.

Edited 1 time(s). Last edit at 06/26/2017 09:34PM by Roberts_Clif.
Re: Extruder Strange Movement!
June 27, 2017 10:27AM
I inserted the M121 command in the gcode as shown in the attached screenshot, and tested printing, unfortunately, extruder did it again, it moved all the way to the X Min End Stop and returned and resumed printing. This movement happens quite offen, almost every layer. Still no idea what's going on confused smiley
Attachments:
open | download - Screenshot_2.png (54.3 KB)
Sorry, only registered users may post in this forum.

Click here to login