Welcome! Log In Create A New Profile


Delta/Kossel homes in wrong direction

Posted by Gunnir 
Delta/Kossel homes in wrong direction
April 28, 2018 12:30PM
Hey Everyone.

I recently inherited a Kossel Mini running some heavily outdated firmware. I decided to update it inline with the current 1.1.8 Marlin build, however, since the update the printer now homes in the opposite direction - directly for the print bed, instead of up towards the endstops. I initially suspected bad wiring of the endstops or incorrect logic in the configuration file: however, everything seems fine there. There was an inductive z-probe connected, and I wondered if, again, bad wiring or enabled auto-levelling was causing the issue: but again, with said features disabled and the probe removed, the behaviour is still erroneous. Desperate, I tried inverting the home direction. This threw up some safety errors regarding Delta printers always homing to max (not min), so I decided to come here.

So, to summarise:
  • I've tried removing and disabling the z-probe (and levelling features)
  • I've attempted to vary the endstop logic
  • I've manually changed home direction - altering #define Z_HOME_DIR does not change behaviour (still homes down)

Is there anything I've missed? I dont have the original config file I'm afraid, but I do have (and have attached) my current config file. If I'm honest, it's very similar to the current 1.1.8 release example config for Kossel's. I should mention from a hardware side: the endstops are wired into X/Y/Z+, and the probe (was) wired to Z-, which I believe is the correct pin setup?
open | download - Configuration.h (70.8 KB)
Re: Delta/Kossel homes in wrong direction
April 28, 2018 04:38PM
Hey again guys,

After much playing around I seemed to have solved it. This took me a good few hours, and to hopefully prevent anyone else losing the same time: I thought I should upload my new *functioning* configuration file and explain the changes to the original. So, here's the fix:

  • First, all the if DISABLED(ENDSTOPPULLUPS) were commented out, so I enabled them.
  • Second, set INVERT_X/Y/Z_DIR ALL to true (ignoring the comment warning that Delta printers do not invert).
  • I also had to set INVERT_E0_DIR to true, and last, Z_MIN_ENDSTOP_INVERTING to true (leaving all others false) to get the inductive proximity probe to trigger correctly.

Z_MAX will not calibrate and trigger correctly if the logic for the Z_MIN is set to TRIGGER when it is not in local influence of an E-field, and vice versa - so that's important with or without a probe attached. Alternatively, I guess you could just comment out USE_ZMIN_PLUG and ENDSTOPPULLUP_ZMIN if you don't have, or care, about a probe.

Hope that helps!
open | download - Configuration.h (70.8 KB)
Sorry, only registered users may post in this forum.

Click here to login