Welcome! Log In Create A New Profile


Issue with my Y Axis settings, could use some help!

Posted by ZackRP 
Issue with my Y Axis settings, could use some help!
May 02, 2018 12:59PM
I just recently upgraded my Monoprice Maker Select v2 to a ramps 1.4 board because my melzi fried. I have been trying to upload the firmware but I'm consistently having this issue. I'm using the newest version of marlin as well as the arduino ide, and I've got ALMOST everything working, except my Y-Axis. When I first turn on my printer and hit 'Home' the Y homes, then the X, and then the Z. And they all work perfectly fine. But then if I go to start a print, or if I hit home again for any reason (ie level the bed and then re-home) it moves the bed a small amount (like 10mm) away from the min endstop, and then it doesn't move again. Or, if the bed is homed and resting against the min end-stop, and I shut it off, and restart it and hit 'Home' it drives the bed against the min endstop for quite some time, like it's searching for the endstop it is already resting against. I know it's firmware related because I have tried moving the x axis motor connector to the y axis motor spot on the board, in which case the problem moves to the X axis, and to eliminate my cable being the issue I completely replaced it as well and continue to have the same problem. I've also replaced the stepper driver on the Y-axis, to no avail. I am at my wit's end here, and would greatly appreciate if someone with fresh eyes could take a look at my configuration.H file and figure out the issue here. I can also send my .Zip file with my entire configuration if needed. If you can help me figure this out I will worship you as a god. Thanks for any advice!
open | download - Configuration.h (64.8 KB)
Re: Issue with my Y Axis settings, could use some help!
May 03, 2018 06:42AM
From your description of problem, it looked like your min y-endstop has wiring problem. Try to fiddle with its switch and check using M119 command. Further testing should be you swap the y-endstop plug into another axis connector to isolate the problem.
Re: Issue with my Y Axis settings, could use some help!
May 03, 2018 04:05PM
Thanks for the response, I did switch connectors for the x and y axis on the board and the problem does switch to the x axis when I do that. I also tried just taking off the x and y end stops and switching them as well, but the problems remains, which is what leads me to believe it's a firmware issue as opposed to the end stop itself.
Re: Issue with my Y Axis settings, could use some help!
May 04, 2018 02:23AM

It might have to do with the board. I also running on ramps 1.4, marlin 1.1.x bugfix and didn't have any problems.

Try to modify pins_RAMPS.h, line 76. swap the number between Y_MIN_PIN and Y_MAX_PIN

#define Y_MIN_PIN          14
#define Y_MAX_PIN          15

#define Y_MIN_PIN          15
//#define Y_MAX_PIN          15

Save, flash/upload the firmware to your arduino. Move the y-endstop to the y-max port there and verify with M119 again =)

Edited 1 time(s). Last edit at 05/04/2018 02:24AM by sarf2k4.
Re: Issue with my Y Axis settings, could use some help!
May 05, 2018 06:39PM
Thanks again for the reply! I switched it, and re-uploaded the firmware but get the same result. It homes perfectly fine when I first switch on the printer, but every time after that it moves 10ish mm away from Y home, and then stops, like it thinks it's always -10mm from home after that point. Then homes the other 2 axis' fine. And no matter how many times I try to home after the first home at startup, or where the position of the bed along the y axis is, it always does that exact thing.

Also, if I try to home and it does that little +10mm shift then stops, then I go to 'Move Axis' and look at Y, it says it's at 0.00mm, as if it thinks when it homes and does that, that it is actually at home, even though the min end stop isn't triggered, and it is not actually homing.

Edited 1 time(s). Last edit at 05/05/2018 06:47PM by ZackRP.
Re: Issue with my Y Axis settings, could use some help!
May 05, 2018 08:19PM
After further experimentation it seems like the y axis just doesn't 'remember' when it's at home or not. If I try to print a small circular object it starts right how it's supposed to, and then the y axis continually moves away from min endstop until it reaches the end of the frame and starts grinding the belt, never moving back towards the min endstop, until I shut off the printer off and re-home on startup.
Re: Issue with my Y Axis settings, could use some help!
May 06, 2018 01:28AM
Have you tried the latest bugfix including the version 2.0 of marlin? I can't help but to think it might be your board is the one having issues. Also, what about your eeprom settings?
Re: Issue with my Y Axis settings, could use some help!
May 07, 2018 10:47AM
I did try the bugfix, which didn't change anything, and I've got a new board on the way, should be here tomorrow. I'm hoping that's the issue so I can just get this thing working! If not I guess I'll also replace the Arduino before going back to firmware as the issue.
Re: Issue with my Y Axis settings, could use some help!
May 09, 2018 02:47AM
Alright well new board comes in, I hook everything up, flash firmware and it homes, but then it seems like the Z axis has an issue now. The Z motors wouldn't respond to up commands at first, and would only go down towards home. Now, if I go up, they just shake like they're at the min endstop trying to go down, and if I go down, since they're already at min endstop they shake the same, only much more viciously. If I manually raise the Z axis and go down, they go down fine but still won't respond to up. There's no way I just got two bad ramps boards in a row, right? I just don't understand the issue here. When I first turned it on and homed it it moved Z up fine for just a second, before reversing direction and going down towards home. After that it has this new issue. I'm at the absolute end of my rope here. It seems like my time would be better spent researching what printer to buy next and toss this one. I'd just hate for a printer that worked just fine a couple of weeks ago to be wasted like that.

Edited 1 time(s). Last edit at 05/09/2018 02:53AM by ZackRP.
Re: Issue with my Y Axis settings, could use some help!
May 10, 2018 02:51AM
After some experimentation here's the situation. When I start the printer and home, it homes up and then down to the min endstop, just like normal. Then if I start a print the z axis doesn't move up during. The LCD screen indicates that it thinks it's moving during the print, it just physically isn't. When I use the control knob to manually move the z axis up, it does nothing. It hums, like it's trying, but doesn't move. UNLESS I put my fingers underneath it, I don't have to push, just take the slightest most inconceivable amount of pressure off of the z axis, and it move up fine. It's like the motors aren't strong enough to move it up. I got one test print to work, a 15 minute long tiny cylinder printed without issue. And then after that the z axis doesn't work again. I'm at a complete loss. If anyone at all knows a solution to this I'd love to know. I have my Z max feed rate at 0.3, I replaced the stepper driver and it doesn't change anything either.
Re: Issue with my Y Axis settings, could use some help!
May 14, 2018 06:56AM
Maybe you could try to increase the current to the steppers through the drivers' pot if you feel its a little underpowered
Re: Issue with my Y Axis settings, could use some help!
May 20, 2018 01:47PM
Hi, sorry for the late response, been busy with things and forgot to check with your issues here. You got a new board and now it hums on the z axis although it is the same if you changed the stepper driver. This usually involves with what nicknonsense stated, maybe underpowered.

What I might do for calibrating the stepper current is to rotate the potmeter while moving the axis. Be very careful though, those potmeter are infinite rotation and by tiny rotation of about 1-5' would have significant change in current supplied to the stepper motor until there are no more humming.

Get a sweet spot for the current setting by feeling the motor by hand as long as it is warm probably around 35-50'c (I think) while the motor is actively moving also carefully feel the stepper driver's heatsink (if you have) and not to get it too hot.

Another thing about adjusting the stepper current is that, once you reached the point where the motor no longer humming, you still need to do movement test for those drivers. Whether or not it will be skipping steps due to sudden movement aka high acceleration, high speed movement, the mass of the axis, your default feedrate, printing speed and etc.
Sorry, only registered users may post in this forum.

Click here to login