Welcome! Log In Create A New Profile

Advanced

Dual X carraige X2 stepper pin define

Posted by moose4621 
Dual X carraige X2 stepper pin define
July 06, 2018 08:15PM
I have just modified my P3Steel, Toolson edition, to a dual X carraige with two E3d hotends.
Using my old 1.0.1 firmware, I was able to configure the X2 stepper pins in Configuration_adv.h and everything was working.

Out of guilt for not keeping with the times, I upgraded the firmware to 1.1.x and managed to configure most of it, and even found the typo in endstops.cpp (line 444).
But, I am yet to figure out where to allocate the stepper driver pins for the X2 stepper. There is no longer an option in Configuration_adv.h and looking in pins.h, I found it at line 611 but after changing the pin allocations there, I still have no movement from the X2 stepper. ie, it will not move during the homing cycle.

I am running a 2560Mega with Ramps 1.4 and a stepper extender connected to
#define X2_ENABLE_PIN 44
#define X2_STEP_PIN 42
#define X2_DIR_PIN 40

I have attache my config files for Marlin 1.1.x

Any help would be greatly appreciated.
Attachments:
open | download - Configuration.h (64.8 KB)
open | download - Configuration_adv.h (63.4 KB)
open | download - pins.h (18.9 KB)
Re: Dual X carraige X2 stepper pin define
July 07, 2018 07:03PM
I was not able to get the X2 stepper working correctly under 1.1.x firmware but I got it moving under bugfix 1.1.x. Don't know why but there you have it.
So now my question is about the endstop offsets and how to get it to park the x carraige to the left of the build plate while X2 goes to work, and visa versa.
I have the firmware set to:
configuration.h
#define X_MIN_POS 0
#define X_MAX_POS X_BED_SIZE
 #define MANUAL_X_HOME_POS -37

configuration_adv.h
 #define X2_MIN_POS 45     // set minimum to ensure second x-carriage doesn't hit the parked first X-carriage
  #define X2_MAX_POS 259    // set maximum to the distance between toolheads when both heads are homed
  #define X2_HOME_DIR 1     // the second X-carriage always homes to the maximum endstop position
  #define X2_HOME_POS X2_MAX_POS // default home position is the maximum carriage position
  
#define DEFAULT_DUAL_X_CARRIAGE_MODE DXC_AUTO_PARK_MODE

Do I need to enable //#define NOZZLE_PARK_FEATURE?

Example configurations for dual x carraiges seem impossible to find.
Re: Dual X carraige X2 stepper pin define
July 07, 2018 08:29PM
Check this

[marlinfw.org]

Scroll down to

Dual Steppers / Dual Endstops
or
Dual X Carriage

Hope this helps.

Edited 1 time(s). Last edit at 07/07/2018 08:30PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Dual X carraige X2 stepper pin define
July 07, 2018 11:53PM
Thanks so much for your input Cliff?
I have had that page open for a couple of days and it hasn't seemed to given me the information I need, or I am reading it wrong.
Atm, when X2 is activated in the print, X moves left a little but not to home, or to the edge of the build plate either. At a glance, it seems to be moving to +45 which is coincidentally what I have set #define X2_MIN_POS 45 // set minimum to ensure second x-carriage doesn't hit the parked first X-carriage.
May not be related. but,
machine limits vs endstop locations.
July 08, 2018 04:36AM
I am trying to work out if the #define X_MIN_POS should be a negative value or not.
My machine has the end stop 37mm to the left of the build plate so the whole hotend assy is clear of the build plate.
So I have set the #define MANUAL_X_HOME_POS -37,
and so now, is the #define X_MIN_POS relative to the endstop or the new 0 at the MANUAL_X_HOME_POS -37?
ie, MANUAL_X_HOME_POS -37
Or
MANUAL_X_HOME_POS 0
?
Idle carriage will not park.
July 08, 2018 08:30AM
I am still not sure if I have the end stop offsets and manual x home settings right yet but I am getting close enough that I can print with a single carraige ok.

No matter what I do though it refuses to park the idle carriage during a dual extruder print.
I have set the default Dual Carriage mode to:
#define DEFAULT_DUAL_X_CARRIAGE_MODE DXC_AUTO_PARK_MODE

and I have even inserted
M205 S1 ; Dual X carriage auto park mode.
into the start script in S3d.

Attached are my latest config files if anyone is keen at all to solve this.

The machine is a P3steel type prusa. X Carriage 1 min end stop triggers 37mm to the left of the bed and carriage X2 or max end stop triggers 295mm to the right of carriage 1. Thats nozzle to nozzle, of course.

Ant help would be greatly appreciated.
Attachments:
open | download - Configuration.h (68.7 KB)
open | download - Configuration_adv.h (68.1 KB)
Re: machine limits vs endstop locations.
July 08, 2018 08:43AM
Quote
moose4621
My machine has the end stop 37mm to the left of the build plate so the whole hotend assy is clear of the build plate.

OK!

If I read this correctly, your X axis is 37mm off the bed to the left.

So then
#define X_MIN_POS -37 ; This will home to end-stop then move to zero position. Putting the nozzle over the bed.

READ: Configuring Marlin Bed Dimensions
[reprap.org]

Edited 3 time(s). Last edit at 07/08/2018 08:53AM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Idle carriage will not park.
July 08, 2018 05:58PM
Thanks Cliff for your help.
Setting offsets using M206 seems like the way to go. Thank you for the link.

There doesn't seem to be any mention of these settings there.
// Manually set the home position. Leave these undefined for automatic settings.
// For DELTA this is the top-center of the Cartesian print volume.
#define MANUAL_X_HOME_POS 37
#define MANUAL_Y_HOME_POS 10
//#define MANUAL_Z_HOME_POS 0
Are these settings the same as issuing an M206?

Edited 1 time(s). Last edit at 07/08/2018 06:00PM by moose4621.
Re: Idle carriage will not park.
July 08, 2018 09:14PM
I have tried M206 and M218 to set the offsets. Both pos and neg values. I get the print head moving to X63 to home, Or (X137 but in reality = X63).
I also tried
#define MANUAL_X_HOME_POS 0
#define MANUAL_Y_HOME_POS 0
Which limited my travel to withing the bed.
I am at a loss as to how this all works together.
I have included a drawing of the location of the end stops and print heads in relation to the bed.

Has anyone got a sample dual x carraige configuration that they would like to share?




Edited 5 time(s). Last edit at 07/08/2018 09:21PM by moose4621.
Attachments:
open | download - Screenshot from 2018-07-09 10-20-39.png (45.6 KB)
Re: Idle carriage will not park.
July 12, 2018 06:20AM
Finally, an answer to this mystery.smileys with beer

I found no matter what I did, both carriages would park themselves over the print bed when not in use, thus interferring with the movement of the other carriage.
I tried all sorts of combinations of end stop offsets and x_MIN aand X_MAX, nothing seemed to make sense.

So, what was the cause.
I noticed that the X axis travel speed when parking was very fast and so I slowed the DEFAULT_MAX_FEEDRATE down from 500mm/s to 300mm/s. All of a sudden the world was at peace.spinning smiley sticking its tongue out
It turns out that at 500mm/s DEFAULT_MAX_FEEDRATE, the carraiges were skipping steps at exactly the same rate every time they went to park and so were stopping short of their intended mark.
I was surprised that it was so consistent.
I had been running both of my printers at 500mm/sec as single carriage machines without issue but for what ever reason, as a dual carriage machine it missed steps.

So now, at 300mm/s all the settings do as they should and it was an easy task to get the machine configured and running as it should.

Several days lost, but a happy outcome.

Thank you to those who chimed in with suggestions, much appreciated.
Re: Idle carriage will not park.
October 01, 2018 12:17PM
I use marlin1.1.0RC6,and i want to upgrad my firmware to 1.1.8,but it doesn't work.Then i hacked my ramps1.4 to azteeg x3 pro and used the pin of azteeg x3 pro ,but it doesn't work.
Sorry, only registered users may post in this forum.

Click here to login