Welcome! Log In Create A New Profile


RepRap Full Graphic Controller SD Card Issue

Posted by tanmay 
RepRap Full Graphic Controller SD Card Issue
December 10, 2018 02:38PM
I have spent a long time trying to get SD card support working on a Full Graphic Display and RAMPS. I have tried 2 Megas, 2 RAMPS, 2 displays and 5 SD cards (All formatted multiple times). Neither of them seem to work!

I enabled SDSupport in Marlin and selected the right controller so it does work normally (the dispaly at least). I have also tried using the SD card library example to read data off the SD card, or at least to detect it. Marlin says the SD card was inserted but the menu says No SD Card. I have tried adding a delay to the code, and chaning a bunch of the speed settings and init rates. I've tried two different sets of cables, different 'smart adapters' and manually hooking up the pins to an Arduino Mega and an Uno.

I am not sure if I have been extremely unlucky and had two faulty displays, but I can't see what else I can try to check I haven't made a silly mistake.

Any suggestions are welcome smiling smiley

Thanks in advance!
Re: RepRap Full Graphic Controller SD Card Issue
December 10, 2018 05:54PM
You could try my glcd tester.... [github.com]

No setup required, so you cant get it wrong.... (so don't change anything!)

There are many possible causes

Most probable cause is your lcd cables are to long (only works with short cables)
Or you haven't formatted the sd to fat16 or fat32
Or the sdcard just does not support the required SPI protocol (newer high capacity cards often lack this) (you didnt mention brands or sizes)
Re: RepRap Full Graphic Controller SD Card Issue
December 10, 2018 08:29PM
You could try my glcd tester.... [github.com]

Thanks Dust - I Can always use testing solutions.

Computer Programmer / Electronics Technician
Re: RepRap Full Graphic Controller SD Card Issue
December 11, 2018 03:43AM
Thanks Dust, I'll try that when I get home!

I tried 512MB, 2GB and Transcend and then 8GB unnamed that came with the Anet and then 8GB and 32GB SanDisk. I have formatted them all several times using both the SD tool and the windows 10 one. Also tried partitioning to smaller drives while keeping unused space unallocated to not confuse the printer.

It could be the cables, they are currently about 30cm long, but I'm hoping that's not too short otherwise it may be hard to route to the electronics .

Thanks for making the tool, hoping it sheds some light!


Edited 1 time(s). Last edit at 12/11/2018 03:44AM by tanmay.
Re: RepRap Full Graphic Controller SD Card Issue
December 11, 2018 05:47AM
Okay - I've got some very interesting results! The first mSD card I used said initialisation failed, that the 8GB card that came with the ANET in an adapter. I then formatted it to 4GB FAT and that still didn't work. My 32GB SanDisk showed up but wouldn't read any volumes (said no FAT32/FAT16 partitions) and the same story with the rest. I then decided to open a brand new 16GB off brand chinese mSD card, stuck that in the adapter and it worked!

Just flashed Marlin and it seems to be working! I am honestly not sure what is up with my SD cards, they all seem to work fine on laptops and cameras!

Thank you so much for you help! That tool is awesome! smiling smiley

Re: RepRap Full Graphic Controller SD Card Issue
July 13, 2019 12:27PM
You seem like you have worked hard on this problem. I believe I have a similar issue. I have the MKG Gen 1.4 mainboard, Marlin 1.1.9 and a RepRapDiscount full graphic smart controller

Display detects card inserted/removed but always lists "No Card" and I am unable to load and print files from SD.

I ran the RRD-GLCD-test and it lists Initializing SD Card: FAILED. is there a way to test if its the RepRap or the SD card?

I'm using an 8GB card formatted to FAT (not FAT32) with a 2 GB partition. This card reads fine on my original Creality mainboard (but that has other issues hence the new MKS board).

I'm a CAD/designer guy and not so much a debug firmware/Ender hardware guy. I have a deadline to print some parts and would appreciate any help you can offer.



Edited 1 time(s). Last edit at 07/13/2019 12:33PM by humbuckr.
Sorry, only registered users may post in this forum.

Click here to login