Hotend fan won't activate under Marlin bugfix 1.1.x on Ultimainboard 2.1.4
February 25, 2019 09:48PM
I have an Ultimaker 2+ that I am trying to use with Marlin bugfix 1.1.x.

Everything seems to work fine except the hotend fan won't spin up after the hotend reaches and exceeds the trigger temperature.

I know the fan itself works and is hooked up correctly because I tried uploading the stock UM2+ firmware and watched it correctly spin the fan when hotend heated up.

So I think the problem has to be in how I've (mis)configured the 1.1.x firmware include files.

I have tried everything I can think of and nothing has worked so I'm hoping y'all have some different ideas on what to try.

latest Configuration.h and Configuration_adv.h attached.

I've tried commenting out this line in Configuration_adv.h, as well as the lines near it, no joy.

#define E0_AUTO_FAN_PIN -1

After digging into the schematic of the board, I've tried changing E0_AUTO_FAN_PIN from -1 to PJ6_PIN and PINJ6, still no dice.

Gotta be something simple I'm missing, I think.


Thanks...
Attachments:
open | download - Configuration.h (72.6 KB)
open | download - Configuration_adv.h (69 KB)
Sorry, only registered users may post in this forum.

Click here to login