Welcome! Log In Create A New Profile


Re-ARM + Marlin 2.0 SD card reader not working

Posted by James2858 
Re-ARM + Marlin 2.0 SD card reader not working
March 01, 2019 07:13PM
I have been using 8 bit Marlin for the last few years and finally decided to upgrade my machine to a Re-ARM, RAMPS 1.6 and Marlin 2.0. The process was pretty smooth and my printer is fully functional except for one thing - the SD card reader in my reprapdiscount full graphic smart controller isn't working with this setup. I am able to print via USB link only.

Using my old Arduino Mega and Marlin 1.9, I have been able to determine that the RRD full graphic smart controller and RAMPS 1.6 are both in perfect working condition. I also tried downloading the latest Marlin bugfix-2.0, but this did not help. I know that the problem must be with either my Re-ARM board or Marlin 2.0. Because I cant find anyone else complaining about this issue, it leads me to believe there is something wrong with my Re_ARM board.

Every time I have uploaded a new version of Marlin 2.0 to the Re-Arm I get the same exact result. The machine appears to be functioning normally and the LCD screen and LCD menu work fine. When I insert an SD card the menu options I see are "Init SD" and "NO SD card". Clicking "Init SD" changes "Init SD" to "print from SD". Clicking "print from SD" shows no files (yes, I have tried different files and different cards). Clicking the "NO SD card" option does nothing.

Other Details:
SD support was enabled in Marlin
The correct full graphics display was chosen- #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER
I have tried enabling the SD card options for "SPI speed" and "check and retry"

Please let me what other info you need. Thanks for the help!
Re: Re-ARM + Marlin 2.0 SD card reader not working
March 01, 2019 09:38PM
Are you using the custom cable to provide the lcd with 5v? (the on board 3.3v regulator on the lcd for the sdcard also need 5v)

see RRD Full Graphic Smart Display section of

Edited 1 time(s). Last edit at 03/01/2019 09:44PM by Dust.
Re: Re-ARM + Marlin 2.0 SD card reader not working
March 01, 2019 09:52PM
Yes. I followed the LCD set up guide from panucatt and bought the custom cable.
Re: Re-ARM + Marlin 2.0 SD card reader not working
March 14, 2019 08:14AM
You will need to configure this:
Re: Re-ARM + Marlin 2.0 SD card reader not working
March 14, 2019 12:49PM
Thank you. This worked to resolve the problem.

Why does this need to be modified? Most people use the SD reader in the LCD to upload print files so I don't understand why it is not set this way as default. Also, there was no mention in the Installing Marlin (Re-ARM) guide do this. This seems like a bug in Marlin that needs to be fixed.

Re: Re-ARM + Marlin 2.0 SD card reader not working
August 25, 2020 01:12PM
Marlin recently moved the settings:

//#define LPC_SD_LCD // Marlin uses the SD drive attached to the LCD
#define LPC_SD_ONBOARD // Marlin uses the SD drive on the control board

from pins_RAMPS_RE_ARM.h to configuration_adv.h:

* When using a bootloader that supports SD-Firmware-Flashing,
* add a menu item to activate SD-FW-Update on the next reboot.
* Requires ATMEGA2560 (Arduino Mega)
* Tested with this bootloader:
* [github.com]

// Add an optimized binary file transfer mode, initiated with 'M28 B1'

* Set this option to one of the following (or the board's defaults apply):
* LCD - Use the SD drive in the external LCD controller.
* ONBOARD - Use the SD drive on the control board. (No SD_DETECT_PIN. M21 to init.)
* CUSTOM_CABLE - Use a custom cable to access the SD (as defined in a pins file).

#endif // SDSUPPORT

* By default an onboard SD card reader may be shared as a USB mass-
* storage device. This option hides the SD card from the host PC.
//#define NO_SD_HOST_DRIVE // Disable SD Card access over USB (for security).

I still cannot get the SD card reader to work after following chris's basement guide for the discount smart controller: [www.youtube.com]

Got any ideas what I can enable or jump to get this working? I have been trying a bunch of trouble shooting for the past week and just started a github issue to ask for help because I am stuck. [github.com]

Edited 1 time(s). Last edit at 08/26/2020 12:44PM by Power3DPrinting.
Sorry, only registered users may post in this forum.

Click here to login